www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Stromregelung beim Zetex ZXLD1360 bricht ein


Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ich habe mir eine kleine Testschaltung mit einem ZXLD1360 von Zetex 
aufgebaut.
Es sollen einfach LED's (Stückzahl variert) angeschlossen werden.
Nur leider erreicht der "Treiber" nicht die von mir gewünschten 700mA, 
im Gegenteil, je nach Ausgangslast bricht er sogar bis auf 400mA ein!

Auslegung:
C1 4,7µF (1735545 Farnell)
Rs= 0,15 Ohm
L1: 100µH (74477120 Farnell)
D1: 10BQ100PbF von International Rectifier (1463227 Farnell)

Ich wollte mir ein kleinen Kurvenverlauf skizzieren (I=f(U)).
Der Treiber geht zwar bis ca. 680mA hoch. Wenn ich die Spannng weiter 
erhöhe fällt der Strom immer weiter ab bis irgendwann die LED's angangen 
zu flackern.
Die Kurven aus dem Datenblatt erreiche ich demnach mit einer 100µH 
leider nciht.
Nur leider wqeiß ich auch nicht wo mein Fehler sein könnte...#
Deswegen bitte ich um Hilfe!!

Gruß Micha

Autor: Raimund Rabe (corvuscorax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit was und wo genau hast Du den Strom gemessen und wie sieht der ganze 
Aufbau aus, d.h. Platine und Bestückungsdruck und insbesonder Fotos vom 
aktuellen Aufbau wären ganz nett.

Mit einem Feld-, Wald- und Wiesen-DMM wird's nichts gescheites mit der 
Strommessung. Die Taktfrequenz kann ja bis 1MHz betragen und da der 
Strom alles andere als sinusförmig sein wird geht's mit den günstigen 
DMMs schon mal gar nicht. Selbst 'echte' RMS-Schätzeisen, haben bei 
höheren Frequenzen so ihre Probleme und 1MHz schaffen nur die teuersten.

Die Auswahl der Spule ist in manchen Fällen auch kritisch - häufig wurde 
der max. Strom, bei der sie in Sättigung geht, nicht ausreichend 
berücksichtigt. In Deinem Fall scheint es aber, mit 1.53A, okay zu sein.

Die Qualität bzw. Funktion der ganzen Schaltung steht und fällt häufig 
mit dem sauberen Aufbau der Schaltung auf einer Platine. Breadboard-(aka 
Steckbrett-)Aufbauten machen nur Ärger wg. der langen Leitungen. 
Schaltregler mögen i.d.R. nur kurze Wege bei den Stromkreisen, in denen 
nennenswerte Ströme fließen.

Diese beiden Punkte sind wohl die häufigsten 'Fehler', wenn ein 
Schaltregler bei der messtechnischen Ermittlung nicht so arbeitet wie 
gewünscht.

Weiterhin hast Du nicht angegeben, wieviele (und genau welche, mit If- 
und Vf-Angabe) der LEDs Du in Reihe geschaltet hast und wie die 
Versorgungsspannung beschaffen ist, u.a. bzgl. Höhe und Qualität (z.B. 
mit einem Oszi anschauen, ob und wann sie einbricht, oszilliert, usw.).

Autor: Micha (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Nabend Raimund und erstmal danke für die Antwort!

ein Bild habe ich mit beigefügt und den Strom messe ich mit einem Fluke 
189 True RMS Multimeter.
Als Last sind wie gesagt LED's mit 3,5V und 700mA (Bsp.: Cree XP-E oder 
XR-E).
Eigentlich dachte ich, dass ich die Kurvenzüge genau wie im Datemblatt 
mit der 100µH Spule hinbekomme durch etwaige gleiche externe Beschaltung 
des 1360.
Was ich auch noch nicht so richtig verstanden habe ist, was die 
eigentliche Aufgabe der Schottkydiode ist.

Also kann man dennoch davon ausgehen, wenn ich dich richtig 
interpretiere, dass diese Schaltung bei richtiger Anordnung der Bauteile 
funtioniert.
So wie sie jetzt ist, bekomme ich durch die Taktfrequenz auf den 
"Leiterbahnen" störungen eingekoppelt.
Das Layout dann mit sehr sehr kurzen Wegen und es sollte funtionieren...

Danke, schönen Abend noch und Gruß: Micha

Autor: Zötöx (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und die Eingangsspannung wäre wie hoch?

Nebenbei:
Mit Rs=0.15E würde ich als Regler auch nicht bis
700mA arbeiten (siehe Datenblatt).
Ein bißchen knapp, meinst Du nicht auch?
Nimm doch einfach 0.1E.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Micha (Gast)

>      IMG_0050.JPG
>      1,3 MB, 0 Downloads

Lies mal was über Bildformate.

>ein Bild habe ich mit beigefügt und den Strom messe ich mit einem Fluke
>189 True RMS Multimeter.

An welcher Stelle?

>Als Last sind wie gesagt LED's mit 3,5V und 700mA (Bsp.: Cree XP-E oder
>XR-E).

LEDs.

>Eigentlich dachte ich, dass ich die Kurvenzüge genau wie im Datemblatt
>mit der 100µH Spule hinbekomme durch etwaige gleiche externe Beschaltung
>des 1360.

>Was ich auch noch nicht so richtig verstanden habe ist, was die
>eigentliche Aufgabe der Schottkydiode ist.

Das ist die Freilaufdiode für die Spule. Die leitet den Strom in der 
Ausschaltphase des MOSFETs (der im IC steckt).

>Also kann man dennoch davon ausgehen, wenn ich dich richtig
>interpretiere, dass diese Schaltung bei richtiger Anordnung der Bauteile
>funtioniert.

Wenn Zetex nicht totalen Müll baut, dann ja.

MFG
Falk

P S Oder bau einfach eine einfache, robuste [[Konstantstromquelle fuer 
Power LED]]

Autor: Arno H. (arno_h)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lies mal die Anwendungshinweise im Datenblatt, das muss auf höchstens 
einem Zehntel der Fläche untergebracht werden.
Der 4,7µF sieht aus wie 0805, ist also vermutlich Y5V-Keramik. X7R 
sollte es schon sein und möglichst dicht am IC.
Der interne FET hat bis zu 1Ohm RDSON, die Wärme muss auch irgendwo hin, 
geht mit der Adapterplatine nicht. Die viel zu langen Leitungen 
verursachen Schwingneigung und sind bei Schaltreglern ein absolutes 
NoGo.
Guck mal nach dem Aufbau der Demo- oder Evaluaion-Boards und orientiere 
dich daran. Application Notes werden von den AEs nicht aus Langeweile 
geschrieben.
Was willst du für eine Kennlinie aufnehmen?
Sobald die Spannung ausreicht, liefert der IC den Nennstrom. Es gibt nur 
einen leichten Stromanstieg mit der Speisespannung.

Arno

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten morgen zusammen und erstmal danke für Eure Antworten.

Als Kondensator habe ich ein 1206 4,7µF "X7R" (1735545 Farnell) 
eingesetzt.

Die Eingangsspannung soll nach Möglichkeit von 7V bis 30V groß sein und 
dann wie auf S.12 im Datenblatt eine fast "gerade" Stromverlauf ergeben.

Zu Tötöx: Wenn ich nen 0,1 Ohm einsetze komm ich ja laut Rechnung auf 
1A.
          Also versuche ich mit mehreren Widerständen auf genau
          0,143 Ohm zu kommen.

Da ich die Schaltung variabel gestalten möchte, d.h. nur durch 
austauchen des Rs Widerstandes will ich verschiedene Treiber (350mA, 
500mA & 700mA) realisieren.

Für die kleineren Ströme sollte doch auch die 74477820 von WE genügen
(http://katalog.we-online.de/kataloge/eisos/media/p...)

Würdet Ihr erfahrungsgemäß die gleiche Spule für die 700mA auch 
einsetzten oder besser die 74477720 wenn nicht sogar die 1245 oder 1260 
Serie mit 100µH?


Micha

Autor: Raimund Rabe (corvuscorax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Micha schrieb:
> ...
> Für die kleineren Ströme sollte doch auch die 74477820 von WE genügen
> (http://katalog.we-online.de/kataloge/eisos/media/p...)

Die ist von Ihren Daten zu sehr an der Grenze des von Dir angestrebten 
Nennstromes, bzw. sogar noch darunter und somit nicht einsetzbar. Für 
700mA LED-Strom ist sie zumindest zu klein.

> Würdet Ihr erfahrungsgemäß die gleiche Spule für die 700mA auch
> einsetzten oder besser die 74477720 wenn nicht sogar die 1245 oder 1260
> Serie mit 100µH?

Versuch besser erst einmal einen Prototypen mit 'ner gescheiten Platine 
hinzubekommen, bevor Du anfängst an der Bauteilselektion für 
verschiedene Ausbaustufen Deines Projektes zu denken. Das nur mal so als 
Tip.
Ansonsten muß das jeder selber wissen, ob er sich die verschiedenen 
Bauteile auf 'Lager' legen will oder nicht. Für alles gibt es Vor- und 
Nachteile. Da mußt Du schon selbst entscheiden. Elektrisch gesehen macht 
es keinen Unterschied. Die Version für die 700mA wird mit der gleichen 
Spule sowohl bei 500mA als auch bei 350mA funzen - mußt halt nur den Rs 
anpassen.

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann mir jmand erklären wie ich die richtige Spule auswähle welche 
Induktivität bei welchen Anforderungen bzw. Bedingungen. Ich bin da noch 
nicht so schlau geworden mit dem was ich bisher gelesen hab im 
Datenblatt etc...

Autor: Raimund Rabe (corvuscorax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Ralf:

Was genau ist Dir denn unklar?

folgende geforderte Kenndaten solltest Du basierend auf Deiner Schaltung 
wissen:
a) Induktivität L [µH]
b) Nennstrom Idc [(m)A]
c) Sättigungsstrom Isat [(m)A]
d) Schaltfrequenz

Hinzu kommen evtl. noch:
a) max. Gleichstromwiderstand Rdc [(m)Ohm] (entscheidet mit über den 
Wirkungsgrad des Reglers)
b) Bauform (Glocken-, Stab-, Topfkern, (un)vergossen, SMD/bedrahtet, 
...)
c) Kernmaterial

Anmerkung: Die Auflistung erhebt keinen Anspruch auf Vollständigkeit.

Die Schaltfrequenz und das Kernmaterial korrelieren miteinander, d.h. 
das sinnvoll einsetzbare Kernmaterial ist (mehr oder weniger) von der 
geplanten Schaltfrequenz abhängig - die Resonanzfrequnz der Spule sollte 
deshalb weit genug von der Einsatzfrequenz (sprich Schaltfrequenz der 
Anwendung) entfernt sein.

Step-Down-Regler z.B. haben einen mittleren und einen max. Strom durch 
die Spule. Der mittlere Strom sollte <= dem Nennstrom sein und der max. 
Strom <= dem Sättigungsstrom sein. Ansonsten kann die Spule (Kupfer + 
Kern) zu warm werden.

Autor: Micha (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend zusammen,

ich habe mein Layout soweit fertig.
Im Anhang habe ich ein Bild vom Schaltplan und natürlich auch das Bild 
vom Layout beigefügt.
Nur leider habe ich immernoch die gleichen Probleme...
Ich habe als RS=0.28Ohm gewählt und die Eingangsspannung ist 24V.

Bei einer Last von 3 LED's (XP-E) hab ich einen Ausgangsstrom von 360mA.
Sobald ich dann 6 LED's in Reihe hänge (6 x 3.2V typ) bricht der Strom 
ein und ich habe nur noch 260mA...
Und das auch wenn ich die Spannung erhöhe!!

An was könnte es wohl liegen... ich bin leider Ratlos!!


Gruß Micha

Autor: Michael Roek (mexman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Micha,


Du bist recht wenig konkret in Deinen Aeusserungen.

> Bei einer Last von 3 LED's (XP-E) hab ich einen Ausgangsstrom von 360mA.
> Sobald ich dann 6 LED's in Reihe hänge (6 x 3.2V typ) bricht der Strom
> ein und ich habe nur noch 260mA...
>
> Und das auch wenn ich die Spannung erhöhe!!

WIEVIEL erhoeht?

6 x 3.2V >19V.
Da koennen 24V Betriebsspannung schon knapp werden.


> Der Treiber geht zwar bis ca. 680mA hoch. Wenn ich die Spannng weiter
> erhöhe fällt der Strom immer weiter ab bis irgendwann die LED's angangen
> zu flackern.

Was ist "Irgendwann".
Dass der Eingangsstrom mit zunehmender Spannung niedriger wird liegt in 
der Natur eines Schaltreglers.


> den Strom messe ich mit einem Fluke 189 True RMS Multimeter.

Schau mal in den Daten Deines Fluke:
Da ist bei 100kHz Schluss. Reicht Dir das?


Zeig doch mal ein Oszillogramm des LED-Stroms.
Vielleicht Saettigung der Spule!

Gruss

Michael

Autor: Michael Roek (mexman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Was ich auch noch nicht so richtig verstanden habe ist, was die
> eigentliche Aufgabe der Schottkydiode ist.

Ooops..... schon schwierig, Fehler zu sichen in einer Schaltung, die man 
nicht versteht.
Bitte mal ein bischen ueber Grundlagen von Schaltnetzteilen lesen. Da 
gibt es auch herrlich Unterlagen im Netz zur Funktion und 
Dimensionierung.

Google ist dein Freund (oder Metager oder...)


Gruss

Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.