www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Hilfe! Atmega32 mag nicht mehr!


Autor: anfänger (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Gemeinde,

ich hab gestern mit meinem Avr Dragon und Avr Studio einen Atmega32 per 
ISP geflashed. Ging alles einwandfrei nach dem reset fing mein µC zu 
laufen an.

Heute morgen hab ich das ganze programm nochmals geflashed (keine 
Änderungen selbes Hexfile!) probiert.
Aus irgendwelchen Gründen stoppt mein Programmer das Programmieren 
mittendrin.
Die resetleitung hab ich mit meinem Oszi nachgeschaut, der Programmer 
zieht sie wie er soll auf Masse.
Allerdings mittendrin geht diese wieder auf high. Klingt auch plausibel, 
da Avr Studio flashen möchte, aber mittendrin aufhört und ein 
Fehlerfenster bringt.
Ich hab das mal per Screenshot festgehalten. Anhängend das bild.
Ich hoffe ihr könnt mir helfen.
Evtl. hat sich auch was verstellt.

mfg

Autor: Kay I. (imperator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du vielleicht eine andere Spannungsversorgung dran?
Wenn die instabil ist gitb es gern solche Fehler.

Autor: anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,

ich programmier übers Pollin Avr Evaboard mit nem Steckernetzteil. Wie 
gesagt, gestern hats einwandfrei funktioniert und heute nicht mehr.
Gleiches Hexfile und gleiche bedingungen.

Ich werd dem Controller mal in HV-Modus Programmieren.

Weiss jemand was ich da genau machen muss? Und wie muss ich den 
Controller ans Dragonboard anschließen?

mfg
Anfänger

Autor: Oliver Ju. (skriptkiddy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
anfänger schrieb:
> Und wie muss ich den
> Controller ans Dragonboard anschließen?
Schau mal hier rein:
http://www.google.de/url?sa=t&source=web&cd=2&ved=...

Autor: Anfänger (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Skript Kiddy schrieb:
> http://www.google.de/url?sa=t&source=web&cd=2&ved=......

der Link geht nicht. ich hab jetzt das HV Programmieren versucht!

Leider ist es dasselbe wieder!

Er geht in den Programmiermodus aber hört dann wieder auf und bringt mir 
eine Fehlermeldung!

Ich hab davon einen Screenshot gemacht!
Hängt anbei dran!

Irgendwas ist da faul an der Sache:

Ich hab 4 Controller versucht, jeder dieselbe Meldung

Meint ihr, dass evtl. mein Dragon nen Schaden hat?

Bitte helft mir, ich schmeiß noch die ganze Schei***e zum Fenster naus!

mfg
Anfänger

Autor: ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
danke das hab ich schon durchgeschaut.

Aber schaut mal bitte meine zweiten Screenshot genauer an!
Ich vermute, dass die Statusmeldung das Entscheidende ist, oder?

Mich würde interessieren, warum ich hier einen Error habe

Kann mir das keiner Erklären?
Oder ne Vermutung?

mfg

Autor: ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die sagt im Endeffekt nur, daß das flashen offenbar nicht funktioniert 
hat und der Flash immer noch leer ist (ein leerer Flash liefert 0xff 
beim lesen).

Autor: Floh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zu 90% Verkablungs- oder Versorgungsfehler. :-)

Autor: Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Okay gut. @ Floh: wie hast du das mit dem Versorgungsfehler gemeint?

Ich hab den Controller gemäß SCKT3100A3 angebaut, bzw. versucht das so 
zu machen.
Hab mir dafür ne kleine Adapterplatine gelötet. Kann sein das hier der 
Hund begraben liegt.

Meine Spannung beziehe ich über den Vcc Header und hab ihn auf den Pin2( 
VTG) vom ISP header gebrückt, stimmt das so?


mfg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.