www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit 4049B


Autor: Melvin Strobl (melle)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen

Ich hab mir als Ferien Projekt mal erlaubt einen Hochspannungsgenerator 
mit einem 4049B und einem altem Trafo aus einem Computernetzteil zu 
bauen.
Die Schaltung hab ich von der Seite 
http://homepages.internet.lu/absolute3/tronic/hs.htm
nachgebaut.

Leichter gesagt als getan. Ich hab die Platine aufgebaut (vorerst ohne 
Trafo)
doch am Ausgang des Mosfets kann ich weder eine Frequenz oder sonst eine 
Wechselspannung messen. Das der 4049 schwingt kann ich vor dem Mosfet 
feststellen. Doch die dort angezeigte Spannung ist so niedrig das der 
Mosfet nicht schaltet (0,465V max. bei einer Frequenz von ca. 7khz) und 
folglich auch keine Spannung ansteht.

Soll ich einen Transistor zwischen Gate und dem Ausgang meines ICs 
schalten?
Ist es normal das der IC so eine geringe Spannung liefert? Es liegen an 
meinem Vdd 10V an.


Danke schon mal im Voraus
Gruß Melle

Autor: nefuas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn der 4049 korrekt arbeitet, dann musst du schoene Impulse an dessen 
Ausgang haben. ich vermute,du hast die Zenerdiode falsch montiert.

Autor: Markus ---- (mrmccrash)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit was hast du die Spannung gemessen? Ein Oszi wäre in dem Fall ein 
adäquates Werkzeug.

Und wenn du den Oszillator auf kurze Impulse eingestellt hast (On-Time 
klein), dann hast du eine PWM mit z.B. 5% Duty-Cycle -> ein Multimeter 
würde nur max. 5% der Versorgungsspannung messen.

Am Mosfet wirst du auch kaum eine Spannung messen -> der schaltet gegen 
GND. Ergo müsstest du z.b. einen 10k Widerstand nach +Ub machen, damit 
du dir Impulse am Mosfet angucken kannst.

_.-=: MFG :=-._

Autor: Melvin Strobl (melle)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey gute Idee

Ich geb morgen die Platine mal meinem Vater mit. Der hat n´Oszi an der 
Arbeit. Hab bis jetzt nur mit nem Multimeter gemessen.

Danke

Autor: Melvin Strobl (melle)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@nefuas die diode hab ich mit dem Strich zur Datenleitung gelötet. Also 
richtig.

Autor: Melvin Strobl (melle)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich muss noch hinzu fügen dass ich den VDR weggelassen hab. Macht das 
was aus?

Autor: Melvin Strobl (melle)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok Schaltung funktioniert einwandfrei. Schöne Rechteck Frequenz.
Mosfet schaltet perfekt.

Danke für die Antworten

Autor: Melvin Strobl (melle)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thread wird geschlossen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.