www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Wien Brücke geht nicht


Autor: R. Freitag (rfr)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das folgende Konstrukt stellt einen Wienoszillator dar, der -im 
Gegensatz zu anderen- nicht oszilliert. Warum?

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R. Freitag schrieb:
> der -im
> Gegensatz zu anderen- nicht oszilliert

In der Realität, oder nur in der Simulation?

Kannst du den Schaltplan ggf. mal als PNG posten (lesbarer Screenshot
genügt)?

Autor: R. Freitag (rfr)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Bild im Anhang

Autor: ingo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Modell für den OPV zu "ideal" (rauschfrei?), dann schwingt er vielleicht 
nicht an?
mfG ingo

Autor: R. Freitag (rfr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es ist ein LT1007, recht reeller OPAMP...

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
R. Freitag schrieb:
> Es ist ein LT1007, recht reeller OPAMP...

Das bedeutet doch aber nicht, dass alle Aspekte dieses Opamp auch
nur annähernd reell im Modell abgebildet wären, insbesondere eben
nicht solche Dinge wie Rauschen.

Statisch schwingt ja da erstmal gar nichts, du musst schon irgendwas
einbauen, dass er anschwingt (das ist bei den meisten Oszillatoren
der Fall).

Ich hätte ja mal versucht, einen Kondensator initial zu laden oder
sowas, aber dein File bringt in der ersten und letzten Zeile Fehler,
wenn ich es laden will, und wenn man diese ignoriert, kommt der
angehängte Schwachsinn raus. ;-)

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe deine Schaltung mal abgetippt, weil das .asc ja offenbar
was völlig anderes als einen Wien-Brücken-Oszillator darstellte.
Bei mir schwingt das Teil ordentlich an, siehe Bild.

Autor: Mike Strangelove (drseltsam)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist doch der Wikipediaschaltplan dazu. Der läuft bei mir perfekt, 
nur die Frequenz ist vermutlich aufgrund parasitärer Kapazitäten immer 
ein wenig unterhalb der theoretisch berechneten.

Autor: R. Freitag (rfr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das geht bei mir nach wie vor nicht, und ich wüsste gerne, warum.
Gute N8

Robert

Autor: Helmut S. (helmuts)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Robert,

Nimm die Datei im Anhang. Wenn die bei dir nicht läuft, dann setz mal 
die SPICE-settings zurück.

Control Panel -> SPICE -> Reset to default

Helmut


Tipp: In [Misc] gibt es ein europäisches Widerstandssysmbol.

Autor: R. Freitag (rfr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe es versucht und es geht nicht.  Die Settings habe ich zurück 
gesetzt.

Bei mir zeigt dein File aber eine seltsam erscheinende 
Spannungsversorgung des OpAmps an, bist du sicher, dass das so richtig 
ist??

Gruss

Robert

Autor: R. Freitag (rfr)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nach einem Neustart geht es nun doch...
Gruss
Robert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.