www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik LatticeMico32, Probleme mit Geschwindigkeit


Autor: YTZ67 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe ein Problem mit der Geschwindigkeit des LM32, und zwar habe ich 
ein Programm in C geschrieben, in dem ein Signal abwechselnd auf high 
und low geht, also quasi ein clk-Signal erzeugt.

Die Periodendauer liegt bei etwa 1,4 µs, was ich für viel zu hoch halte, 
da die Frequenz des Prozessors auf 75 MHz eingestellt ist.
Hat jemand eine Idee wie ich die Geschwindigkeit optimieren kann?
Habe einige Tests mit den Caches durchgeführt, wodurch sich die 
Geschwindigkeit aber nur minimal verbessert hat.

Vielen Dank schon mal!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.