www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Probleme mit Verstärker aus Transistoren


Autor: Manuel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Es geht um eine Entwicklungsaufgabe bei der ich einfach nicht weiter 
komme:

Spezifikationen:
Speisespannung : 9V Batterie
Verstärkung einstellbar : ca. 0...20db (0-10)
Ausgangsspannung : Upp = ca. 5V
Lautsprecherimpedanz : R= 4/8 Ohm
Ausgangsleistung : Pmin = 0.25W à 8 Ohm

Dabei dürfen nur Transistoren, Z-Dioden, Widerstände, Kondensatoren, 
usw. verwendet werden (keine IC'c)!

Ich habe bereits die Schaltung im Bild (Link) entwickelt aber sie 
funktioniert nicht wie gewünscht!
Die A-Verstärker Stufe ist richtig ausgerechnet und verstärkt im 
Alleinbetrieb genau um 10. (Kann dann durch ein Poti eingestellt werden)
Sobald ich dann aber meine Leistungsendstufe im AB-Betrieb anhänge ist 
die Schaltung zu schwach! Das Ausgangssignal ist nur ca. 0.5 mal so 
gross wie es sein sollte.
Was mache ich falsch?? Wie kann ich die nötige Leistung erreichen??

Vielen Dank schon mal im Voraus!
lg

: Verschoben durch Admin
Autor: Peter R. (pnu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Schaltbild ist schlecht lesbar, aber:

Können die Ausgangstransistoren überhaupt den Ausgangsstrom liefern, der 
Basisstrom erscheint mir etwas gering. Die Basisvorwiderstände mal von 
1k auf 470R ändern. Oder mal anstatt Raus = 8 Ohm einen höheren Wert 
nehmen.

Autor: Manuel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Ausgangsimpedanz ist leider vorgegeben! (4/8 Ohm) Wenn ich die 
Basiswiderstände kleiner wähle, wird die Ausgangsspannung noch kleiner!
Auf diese Weise habe ich schon viele Widerstände ausgewechselt und 
getestet. Mit besseren Transistoren erziele ich auch keine bessere 
Wirkung!

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich vermute dein Arbeitspunkt bei der Endstufe ist nicht richtig 
eingestellt.
Sieh dir das mal an: http://www.elektroniktutor.de/analog/ab_verst.html

Grüße, Jens

Autor: Praktiker (kein Baumarkt) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn sich die Spannung am Kollektor vom Vorverstärker ändert, liegt 
diese Änderung auch an den beiden 1k Widerständen an.

Diese sind als parallel geschaltet zu den 430 Ohm zu betrachten, da die 
Potentiale am "kalten" Ende der 1k Widerstände konstant sind.

Also wirken am Kollektor der Vorstufe 430 Ohm parallel mit 2 x 1k also 
430 Ohm parallel mit 500 Ohm was im Ergebnis etwa 230 Ohm sind.

Bei diesem kleineren dynamischen Kollektorwiderstand ist die Verstärkung 
der Vorstufe nur noch halb so groß.

Also die Verstärkung verdoppeln.

joe

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum nimmst Du nicht einfach die klassische Komplementärendstufe mit 
Bootstrap?

http://www.elektroniktutor.de/analog/kompl.html

Hab ich früher selbst öfters aufgebaut, noch mit GE-Transistoren 
(AC178/188K).


Peter

Autor: Anselm 68 (anselm68)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In jeder Schaltung von Bipo-Endstufen die ich bisher gesehen habe, waren 
die Basen der Leistungstransistoren IMMER einzeln getrieben.
Dies liegt wohl daran dass Die Stromverstärkung mit steigendem 
Kollectorstrom sinkt, und ein stärkerer Basisstrom gebraucht wird.
Dies würde auch dein Phänomen erklären.
Weiterhin fällt mir auf, dass deine Basisvorpsannung eventuell einfach 
zu klein ist, wenn du dir mal Standard-Schaltungen ansiehst, sind in der 
Mitte zwischen den Basen oft 2 Dioden + 1 Widerstand(Trimmer) um den 
Ruhestrom einzustellen.

Gruß Anselm

Autor: Manuel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sorry dass ich mich so lange nicht gemeldet habe.

Also ich habe die Schaltung jetzt angepasst und bin der Überzeugung das 
es so funktionieren sollte!
Das Ausgangssignal stimmt so weit recht gut aber könnte noch ein wenig 
angepasst werden. Als Endstufen PNP habe ich jedoch ein BC327-25 
genommen.

Das Problem ist jetzt aber dass bei meinem Aufbau die 
Endstufentransistoren extrem heiss werden.
Es fliesst ein Gesamtstrom von ca. 750mA!!! Das kann doch nicht sein?!

Kann mir jemand helfe?

lg

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> In jeder Schaltung von Bipo-Endstufen die ich bisher gesehen habe, waren
> die Basen der Leistungstransistoren IMMER einzeln getrieben.
Leistungstransistor = BC548, BC558?  LOL  :-D

Manuel schrieb:
> Das Problem ist jetzt aber dass bei meinem Aufbau die
> Endstufentransistoren extrem heiss werden.
> Es fliesst ein Gesamtstrom von ca. 750mA!!!
Logisch, das Eine kommt vom Anderen.

> Das kann doch nicht sein?!
Warum nicht? Weil die Transistoren in der Simulation nicht heiß wurden?

Ersetze mal eine der 1N4148 durch eine Brücke. Oder gleich beide.
Oder mach Emitterwiderstände an deine Endstufentransistoren.
Oder sieh dir mal an, wie Andere das machen....

Autor: Joe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R5 und R6 mit je 1k wählen.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ersetze mal eine der 1N4148 durch eine Brücke. Oder gleich beide.

Das ist keine gute Idee, weil es dann Übernahmeverzerrungen gibt, da
die Transistoren ja erst bei 0,7 Volt Ube angesteuert werden.
Die Dioden dienen zur Erzeugung einer Basisvorspannung.

MfG Paul

Autor: Anselm 68 (anselm68)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm doch einmal BD239/240 als Endstufentransistoren.
Die können wenigstens deinen Laststrom treiben.
Deine gewählten BC-Type sind für kleine Leistungen.

BC = Kleinsignal
BD = Leistung
BF = Hochfrequenz

So hab ich es mal gelernt ;)

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul Baumann schrieb:
> Das ist keine gute Idee, weil es dann Übernahmeverzerrungen gibt, da
> die Transistoren ja erst bei 0,7 Volt Ube angesteuert werden.
Das ist mir schon bekannt. Ich wollte nur die Vorspannung mal soweit 
verringert sehen, dass die Transistoren nicht schon im Ruhezustand die 
750 mA durchlassen...
Das Thema "Übernahmeverzerrungen" kann dann (wenn nötig) nach dem Thema 
"Ruhestromeinstellung" angegangen werden. Denn was ist, wenn die Dioden 
erst bei 0,7V leiten, die Transistoren aber schon bei 0,6V?

Autor: X- Rocka (x-rocka)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na, sind wir Heizungsbauer? ;-)

Ich würde in der Vorstufe beginnen und R3 und R4 *10 nehmen.

Dann wie schon gesagt vielleicht ein Öhmchen Emittergegenkopplungs-Rs 
spendieren, und wie auch schon gesagt dickere Endstufen Transisitoren.

Aber als allererstes solltest du mal ausrechnen, wieviel Strom denn da 
am Ausgang durch die Transistoren geht.

Außerdem ist das Schreiben von 0.3k verboten!

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrob:
>Das ist mir schon bekannt.

Ich wollte Dich nicht auf den Schlips treten. Entschuldige 3-4 mal.
;-)
MfG Paul

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul Baumann schrieb:
> Ich wollte Dich nicht auf den Schlips treten. Entschuldige 3-4 mal.
Du bist hiermit 3-4 mal entschuldigt...  ;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.