www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Schaltung von mehreren LEDs mit unterschiedlicher Spannung


Autor: Alex M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

solangsam merke ich, dass mein Physik-Leistungskurs doch schon ein paar 
Jahre zurückliegt und wende mich deswegen vertrauensvoll an euch.

Für einen kleinen Home-Server habe ich vorige Woche ein 19'' Gehäuse 
erhalten. Dieses hat 9 LEDs in der Front. Diese möchte ich auch gerne 
nutzen um wichtige/interessante Informationen auszugeben.

Bei den LEDs handelt es sich um blaue (3.1V, 20mA) und rote (2.0V, 
20mA). Angeschlossen sind die LEDs über einen Pfostenstecker wobei alle 
den gleichen Minus-Pol haben.

Nun zu meinem Problem:
Die Signale mit denen die LEDs betrieben werden sollen sind recht 
unterschiedlich.
Zum einen handelt es sich um die Aktivitätsanzeigen von zwei Laufwerken. 
Diese besitzen einen dreipoligen Pfostenstecker, wobei ein PIN der 
Plus-Pol ist und die beiden anderen jeweils für eine LED genutzt werden 
(An/Aus und Aktivität). Die Spannung zwischen dem Minus und Plus ist bei 
angeschaltener LED bei 2.5V, wenn die LED aus ist bei -2.5V (also 
umgekehrt).

Die zweite Signalquelle ist ein weiterer dreipoliger Pfostenstecker. 
Hier liegt bei eingeschaltener LED eine Spannung von 1.7V zwischen den 
beiden Minus-Polen an. Wenn die LED aus ist, ist die Spannung 0V.

In der Schule hat man den Transistor als Verstärker oder Schalter 
kennengelernt. Meine Idee war nun, eine vorhandene Speisespannung (12V) 
zu verwenden und diese mit einem Transistor auf die LEDs loszulassen.

Leider fehlt mir völlig das Verständnis dafür, wie ich das ganze am 
besten nun anfange ;)

Ich würde mich sehr freuen, wenn mir jemand hierbei helfen könnte, 
solangsam vergeht mir hier der Spaß am Löten und bunten Lämpchen :-/

Vielen vielen Dank schonmal!

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> wobei ein PIN der Plus-Pol ist
> und die beiden anderen jeweils für eine LED genutzt werden
> (An/Aus und Aktivität).
> Die Spannung zwischen dem Minus und Plus
> ist bei angeschaltener LED bei 2.5V,
> wenn die LED aus ist bei -2.5V (also umgekehrt).

Dann ist dein plus nicht so plus wie du meinst sondern auch mal minus ?

Die Schaltung ist wohl anders als du denkst.

> Hier liegt bei eingeschaltener LED eine Spannung von 1.7V zwischen den
> beiden Minus-Polen an. Wenn die LED aus ist, ist die Spannung 0V.

Eine Spannung von 1,7V zwischen den beiden minus-Polen ?
Deine Minus-Pole sind wohl nicht so minus wie du gerne hättest.

> eine Spannung von 1.7V

Natürlich, das ist die Spannung der (roten) LED.
Nu zwischen welcher Spannunng schaltet der Anschluss hin- und her wenn 
keine LED dran ist ?

Vermutlich 0V und 5V (oder 0V und 3.3V).


Verbinde mal die schwarze Leitung deines Messgeräts mit Masse des 
Computers, also einer schwarzen Leitung z.B. eine 
sFestplattenstromanschluss.

Dann miss:

Den einen Kontakt der LED der Aktivitätsanzeigen eines laufwerks
bei eingesteckter LED in etrieb (Aktivität) und ohne Betreib,
denselben Anschluss noch mla messen bei ausgesteckter LED,
dasselbe mit dem andefen nAnschluss dieser LED,
dann dasselbe beim anderen Laufwerk (noch mal 4 Messungen)
dann miss deinen weiteren dreipoliger Pfostenstecker.

Jeden Pol einzeln, bei eingeschalteter LED und bei ausgeschalteter LED
und bei abgestöpselter LED im eingeschalteten und ausgeschalteten 
Zustand.

Es werden 28 Messwerte sein, die du sauber und übersichtlich 
aufschreiben solltest.

Danach kann man beurteilen, welche Spannung die geschaltete ist und auf 
welcher Seite der Vorwiderstand sitzt und welchen Wert er hat und ob man 
deine FronPanel-LED direkt anschlissen kann oder ob man eine 
Zwischenstufe braucht.

Ganz ohne diese Messungen kann man "vom schlimmsten Übel" ausgehen und 
mit Optokopplern (4N28 oder was der Händler gerade billigst da hat) 
potentialfrei schalten:

http://www.datasheetcatalog.org/datasheet/vishay/83725.pdf

Du baust die bisherige LED aus (klemmst sie ab) und klemmst an ihrer 
Stelle die LED des Optokopplers dran (nicht beide parallel betreiben).


                     +12V
                      |
------A--+  +-----B  1kOhm
         |  |         |
         V  |  +--C---+
         |  +-|<
------K--+     +--E---+
                      |
                     LED in Frontpanel
                      |
                    Masse

Dann schaltet der Transistor des Optokopplerausgangs den Strom zu deiner 
LED in der Frontplatte.

So muß man sich nicht um Potentialuntershciede kümmern, und der 
notwendige Vorwiderstand zur LED (des Optokopplers) war sowieso schon 
vorhanden.

Autor: Alex M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MaWin schrieb:
>
> Dann ist dein plus nicht so plus wie du meinst sondern auch mal minus ?
>
> Die Schaltung ist wohl anders als du denkst.
>
Naja, die Spannung invertiert sich halt (aus 2.5V wird - 2.5V). Hierbei 
ist aber wohl noch wichtig zu erwähnen, dass an dieser Stelle noch keine 
LED eingebaut ist.

> Eine Spannung von 1,7V zwischen den beiden minus-Polen ?
> Deine Minus-Pole sind wohl nicht so minus wie du gerne hättest.
>
Sorry, verschrieben, die Spannung liegt natürlich zwischen dem 
gemeinsamen Plus-Pol und dem jeweiligen Minus-Pol an.

Die Messungen werde ich gleich vornehmen und dann möglichst 
übersichtlich hier notieren.

Danke schonmal für die ausführliche Antwort!

Autor: Alex M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sodala, ich habe hier dann mal alles gemessen, was es so gab. Insgesamt 
bin ich auf 16 Messungen gekommen. Da sich die beiden 
Laufwerks-Pfostenstecker nicht unterscheiden gelten die Messungen für 
beide.
Ich hoffe, es ist übersichtlich genug ;)

Pfostenstecker Laufwerk
-----------------------------
| An/Aus | Plus | Aktivität |
-----------------------------

Die Messungen haben folgendes ergeben:
Messpunkt     | Status | Spannung gegen Minus-Pol
-------------------------------------------------
An/Aus \w LED |   1    |  2.5V
              |   0    |    0V
An/Aus o LED  |   1    |  5.5V
              |   0    |    0V
Aktivi. \w LED|   1    |  2.5V
              |   0    | -2.4V
Aktivi. o LED |   1    |  2.5V
              |   0    | -2.4V


Pfostenstecker Zwei
-----------------------------
| An/Aus | Plus | Aktivität |
-----------------------------

Hier war das Problem, dass ich die LED leider nicht entfernen kann. 
Interessant ist hier auch, dass die Spannung gegen den Minus-Pol des 
Pfostensteckers sich von der Spannung gegen das Gehäuse (wo das Netzteil 
geerdet ist) unterscheidet.
Messpunkt     | Status | Spannung gegen Minus-Pol | S gegen Gehäuse
--------------------------------------------------------------------------
An/Aus \w LED |   1    |  1.7V                    |   1.4V
              |   0    |    0V                    |     0V
Aktivi. \w LED|   1    |  1.7V                    |   1.4V
              |   0    |    0V                    |     0V

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Aktivi. \w LED|   1    |  2.5V
>               |   0    | -2.4V
> Aktivi. o LED |   1    |  2.5V
>               |   0    | -2.4V
>

Du hast hier wirklich gegen Masse gemesen ?
Und die Spannug unterscheidet sich mit und ohne LED nicht ?
Sehr merkwürdig. Ich halte es für falsch gemessen.
Auch ist die genannte Belegun
An/Aus-LED | Plus | Aktivität-LED
merkwürdig, die LEDs brauchen (wenn du richtig
gmessen hast) kein Plus, sondern Masse, könnten
also gar nicht (ohne weitere Verbindungen) an
diesem Pfostenstecker hänge,

> sich von der Spannung gegen das Gehäuse (wo das Netzteil
> geerdet ist) unterscheidet

Du solltest auch nicht das Gehäuse messen,
sondern eine (schwarze) Minusleitung z.B. der Stromzuführ.

Aber egal.

Derzeit sieht es so aus, als ob du die LEDs
An/Aus Pfostenstecker Laufwerk
An/Aus Pfostenstecker zwei
Aktivi Pfostenstecker zwei
einfach entfernen kannst, von jedem eine
Leitung zum Frontpanel legen kannst, und dort
die gewünschte LED anschliessen kann (andere
Seite ist ja schon mit Masse verbunden) ohne
weitere Zusatzteile.

Nur Aktivi. Pfostenstecker Laufwerk haut nicht hin.
Hattest du doch nicht die schwarze Leitung des
Messinstruments an einer schwarzen Masseleitung ?

> Pfostenstecker Zwei
> | An/Aus | Plus | Aktivität |
> Spannung gegen den Minus-Pol des Pfostensteckers

zumindest DIESE Pfostenstecker haben keinen Minuspol.

Du hast das Geschick, dich extrem unverständlich
auszudrücken.

Autor: Alex M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MaWin schrieb:
> Du hast das Geschick, dich extrem unverständlich
> auszudrücken.

Danke das du trotzdem versuchst mir zu helfen ;)

Also am Gehäuse ist der Stecker fürs Netzteil (12V) und dessen Minus-Pol 
ist direkt mit dem Gehäuse verbunden. Das Gehäuse ist also Minus.

Mit dem Minus-Pol gegen den ich gemessen habe meinte ich immer den, der 
zu der LED gehört.

Ich habe mich jetzt aber mal etwas mit den Optokopplern auseinander 
gesetzt (kannte ich so nicht das Bauteil) und mir folgendes überlegt:

Die für mich momentan einfachste Lösung wäre, mir zwei Quad-Optokoppler 
(PC847) zu kaufen (je 1 Euro). Von diesen dann jeweils den Eingang auf 
die Signalleitungen (die ja Minus sind) und deren Pluspol. Die LED von 
Pfostenstecker zwei ist eine SMD, die müsste ich dann entweder auslöten 
oder sonst wie eliminieren.

Dann den Ausgang der Optokoppler jeweils auf 12V + Widerstand legen und 
fertig ist das ganze, oder?

So könnte ich dann, wenn ich die Anleitung aus dem Forum 
(http://www.mikrocontroller.net/articles/Optokoppler) richtig verstanden 
habe, eventuelle weitere Signalleitungen (egal welcher Polung) auch 
direkt verwenden und ggf. invertieren.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Mit dem Minus-Pol gegen den ich gemessen habe meinte ich immer den,
> der zu der LED gehört.

Falscher Ansatz. Völlig falscher Ansatz.

Ich schrieb extra:
"Verbinde mal die schwarze Leitung deines Messgeräts mit Masse des 
Computers, also einer schwarzen Leitung z.B. eine 
Festplattenstromanschluss."

Also alles noch mal messen (und meine vorherige Antwort ignorieren, sie 
war ggf. falsch weil ihr falsche Messwerte zugrunde lagen).

War MEIN Text wirklich so unverständlich formuliert ?


> Dann den Ausgang der Optokoppler jeweils auf 12V + Widerstand legen und
> fertig ist das ganze, oder?

Ja.

> So könnte ich dann, wenn ich die Anleitung ... richtig verstanden habe, > 
eventuelle weitere Signalleitungen (egal welcher Polung) auch
> direkt verwenden und ggf. invertieren

Nein.

Die anderen Signalleitungen sind nicht zum Anschluss einer LED gedacht, 
sondern werden in ihrer Funktion durch Anschluss einer LED (des 
Optokopplers) behindert.

Autor: Alex M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit weiteren Signalleitungen meine ich welche, wo eigentlich eine LED 
hängt, also genau wie bisher ;)

Danke auf jedenfall für die Hilfe, ich denke, mit den Optokoppler 
bekomme ich das morgen zum laufen!

Autor: Alex M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, ich habe mir jetzt 2 PC847 geholt, die Schaltung funktioniert 
wunderbar. Nur die LED an der Leitung die normal mit 1.4V betrieben wird 
(Pfostenstecker Zwei) ist leider etwas dunkel, da muss ich mal noch 
raus-finden, woran das liegt. Dank dir auf jedenfall für die Erleuchtung 
(im wörtlichsten Sinn ;) )

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Nur die LED an der Leitung die normal mit 1.4V betrieben wird
> (Pfostenstecker Zwei) ist leider etwas dunkel

Wenn du die anderen LEDs dort nicht entfernt hast

> Hier war das Problem, dass ich die LED leider nicht entfernen kann.

Dann hast du gegen

"Du baust die bisherige LED aus (klemmst sie ab) und klemmst an ihrer
Stelle"

verstossen und brauchst dich nicht wundern.

Autor: Alexander M. (alexander_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die bisher vorhandenen sind weg...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.