www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik OPV als Integrator simulieren


Autor: fresh (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Also ich versuche gerade einen Integrator mit einen OPV zu simulieren 
und verwende dazu Multisim 7. Als OPV habe ich den LM324AJ im Einsatz 
mit einer Versorgungsspannung von +-12V. Am Eingang liegt ein 
Rechtecksignal mit einer Amplitude von 1 V und einer Frequenz von 50Hz 
an. Das Eingangssignal zeigt mir das Oszi perfekt an aber am Ausgang des 
OPVs habe ich immer ca 100kV. Sollte er aber am Ausgang des OPV nicht 
maximal 12 oder -12 V ausgeben? und warum ändert sich der Wert nicht 
wenn der EIngang schwingt?!

Danke im vorhinein für eure Antworten.

MFG Fresh

Autor: Michael Lenz (hochbett)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

> Also ich versuche gerade einen Integrator mit einen OPV zu simulieren
> und verwende dazu Multisim 7. Als OPV habe ich den LM324AJ im Einsatz
> mit einer Versorgungsspannung von +-12V. Am Eingang liegt ein
> Rechtecksignal mit einer Amplitude von 1 V und einer Frequenz von 50Hz
> an. Das Eingangssignal zeigt mir das Oszi perfekt an aber am Ausgang des
> OPVs habe ich immer ca 100kV. Sollte er aber am Ausgang des OPV nicht
> maximal 12 oder -12 V ausgeben?

aus den OPV-Eingängen kommt immer ein kleiner parasitärer Strom heraus. 
Möglicherweise integriert der Integrierer diesen Strom auf und kommt 
daher auf so abenteuerliche hohe Werte. Offenbar berücksichtigt das 
OPV-Modell die Spannungsversorgung nicht.

Probiere daher drei Dinge:
1. Umpolen der Spannungsversorgung; man sieht nicht, ob richtig 
angeschlossen ist.
2. Anschließen eines Widerstandes (Größenordnung 100k...1MEG) parallel 
zu den 100nF.
3. VVerkleinern des Rückkopplungskondensators; OPV treiben nicht so 
gerne kapazitive Lasten.

> und warum ändert sich der Wert nicht
> wenn der EIngang schwingt?!
Unendlich plus 1 = unendlich.

Du kannst alternativ auch LTSPice verwenden; ebenfalls kostenlos und zum 
Lernen gut geeignet.

Gruß,
  Michael

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Statwert von 0V für C1 festlegen, falls diese Simusoftware das kann.

Autor: fresh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

So habe jetzt den Wert vom Kondensator verringert und nun sieht man 
zumindest einmal das es ein Integrator ist aber  er hat weiterhin werde 
im kV bereich auch wenn ich den Widerstand parallel nehme bzw die 
Spannungsversorgung umpole. Der initalisierungswert des Kondensators ist 
auch auf 0 gesetzt. Aber woher kommt nun die hohe Spannung am Ausgang?!

Mfg fresh

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
NImm mal ein anderen OPV, bei manchen ist das Modell so schlecht, dass 
die Augangsspannung über der Versorgungsspannung liegen kann.

Autor: René F. (ren_f)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuchs mal mit LT Spice.

Autor: Yalu X. (yalu) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Mit LT-Spice und dem LM324-Modell von National funktioniert es recht
gut. Bei längere Simulationsdauer erkennt man die durch die Offset-
spannung verursachte Drift, die beim Erreichen der Ausgangsspannungs-
grenze (ca. 11V) ihr Ende findet.

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Also ich versuche gerade einen Integrator mit einen OPV zu simulieren
und verwende dazu Multisim 7.


Aaahhh.... Was soll den das ? Die diesbezueglich einzig relevante 
Groesse ist der Eingangsbias Stom. Der sagt schon alles. Den Rest der 
Simulation kannste Kuebeln.

LM324 als Integrator ... vergessen. Da muss ein Fet-OpAmp her.

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
A...aha Soooo. schrieb:
> Aaahhh.... Was soll den das ? Die diesbezueglich einzig relevante
> Groesse ist der Eingangsbias Stom.

Ich glaube nicht, dass der Biasstrom die Ursache für die fast 100kV am
Ausgang des Opamp ist ;-)

Und bevor man sich um den Biasstrom Sorgen macht, sollte man erst einmal
die Offsetspannug ins Auge fassen, die in dieser Schaltung die Hauptfeh-
lerquelle ist, zumal man den Biasstrom auch leicht durch einen zusätzli-
chen 10kΩ-Widerstand vor dem nichtinvertierenden Eingang kompensieren
kann, so dass nur noch der deutlich geringere Offsetstrom bleibt.

> LM324 als Integrator ... vergessen. Da muss ein Fet-OpAmp her.

Da es den idealen Integrierer sowieso nicht gibt (und man ihn auch nur
ganz selten wirklich braucht), wird man überlegen, ob die 2mV und 5nA
des LM324 nicht schon ausreichen. Wenn nicht, kann man natürlich zu
einem Präzisionsteil greifen, wobei auch bei diesem i.Allg. die Offset-
spannung deutlich stärker als der Offsetstrom stört, so dass es nicht
unbedingt ein FET-Typ sein musss. Ein FET-Opamp wird erst interessant,
wenn man mit deutlich mehr als 10kΩ in die Eingänge hineingeht.

@fresh:

Es scheint bei Multisim mehrere LM324-Modelle mit unterschiedlichem Ab-
straktionsgrad zu geben. Darunter gibt es welche, bei denen der Einfluss
der Versorgungsspannung nicht berücksichtigt wird. Dieser Link hilft dir
sicher weiter:

  http://forums.ni.com/t5/Circuit-Design-Suite-Multi...

Der dortige Threadstarter ist schließlich mit dem National-Modell glück-
lich geworden, als dem gleichen, das ich für die Simulation in meinem
letzten Beitrag verwendet habe. Alternativ kannst du auch das Modell von
TI nehmen, das bzgl. der Offsetspannung etwas optimistischer, bzgl. des
Output-Swings etwas pessimistischer ist.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yalu X. schrieb:
> A...aha Soooo. schrieb:
>> Aaahhh.... Was soll den das ? Die diesbezueglich einzig relevante
>> Groesse ist der Eingangsbias Stom.
>
> Ich glaube nicht, dass der Biasstrom die Ursache für die fast 100kV am
> Ausgang des Opamp ist ;-)
>

Die 100kV kommen von der Berechnung des DC-Arbeitspunktes am Beginn
der Simulation. Da reicht schon die kleinste Eingangsspannung oder 
Offsetspannung um bei einer Verstärkung von z.B. 100000 eine große 
"falsche" Ausgangsspannung zu bekommen. Allerdings hätte man da eher 
-12V oder maximal die Versorgungsspannung +12V am Ausgang erwartet. 
Eventuell ist die Berechnung des DC-Arbeitspunktes auch einfach 
fehlgeschlagen. Um dieses Problem zu umgeben, kann man diese Bestimmumg 
des Arbeitspunktes überspringen.
Dazu muss man im Simulationskommando .TRAN die Option "uic" setzen.

Autor: fresh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Erstmals danke für alle Antworten. Also eigentlich ist mir egal welcher 
OPV verwendet wird da ich dies nur als Demonstration und nicht als 
simulation einer realen Schaltung. Wenn ich aber das model eines idealen 
OPVs verwendet dann kommt einfach eine konstante Spannung raus.

Werde jetzt mal suchen wo ich das uic setzen kann und dann hoffen das es 
geht!

Mfg Fresh

Autor: fresh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Also ich habe jetzt zwar ewig gesucht und herumprobiert aber ich finde 
die Einstellung für UIC einfach nicht im Multisim. Kann mir vielleicht 
jemand sagen wo ich das finde bzw. welchen OPV Typ ich nehmen könnte mit 
den es funktioniert?!? DANKE im vorhinein!

Mfg Fresh

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Integrator ? Was soll denn integriert werden, welcher Strom, ueber 
welche Zeit ? Ein guter Anfang : der LF356.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
A...aha Soooo. schrieb:
> Ein Integrator ? Was soll denn integriert werden, welcher Strom, ueber
> welche Zeit

Lies mal den Thread, das hilft ungemein.

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
.. Wenn der Poster sich das ueberlegt hat, ist die Aufgabe eigentlich 
schon geloest.  Vorausgesetzt man hat die Integration begriffen.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
A...aha Soooo. schrieb:
> .. Wenn der Poster sich das ueberlegt hat, ist die Aufgabe eigentlich
> schon geloest.  Vorausgesetzt man hat die Integration begriffen.

Die letzte wichtige Frage war wo in Multisim die Option "uic" für .TRAN 
eingestellt werden kann. Irgendwo in den Simualationseinstellungen muss 
es so etwas wie "Skip initial operating point calculation" geben.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.