www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATmega8 Spannungsversorgung


Autor: Marcel Binder (mcb)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe folgendes Problem:
Im AVR-Tutorial (http://www.mikrocontroller.net/articles/AVR-Tutorial) 
ist bei der Spannungsversorgung für den ATmega8 ein 
Elektrolyt-Kondensator mit dem Wert 10µF angegeben (siehe Dateianhang 
oder 
http://www.mikrocontroller.net/articles/AVR-Tutori...). 
Es gibt die 10µF-Elkos aber in verschiedenen Spannungswerten wie z.B. 
25V.
Meine Frage ist nun: Welchen Spannungswert soll der Elko haben?

Danke im Voraus,
Marcel

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcel claudio Binder schrieb:
> Meine Frage ist nun: Welchen Spannungswert soll der Elko haben?

kommt auf dein spannung an, wenn du nur 9V drauf gibst recht ein 16V 
Kondensator.

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcel claudio Binder schrieb:

> Meine Frage ist nun: Welchen Spannungswert soll der Elko haben?

Soviel, dass er höher liegt, als das was über JP1 reinkommt.
Im Zweifelsfall nimmt man eher den größeren, wobei man aber auch 
sinnvoll darüber nachdenken sollte, was man denn so an JP1 für 
Spannungen erwarten darf.
Du wirst ja da keine 40Volt anlegen, denn dann hast du ganz andere 
Probleme.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da der 78L05 maximal 35V verträgt, wäre ein 35V/40V Elko nicht schlecht.

Selbst wenn auf dem 78L05 draufsteht, daß er 100mA liefern kann, kann er 
das aber nicht, wenn er mit 35V versorgt wird. Er würde zu heiss werden, 
weil er 3 Watt Verlust wegschaffen müsste. Ab 20mA ist bei so hohen 
Eingangsspannungen Schluss und man müsste zum 78M05 greifen für mehr.
Bei 9V hat aber der 78L05 keine Schwierigkeiten, die 100mA auch zu 
bringen, das wäre dann aber oft eine Batterie, bei der man die 3-4mA 
Eigenstromverbrauch den 78L05 nicht unbedngt will, ein LP2950-5 wäre da 
die bessere Wahl.

Autor: Marcel Binder (mcb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für eure schnellen Antworten.
Ich habe als Eingangsspannung 5V/ DC, so muss ich vor den ATmega8 keine 
Vorwiederstände schalten.
Ich werde dann wahrscheinlich in diesem Fall einen Elko mit 10µF/ 16V 
benutzen.

Danke,
Marcel

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcel claudio Binder schrieb:
> Hallo,
>
> danke für eure schnellen Antworten.
> Ich habe als Eingangsspannung 5V/ DC


das ist für einen 7805 sowieso zuwenig.

 >8V, je nach Quelle reichen auch 7V schon aus.

Autor: Marcel Binder (mcb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für deine Antwort.
Ich glaube ich hab in dem Schaltplan den ich im Anhang habe in EAGLE aus 
Versehen den 78L05 verwendet. Gemeint ist allerdings der 7805. Und laut 
Conrad bringt der 1A 
(http://www.conrad.de/ce/de/product/179205/SPANNUNG...).

Aber welche Spannung soll ich denn verwenden?
16V, 25V, 35V, 50V oder 63V

Danke,
Marcel

Autor: Marcel Binder (mcb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für deine Antwort.
Wie viel Volt und Ampere soll ich dann benutzen?

Danke,
Marcel

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcel claudio Binder schrieb:

> Ich glaube ich hab in dem Schaltplan den ich im Anhang habe in EAGLE aus
> Versehen den 78L05 verwendet. Gemeint ist allerdings der 7805. Und laut
> Conrad bringt der 1A
> (http://www.conrad.de/ce/de/product/179205/SPANNUNG...).

:-)
theoretisch.

Praktisch bist du meistens vorher schon lange mit der Verlustleistung am 
Limit, ehe die 1A überhaupt relevant werden.

> Aber welche Spannung soll ich denn verwenden?
> 16V, 25V, 35V, 50V oder 63V

Wie hoch ist deine Eingangsspannung?
Da es bei einem 7805 meistens eh nicht sinnvoll ist, wesentlich über 12V 
drüber zu gehen, würden 16V ausreichen. Wenn du auf Nummer sicher gehen 
willst, kannst du auch den 25V nehmen. Bei 25V Eingangsspannung und ein 
paar mA Stromverbrauch wird dir der 7805 sowieso in ein paar Sekunden 
brennheiss (ausser du kühlst ihn mit flüssigem Stickstoff), so dass es 
nicht mehr weiter tragisch ist, wenn dann bei 30V der Elko zerplatzt!

OK. Um der Wahrheit genüge zu tun: Der 7805 schaltet dann wegen 
thermischer Überlastung ab, ist also nicht defekt. Aber der Elko platzt 
weiterhin.
Brauchbar ist es aber deswegen immer noch nicht, selbst wenn der Elko 
durchhalten würde.

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcel claudio Binder schrieb:
> Hallo,
>
> danke für deine Antwort.
> Wie viel Volt und Ampere soll ich dann benutzen?

Volt: so knapp wie möglich an den 8V

Ampere: die kannst du an dieser Stelle nicht beeinflussen. Die dahinter 
liegende Schaltung zieht soviel Strom wie sie braucht.
Die Ampere sind nur deswegen interessant, weil man damit ausrechnen 
kann/muss, wie warm der 7805 werden wird, welchen Kühlkörper man nehmen 
kann.
Je mehr du auf die 7-8V an der Eingangsspannung drauf legst, umso wärmer 
wird der 7805 werden.

Autor: Marcel Binder (mcb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für eure Antworten.
Also ich habe mir jetzt folgendes überlegt:
Ich benutze ein stabilisiertes Netzteil mit 7,5V (oder 9V) für den Chip, 
ect. und ein stabilisiertes Netzteil mit 12V für den Lüfter.

Lüfter: 
http://www.pollin.de/shop/dt/MzA5OTc2OTk-/Baueleme...
Kühlkörper: 
http://www.pollin.de/shop/dt/Mjg4OTY1OTk-/Baueleme...

Der Elko hat dann einen Wert von 10µF/ 16V.
Braucht eigentlich der ATmega8 auch einen Kühlkörper.

Danke,
Marcel

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Braucht eigentlich der ATmega8 auch einen Kühlkörper.

Nein, daher frage ich mich, wozu du den Lüfter brauchst.

Aber wenn du 12V hast, spar dir die zusätzlichen 7.5/9V,
schliss den 7805 direkt an die 12V an.

Der Lüfter dürfte aber sowieso auch mit 9V laufen, so
stabil muss die Spannungsquelle also wohl gar nicht sein,
ein normales unstabilisiertes Steckernetzteil tut's schon.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du nimmst irgendeine Spannung sagen wir mal mindestens 8 Volt, max. 
~24V.
Der Kondensator braucht mind. 25V Spannungsfestigkeit oder mehr, bei 
einer hohen Eingangsspannung (<15V) besser 63V.
Die 10uF sind auch nicht so genau. Bei einem billigen Steckernetzteil 
solltest du eher 100µF nehmen.
Den Atmel direkt mit 5V betreiben geht nur, wenn du ein Labornetzteil 
mit einstellbarer Spannung und wenn möglich Strombegrenzung hast, hast 
du wahrscheinlich nicht, also brauchst du den 7805.
Dein Steckernetzteil braucht nicht so viel Strom liefern, 100mA reichen 
eigentlich, wenn du viele LEDs anschließt, brauchst du evtl. mehr.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ähm nochwas, du brauchst den 7805 nicht kühlen für die 100mA die du 
verbrauchst. Wenn du ein Ampere brauchst, ist ein Kühlkörper notwendig, 
aber KEIN LÜFTER! das ist vollkommen übertrieben, mit KK wird er 
höchstens lauwarm.

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich schrieb:
> Ähm nochwas, du brauchst den 7805 nicht kühlen für die 100mA die du
> verbrauchst. Wenn du ein Ampere brauchst, ist ein Kühlkörper notwendig,
> aber KEIN LÜFTER! das ist vollkommen übertrieben, mit KK wird er
> höchstens lauwarm.

Das kommt immer noch darauf an, mit welcher Spannung er vorne in den 
7805 reingeht. Aber diese Info ist ihm nicht zu entlocken.

Autor: Marcel Binder (mcb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

okay danke für eure Antworten. Ich glaube, dass ich einfach ein 9V 
Netzteil nehme mit Kühlkörper aber ohne Lüfter. Und der Elko hat dann 
den Wert 10µF/ 25V.

Danke,
Marcel

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcel claudio Binder schrieb:
> Hallo,
>
> okay danke für eure Antworten. Ich glaube, dass ich einfach ein 9V
> Netzteil nehme mit Kühlkörper aber ohne Lüfter. Und der Elko hat dann
> den Wert 10µF/ 25V.

Das klingt erst mal vernünftig.
Was kommt denn hinten als Verbraucher an dieses Netzteil drann? Wieviel 
Strom braucht dieser Verbraucher?

Autor: Marcel Binder (mcb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für deine Antwort.
An den PORT B des ATmega8 möchte ich 3 LEDs (je ca. 15-20mA), 2 Relais 
(von den Relais weiß ich keinen Stromverbrauch, aber ist wahrscheinlich 
sehr gering) und einen Piezo-Signalgeber (ca. 10mA bei 12V => bei 9V ca. 
7,5mA) anschließen. An den PORT D 6 Taster (mit Pullup-Wiederstand). Die 
Taster mit den Wiederständen benötigen so gut wie keinen Strom. Das 
heißt wir hätten außerhalb der eigentlichen Chip-Schaltung einen 
Stromverbrauch von höchstens ca. 100mA.

Wie viel Ampere benötigt eigentlich die Chip-Schaltung (nur ungefähr). 
Der Schaltplan ist im AVR-Tutorial unter der folgenden URL einzusehen: 
http://www.mikrocontroller.net/articles/AVR-Tutori...

Danke,
Marcel

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> von den Relais weiß ich keinen Stromverbrauch,
> aber ist wahrscheinlich sehr gering

Prust, miss doch mal nach....

Autor: Marcel Binder (mcb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für deine Antwort.
Das ist alles noch die Theoriearbeit für mein ATmega8-Projekt. 
Nachmessen kann ich leider erst wenn theoretisch alles stimmt und ich 
die Bauteile bestellt und zusammengebaut habe.

Marcel

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marcel claudio Binder schrieb:

> Wie viel Ampere benötigt eigentlich die Chip-Schaltung (nur ungefähr).

laut Datenblatt braucht ein Mega8 bei 8Mhz rund 15mA
Led + Taster machen zusammen noch mal rund 70mA

In Summe also 85mA, runden wir großzügig auf auf 100

Die größte Unbekannte ist das Relais. Entgegen deiner Annahme kann die 
Relaisspule schon ganz schön Strom ziehen.

Sagen wir mal 100mA

D.h. du hast in Summe 200mA

Am 7805 hast du bei 9V Eingangsspannung 4V Verlust.
P = U * I
  = 4 * 0.2
  = 0.8 Watt die der 7805 in Form von Wärme loswird.

Das ist für den 7805 noch gut beherschbar. Kleiner Kühlkörper schadet 
trotzdem nicht. Je weniger Strom dein Relais braucht desto besser wird 
die Bilanz.

Autor: Marcel Binder (mcb)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für deine Antwort.
Ich werde einen kleinen Kühlkörper verwenden (ca. 50x35x20 mm) aber 
keinen Lüfter. Ich habe jetzt einmal alle Schaltpläne hochgeladen. Ich 
habe vor das eigentliche Chip-Board soweit wie möglich erweiterbar 
machen (zuerst LEDs und Taster, später vielleicht einmal ein LCD oder 
7-Segment-Anzeigen). Deshalb sind auch die anderen Boards (Port_B-Board 
und Port_D-Board) seperat.

Danke,
Marcel

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Aber VCC vom ATMega solltest du schon anschließen. Freilaufdioden an den 
Relais fehlen auch.

MfG Spess

Autor: Marcel Binder (mcb)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke für deine Antwort und den Fehlerbericht.
Ich hab den Fehler jetzt ausgebessert. Weiß jemand was für einen Wert 
der 2.Widerstand (Widerstand zwischen Vorwiderstand der Basis und GND 
z.B. R2, R4, ...) bei den Transistoren in der Schaltung Port_B-Board 
haben soll. Den auf einer Seite des AVR-Tutorials wird auf die 
Leitfähigkeit der Transistoren bei einem Chip-Reset hingewiesen 
(http://www.mikrocontroller.net/articles/Basiswider...). 
Die Boards werden nicht in Verbindung mit Elektromotoren geschalten. 
Soll ich dann wahrscheinlich einen Widerstand zwischen 500K und 1M 
benutzen.

Danke,
Marcel

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.