www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 1 von 4 IC595 wird heiß


Autor: Clemens M. (clemens33)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend,

das ist mein erster Beitrag bei microcontroller.net - obwohl ich das 
Forum schon seit längerem lese - deshalb verzeiht meine Unwissenheit. ;)

Mein Problem ist folgendes:

Ich steuere vier 7-Segment LED-Anzeigen über vier 595er an.

-> Die 595er hängen jeweils gemeinsam an 3.3V und an GND.

-> Die 7-Segment Anzeigen hängen an den Ausgängen der dazugehörigen 
595er und alle gemeinsam über einen 220 Ohm Widerstand am GND. Die ICs 
sollen ja nicht mehr als 20mA bekommen.

Nun wird der erste 595 ziemlich heiß, sobald ich die Anzeige in Betrieb 
nehme. Die Darstellung der Ziffern funktioniert aber ohne Probleme. Die 
drei anderen ICs bleiben bei normaler Temperatur.

Habe ich also einen logischen Fehler in meiner Konzeption, oder liegt 
warscheinlich eher ein Lötfehler vor? Ich habe eigentlich alle Konrakte 
auf Kurzschlüsse etc. überprüft. Da die Schaltung auf einer 
Lochstreifenplatine gelötet ist, habe ich leider keinen einfachen 
schaltplan. Ein Foto liefere ich gerne nach, falls die Informationen 
nicht ausreichen.

Die SuFu habe ich benutzt. Dort wurde aber nur berichtet, dass die ICs 
Schaden nehmen, wenn man LEDs ohne Widerstand anschließt...

Vielen Dank für die Hilfe,

Clemens

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Clemens Paul (clemens33)

>-> Die 7-Segment Anzeigen hängen an den Ausgängen der dazugehörigen
>595er und alle gemeinsam über einen 220 Ohm Widerstand am GND. Die ICs
>sollen ja nicht mehr als 20mA bekommen.

Naja, man kann es auch mit der Vorsicht übertreiben. Denn so schwankt 
die Helligkeit mit der Anzahl aktiver Segmente. Schön ist was anderes.

http://www.mikrocontroller.net/articles/AVR-Tutori...

>Nun wird der erste 595 ziemlich heiß, sobald ich die Anzeige in Betrieb
>nehme.

Was ist bei dir heiß? 40°C? 80°C? Kann man den noch anfassen?

>Habe ich also einen logischen Fehler in meiner Konzeption, oder liegt
>warscheinlich eher ein Lötfehler vor?

Schwer zu sagehn ohne Schaltplan ;-)

> Ich habe eigentlich alle Konrakte
>auf Kurzschlüsse etc. überprüft. Da die Schaltung auf einer
>Lochstreifenplatine gelötet ist, habe ich leider keinen einfachen
>schaltplan.

?
Was hat das damit zu tun? Einen Schaltplan kann man IMMER zeichnen, sei 
es als Handskizze oder in einem CAD-Programm.

> Ein Foto liefere ich gerne nach, falls die Informationen
>nicht ausreichen.

Tu das, aber bitte lies vorher was über Bildformate.

>Die SuFu habe ich benutzt. Dort wurde aber nur berichtet, dass die ICs
>Schaden nehmen, wenn man LEDs ohne Widerstand anschließt...

Das ist auch so.

MfG
Falk

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Clemens Paul schrieb:
> -> Die 7-Segment Anzeigen hängen an den Ausgängen der dazugehörigen
> 595er und alle gemeinsam über einen 220 Ohm Widerstand am GND. Die ICs
> sollen ja nicht mehr als 20mA bekommen.

Siehe Falk, für jedes Segment einen Widerstand verwenden.
Hast Du ev. die eine Anzeige direkt an GND, daß der zugehörige Treiber 
warm wird?

Autor: Clemens M. (clemens33)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die beiden Antworten!

Zur Temperatur: der IC wird spürbar warm, aber nicht heiß. Das 
Lasermessgerät habe ich gerade nicht zur hand, aber es werden so etwa 45 
Grad sein.

Alle Anzeigen laufen über den Widerstand zum GND. Allerdings laufen auch 
drei der vier ICs über den Widerstand zum GND... der eine, der direkt 
mit GND verbunden ist, ist allerdings nicht der, der warm wird.

Schaltplan/Foto liefere ich morgen.

Clemens

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Clemens Paul schrieb:
> Danke für die beiden Antworten!
>
> Zur Temperatur: der IC wird spürbar warm, aber nicht heiß. Das
> Lasermessgerät habe ich gerade nicht zur hand, aber es werden so etwa 45
> Grad sein.

45 ist noch nicht wirklich heiß.
Das könnte auch ein Programmfehler sein, so dass diese eine Anzeige aus 
irgendeinem Grund länger eingeschaltet ist als die anderen.

> Alle Anzeigen laufen über den Widerstand zum GND. Allerdings laufen auch
> drei der vier ICs über den Widerstand zum GND... der eine, der direkt
> mit GND verbunden ist, ist allerdings nicht der, der warm wird.

Mit deinen Beschreibungen, wo du da jetzt welche Widerstände 
angeschlossen hast, werd ich nicht wirklich warm. Hier gilt der 
Grundsatz: Ein Bild (Schaltbild) sagt mehr als 1000 Worte. Beschreib 
nicht dein Schaltung. In derselben Zeit hättest du auch mit einem 
Bleistift eine Skizze auf Papier machen können.

Autor: Clemens M. (clemens33)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Hier ist der Schaltplan, ich hoffe, er ist aussagekräftig.
3.3V liegen an jedem IC an, habe ich der Übersichtlichkeit halber nicht 
eingezeichnet.

Clemens

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sicher? Der GND-Anschluss von 2 der 4 S/P-Register ist tatsächlich über 
den (ohnehin in dieser Form wie erwähnt sehr zweifelhaften) Widerstand 
abgetrennt?

Autor: Clemens Paul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Von >drei< der vier Register, ja. Das ließ sich auf der Streifenplatte 
einfacher machen, ist aber zu ändern. Liegt dort der Fehler?

Clemens

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja! Die GND-Anschlüsse direkt verbinden, ohne Widerstand!

Dafür einen 150..250 Ohm Widerstand in jede Zuleitung von den 595er zu 
den Anzeige-LEDs

MfG Peter

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter schrieb:
> Ja! Die GND-Anschlüsse direkt verbinden, ohne Widerstand!
>
> Dafür einen 150..250 Ohm Widerstand in jede Zuleitung von den 595er zu
> den Anzeige-LEDs
>

@TO
Und wenn dir das zuviele Widerstände sind, solltest du mal über 
Multiplexing und einen vernünftig logischen Anschluss der LED 
nachdenken.

Autor: Clemens Paul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die ICs direkt zum GND zu führen, dürfte kein Problem sein.

Aber alle LEDs über einen Widerstand zu führen, wird schwierig. Ist es 
schlecht für den IC, die LEDs zusammen über den Widerstand laufen zu 
lassen, oder macht sich das nur in Helligkeitsschwankungen bemerkbar 
(die mich bei meiner Konstruktion nicht weiter gestört haben)? Dann baue 
ich das ganze später nochmal "richtig" von vorn.

Danke,

Clemens

Autor: Clemens Paul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ kbuchegg

Oder so. Das werde ich beim nächsten Veruch wohl machen.

Clemens

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Clemens Paul (Gast)

>Aber alle LEDs über einen Widerstand zu führen, wird schwierig.

Das hat auch keiner gesagt.

> Ist es
>schlecht für den IC, die LEDs zusammen über den Widerstand laufen zu
>lassen,

JA!

>ich das ganze später nochmal "richtig" von vorn.

Tu das!

MfG
Falk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.