www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Service Unterlagen / Schaltplan Gould Biomation K450


Autor: Lukas K. (carrotindustries)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
kürzlich gelangte ich in Besitz eines Gould Biomation K450 80er-Jahre 
Logikanalysers. Dieser funktioniert auch soweit bis auf die Tatsache, 
dass beim Selbsttest bemängelt wird, dass die -5.2V (für den ganzen 
ECL-Kram) in Wirklichkeit -4.9V sind. Eine Messung bestätigte dies. Der 
Ripple der Spannung ist gering. Außerdem gibt das Netzgerät, welches von 
der ominösen Firma DATAPOWER INC. stammt, seltsame Geräusche ab. 
Womöglich steht dies im Zusammenhang zu den schwachen -5.2V. Es sei zu 
sagen, dass der -5.2V Teil des Schaltnetzteils sehr leistungsfähig zu 
sein scheint, da die -5.2V über Kabel von 4mm Durchmesser zu den 
entsprechenden Schraubklemmen geführt werden und der -5.2V Teil des 
Netzteils ohnehin nach "wumms" ausschaut. Messungen am Netzteil 
gestalten sich schwierig, da dieses sehr kompakt aufgebaut ist; es 
besteht aus 3 auf einem U-Träger aufgeschraubten Teilen, die einander 
den Weg versperren.
Auf einer orthogonal zur Hauptplatine der fraglichen Spannungsschiene 
stehenden Leiterplatte, welche einen SG3524 PWM-IC enthält befinden sich 
3 unbeschriftete Trimmer (Tek war da besser...) die, soweit es die durch 
die räumlichen Gegebenheiten eingeschränkte Sicht zulässt, mit den 
invertierenden/nichtinvertierenden Eingängen des PWM-ICs verbunden sind. 
Von einem verstellen ebendieser Trimmer würde ich es absehen, da der LA, 
wie mich der Vorbesitzer wissen ließ, das Gerät vor 7 Jahren noch 
einwandfrei funktionierte; *oder was meint ihr dazu?*
*Alles in allen wäre Natürlich ein Schaltplan/Servicehandbuch des LAs 
bzw. des Netzteils überaus hilfreich zur Fehlerbehebung*. Demnach würde 
auch der Schaltplan eines ähnlichen Modells ausreichen, da die Netzteile 
vermutlich Identisch, wenn nicht gar gleich aufgebaut sind. Ein 
Servicehandbuch für den K100 konnte ich finden, jedoch verfügt dieser 
über ein lineares Netzteil.

Kurzfassung: Hat wer ein Servicehandbuch zu dem Gould Biomation K450 
oder ähnlichen LAs (ich Vermute mal K4**)

Autor: Carsten Sch. (dg3ycs)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Serviceunterlagen wären natürlich enorm hilfreich und leider kann ich 
dir für dieses Geräte aber keine anbieten. Vlt. findet sich aber noch 
jemand.
Da sich mein Privatbestand an hochwertiger Messtechnik teilweise aber 
aus ehemals "defekten" oder "nicht mehr so zuverlässigen" Geräten 
rekrutiert, die ich dann wieder selbst auf vordermann gebracht habe, 
kristallisisert sich mit der Zeit einiges Raus...

Tatsache ist bis auf eines alle "besseren" Geräte die ich 
reparaturbedürftig bekam mindestens eine zu niedrige interne Spannung 
aufwiesen. Teilweise fehlten zusätzlich noch die eine oder Spannung oder 
es war noch ein weiterer davon unabhängiger Defekt vorhanden, aber das 
alle Spannungen stimmten hatte ich mit ausnahme eines Tek-Skopes noch 
nie.

Bei der Ursachenforschung haben sich dann fast ausnahmslos defekte Elkos 
als Ursache rausgestellt. Entweder im Netzteil selbst oder aber im Gerät 
die dafür sorgten das die Spannung belastet wird. Das geht vom zu 
geringem (realen) Gleichstromwiderstand, über einen Kurzschluss der nur 
durch die Kabel und Leiterbahnkapazitäten begrenzt wird, bis hin zum 
völligen Auslaufen mit zwerstörung von Leiterplatten und Bauteilen durch 
Korrosion.

Das Netzteil wird dadurch in jedem Betriebsmodus einer manchmal 
erheblichen mehrbelastung ausgesetzt die dann wenn die Stromaufnahme zu 
groß ist zum zusammenbrechen der Spannung führt. Wenn es dann dumm läuft 
fällt der jeweilige Spannungszug oder gar das ganze Netzteil irgendwann 
im zuge der Überlastung komplett aus.

Das fängt dann damit an das die Geräte erst eine Aufwärmzeit brauchen 
bis die (scheinbar) richtig funktionieren was vorher nicht nötig war. 
Oder das bestimmte Messfunktionen unsinnige Werte liefern oder das zum 
beispiel eine PLL nicht mehr rasten will. Irgendwann wenn die Spannung 
komplett ausfällt sind es dann massive Fehler bis zum Totalausfall

Dieses Problem haben fast alle Messgeräte sobald ein bestimmtes Alter 
erreicht ist, aber verschiedene Hersteller betrifft es unterschiedlich. 
So ist zum Beispiel bei Stabilock Funkmessplätzen,(Schlumberger/Willtek) 
insbesondere beim Modell 4031 (aber auch schon Vorgängermodelle) dieser 
Fehler so verbreitet das fast keiner dieser Messplätze heute mehr in 
Originalbestückung liegt. Komerziell ist so ein Messplatz ohne 
Neubestückung nicht mehr ehrlich zu verkaufen. Bei mir waren es zum 
Glück nur "etwas Niederohmige" SMD Becherelkos im Gerät die dann den 
+15V Zug im Netzteil zerstört haben, bei anderen haben diese die ganze 
Leiterplatte durch auslaufen zerstört. (Die im NT verbauten habe ich 
zwar vorsorglich getauscht, waren am Messgerät aber nachher alle OK, aus 
dem Gerät waren aber EINIGE defekt)
Oder momentan habe ich ein (japanisches )IWATSU SS7635 (350MHz, 4Kanal 
DRO Oszi) in Bearbeitung das bevor ich es bekommen habe lange Zeit 
eingelagert war. Hier meldete sich der FI und am Trenntrafo das Netzteil 
mit brodelnden Geräuschen. NAch öffnung des Netzteiles stellte ich hier 
fest das dort 105C Elkos von zwei unterschiedlichen Firmen verbaut 
wurden. Die Elkos des eines Herstellers waren bis auf zwei Stück ALLE 
Schadhaft, mehrere erheblich ausgelaufen. Da bin ich gerade mitten in 
der Rekonstruktion, teilweise müssen ja noch weitere wegoxidierte 
Bauteile getauscht und Leiterbahnen geflickt werden. Ein simpler R-Check 
der Versorgungsleitungen ins Gerät brachte keine auffällig niedriegen 
werte, hoffe das der Schein nicht trügt.

Worauf ich hinaus will:
Wenn die Spannung zu niedrig ist, so solltest du wenn du kein richtiges 
Servicehandbuch bekommst und ohne auf dei Fehlersuche gehen musst als 
erstes mal mit den elkos anfangen. Teilweise, je nach dem wie "wichtig" 
das Gerät für dich ist macht auch ein grundsätzlicher Totaltausch der 
Elkos im Netzteil und auf den Spannungsschienen sinn. (Bei Tausch von 
Elkos innerhalb von analogen Signalstrecken wäre ich vorsichtiger da 
dann auf jeden Fall ein Abgleich fällig ist. Zum Glück gibt es die ja im 
LA eher weniger ;-) )
Wenn du sonst keine Probleme mit dem LA hast kann man natürlich auch 
überlegen den so einfach weiterlaufen zu lassen. Allerdings mit den 
Risiko das dann - wenn denn die Spannung wirklich überlastet ist - 
irgendwann das NT komplett ausfällt oder eine Leiterbahn durchkokelt.

Leider weiß man ja auch ohne Servicehandbuch nicht sicher ob man das NT 
auch testweise im Leerlauf laufen lassen darf, bzw. welche spannung man 
wie Stark mit einem Dummy-R belasten muss damit das NT Problemlos läuft, 
keine Schäden auftreten können und die Messwerte auch eingebaut 
stimmen...
Das kann man ohne immer nur Raten/Abschätzen und hoffen das man keinen 
Bock schießt.

So, genug geschrieben

Gruß
Carsten

P.S. Die einzige Ausnahme von der Elko ursache bei Fehler 
"einzelspannung zu gering" war bei mir ein defekter Trimm-R

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Luk4s K. schrieb:
> Außerdem gibt das Netzgerät, welches von
>
> der ominösen Firma DATAPOWER INC. stammt, seltsame Geräusche ab.

Es ist ein Schaltnetzteil, AFAIR.

Du solltest die Elkos der Primär- und Sekundärseite tauschen. Das war in 
diesen Gould Geräten ein sehr beliebter Ausfallfehler.

Autor: Lukas K. (carrotindustries)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für eure Antworten,
Andrew Taylor schrieb:
> Es ist ein Schaltnetzteil, AFAIR.
treffer
dann werde ich mal das Netzgerät zerpflücken und die Elkos genauer in 
Augenschein nehmen. Für eine Grundlast ist bereits im Gerät gesorgt; 
Parallel zum den -5.2V und GND befindet sich ein 10Ohm-Lastwiderstand. 
Bei den anderen Spannungsschienen sieht es ähnlich aus.
Ich vergaß zu erwähnen, dass, als ich gestern das Netzgerät aus dem LA 
ausgebaut anschloss, die der Sicherungsautomat geflogen ist, die 
Sicherung im Netzteil selbst aber ganz blieb. Mit dem Ohmmeter messe ich 
ca. 600Ohm an der Kaltgerätebuchse, was bei 230V ca. 88W ergibt.

Autor: Lukas K. (carrotindustries)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag: Wie ich festgestellt habe, gibt es nur einen 
Gleichstromzwischenkreis für alle Schienen. Demnach ist davon 
auszugehen, dass es diesem gut geht, da sonst auch alle anderen 
Spannungen leiden würden.

Autor: Lukas K. (carrotindustries)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andrew Taylor schrieb:
> Sekundärseite tauschen
Der Fette 18000µF Elko an der -5.2V Schiene ist leer :)

Autor: Lukas K. (carrotindustries)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Luk4s K. schrieb:
> Andrew Taylor schrieb:
>> Sekundärseite tauschen
> Der Fette 18000µF Elko an der -5.2V Schiene ist leer :)
Nen 22000µ Elko eingebaut, -5.2V sind da wo sie sein solln; 80er Jahre 
Digitalparty kann beginnen :>
Die 2 Papst Lüfter von dem LA können es was die Lautstärke anbetrifft 
mit einem Fön, wenn nicht gar mit einem Staubsauger aufnehmen, da hört 
man nichtmal mehr das Tek 7834 :(
PS: Die Leistungsaufnahme beträgt ca. 420W, das erklärt das monströse 
Netzteil.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.