www.mikrocontroller.net

Forum: PC Hard- und Software Probleme mit UART-USB für Multimeter in Win7


Autor: Mike (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen!
Ich habe ein Problem mit meinem Neuerwerb, nämlich einem Multimeter, 
genauer ein PeakTech 4390 mit USB-Port. Weder an meinem XP-Rechner noch 
an meinem Win7-Rechner findet die Software das Gerät unter dem 
eingestellten Port den der UART-Kram vorgibt und auch an den anderen 
nicht. Unter Win7 kassiere ich ein "Error opening serial port", XP 
arbeitet er gar nicht an einer Suche. An einem dritten Rechner, 
ebenfalls mit Win7, wird das Teil sofort gefunden und funktioniert 
tadellos. Auf meinem Win7-Rechner wird für den Controller immer eine 
Maus als Hardware angezeigt, nicht mal die Deinstallation meiner 
Wireless-Mouse hat da bisher geholfen. (Meine beiden Rechner sind die 
einzigen die aus der Dreier-Konstellation der getesteten Rechner die 
gleiche Wireless-Mouse installiert haben). Hat jemand eine Idee wieso 
das MM nicht gescheit gefunden wird bzw der UART-Controller auf meinem 
Rechner eine andere Hardware-Verknüfung erstellt als auf dem anderen 
Rechner ? Kann man das irgendwie manuell zuweisen ?
Schonmal Danke im voraus!!

Grüße

Mike

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du Dir mal die Nummer der verwendeten seriellen Schnittstelle 
angesehen? Ist sie zufälligerweise größer als 9?

Viele Progra... äh, Softwarefrickler vergessen, daß serielle 
Schnittstellen mit zweistelligen Nummer mit einer anderen Namenssyntax 
anzusteuern sind (\\.\COM10 statt COM10), und daher scheitert deren 
Software in solchen Fällen.

Autor: Daniel B. (dbuergin)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau, im JPG steht ja unten links COM18, damit kommt wohl die SW nicht 
klar.
Zwing Windows 7 mal dazu, dass es eine COM Schnittstelle unter 10 
verwendet.

Rechte Maustaste auf "My Computer" (habe leider ein eng. Win7),
dann "Manage" dann "Device Manager" dann "COM/LPT" o.ä
Dort kannst Du Windows zwingen die COM Zuordnung zu ändern.

Damit habe ich mein Christ Elektronik Messgerät zum laufen gebracht.

Daniel

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke, das klingt schonmal schlüssig soweit. Aber wenn sich der 
UART-Controller direkt installiert hat kann ich keinen Port mehr ändern 
oder zuweisen. Geht das noch wenn ich die Installation abbreche ?
Eure Tipps passen zum Fehlerbild, an meinem XP-Rechner gehts auf COM12, 
am Win7-Rechner auf COM18 (siehe bild) und am dritten Rechner auf COM3, 
und bei letztem funktionierts. Ich probiers mal bei Gelegenheit am WE 
aus ob das klappt.

Grüße

Mike

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Super, ich danke Euch vielmals!
Manuell einen einstelligen COM-Port zugewiesen und es lief auf Anhieb 
ohne Probleme.

Grüße

Mike

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.