www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Hallsensoren Anordung herausfinden


Autor: Stefan M. (stefan_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey,

ich versuche bei einer Turbine U71MX die Anordnung der Hallsensoren 
herauszufinden. Dazu habe ich die Sensoren mit 5V Spannung versorgt und 
an die Pins des jeweiligen Sensors einen Kanal vom Oszi geklemmt.

Hall 2 und 3 wechseln sich schön ab. Also Low und High, wenn man die 
Turbine per hand dreht. Aber Hall 1 hat die ganze Zeit ein unverändertes 
Signal. Mit dem Spannungsmesser liegen dort die ganze Zeit ca 500 mv an. 
kann das denn sein?

Viele Grüße,

Stefan.

Autor: ich_eben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gibt Hal1 evtl nur ein Signal pro umdrehung?

Autor: Stefan M. (stefan_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ne, egal wieviele Runden ich drehe, der Wert ist immer der Selbe.

Autor: Hauspapa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Stefan

Habe vor 2 Jahren eine Micronel U51DX in Betrieb genommen und da ging 
das problemlos. Mit den Adernfarben kann man eigentlich nicht viel 
falsch machen.

Wer hat eigentlich für die U71MX die Steckerbelegung so 
durcheinandergewürfelt?

Autor: Stefan M. (stefan_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber ich sehe gerade, wenn ich das Oszi so einstelle, dass ich mehrere 
Perioden sehe und die Turbine drehe, sieht man die Spitzen, die 
ausschalgen, wenn der Magnet an dem Sensor vorbeizieht.

Allerdings kann ich die anderen Sensoren genauer abbilden. Also das 
Signal, welches entsteht,wenn der Magnet vor dem Sensor steht.

Das klappt bei diesem nicht. Hab auch schon die Kanäle durchgetauscht 
und die Einstellungen, oder nur diesen Sensor einzeln betrachtet....

Ich brauch das detailierte Signal im Zusammenhang mit den anderen 
Sensoren. Sonst kann ich die Position nicht bestimmen. Öffnen kann ich 
die Turbine nicht.

Hauspappa ... dann muss es wohl an meiner Messmethode liegen.

Autor: Hauspapa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist leider lange her und ich habe keinen direkten Zugriff mehr darauf. 
Kann also nicht mal schnell nachzumessen. Bei mir hat der U51DX zusammen 
mit irgendeinem Onsemi IC eine Brennstoffzelle beatmet. Hatte soweit ich 
mich erinnere die üblichen 120 Grad versetzten Pulse. Wenn ich mir die 
Datenblätter von Micronel ansehe ist überall dasselbe verbaut. Die Farbe 
der Einzeladern ist identisch und die vermerke im Datenblatt auch. 
(Spannungsbereich, Pullup,...)

Autor: Stefan M. (stefan_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit der 120° Anordnung hab ich auch gerechnet, aufgrund der Reihenfolge, 
wann ein Sensor High und Low schaltet.
Werd es auch erstmal damit versuchen.

Letzendlich war es wieder der Ehrgeiz, der den Grund für diese 
Unstimmigkeit gesucht hat. Naja, und eine gewisse Sicherheit, die man 
erst hat, wenn man alle 3 Sensoren sieht. Aber wenn du ähnliches 
behauptest wie ich vermutete, dann stimmt das vorerst g

Autor: Stefan M. (stefan_m)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier hab ich mal noch ein Bild.

Ganz oben Gelb - Hallsensor 1

Mitte Blau - Hallsensor 2

Ganz unten Lila - Hallsensor 3

Wenn ich die Turbine nun jeweils eine Position weiterdrehe, wechseln die 
Signale. Sowie bei blau, ist das Signal immer, wenn der Magnet nicht vor 
dem Sensor parkt. Und wie bei Lila, wenn der Magnet in der Nähe vom 
Hallsensor ist.

Wie man erkennen kann, ist das Signal gelb, vom Hallsensor 1 ganz anders 
als das vom Hallsensor 2 (blau). Ich hab leider keiner Erklärung dafür.

Eigentlich müssen doch alle drei mal wie ein Sinus aussehen und dann 
wieder wie bei Hallsensor 2 (blau).

Könnte er vielleicht auch schon kaputt sein?

Autor: Stefan M. (stefan_m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also das Problem wurde gefunden. Ein Steckpin in der Buchse des 
Turbinensteckers war aufgebogen. Somit hatte er keinen richtigen 
Kontakt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.