www.mikrocontroller.net

Forum: PC Hard- und Software alten PC an LCD-TV


Autor: HTPC-Freund (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,
ich habe einen recht alten Barebone (Asus Pundit, Intel Celeron 1,4Ghz, 
512MB DDR2, ATi 9100 IGP Chipsatz).

der Rechner hat keine eigenständige Grafikkarte sondern eben nur einen 
ATi 9100 IGP Chipsatz mit shared Memory, hinten raus dann VGA und DVI.

Wenn ich nun den Rechner per DVI-zu-HDMI adapter an meinen 42" LCD-TV 
anschließe, ist die Bildausgabe falsch, d.h. man sieht eine Kachel von 
den oberen linken ca. 200x200 Bildpunkten, das wiederholt sich über den 
Ganzen LCD-TV.
Den Mauszeiger sieht man dagegen unverfälscht, wenn ich zusätzlich am 
VGA noch einen kleinen Monitor anschließe, sieht man dass die Maus auch 
wirklich vom linken Bildschirmrand bis zum rechten bildschirmrand 
verfahren kann, oben und unten genau so.
Der Mauszeiger wird über den gesamten LCD-TV richtig dargestellt!

Da der Grafikchip shared Memory hat habe ich die Größe des 
Grafikspeichers mal von "auto" auf den max. Wert gestellt (64mb) - was 
für meinem HD-ready-TV (1024x768) völlig ausreichen müsste, aber auch 
hier sehe ich als Bildschirm immer nur die Kachel der ersten 200 pixel.

Der DVI-HDMI Adapter fünktioniert an anderen PCs problemlos, auch das 
Kabel kann ich als Fehlerquelle ausschließen.

Die ATI Grafiktreiber habe ich aktualisiert, wobei die neusten Treiber 
für die ATI 9100 IGP aus dem Jahr 2006 sind, aber auch damals gab es ja 
schon das Ausgabeformat 1024x768, ich denke mit den eingestellten 64MB 
Grafikspeicher dürfte die Auflösung kein Problem sein!?

Dieses vorliegende Fehlerbild, dass sich die ersten 200 Pixel immer 
wiederholen kenne ich nicht, weiß jemand an was das liegen könnte bzw. 
wo ich nach dem Problem suchen muss?

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du denn schon mal an diesem Rechner einen anderen Monitor mit DVI 
angeschlossen?

Autor: HTPC-Freund (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ne ich hab keinen anderen DVI-Monitor :-(
ich habe sonst nur noch einen VGA-Monitor.

Allerdings gehe ich bis jetzt davon aus dass die Schnittstelle OK ist, 
der Mauszeiger wird ja richtig angezeigt :-/
Aber ich muss mal schauen, vlt. kann ich ja irgendwo im Bekanntenkreis 
mal auf die schnelle einen DVI-Monitor ausleihen!?

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DVI war vor 4 Jahren noch recht frisch. Nicht alle "neuen" Treiber 
müssen unbedingt funktionieren. Manchmal reicht es den RICHTIGEN zu 
erwischen.

Notfalls andere Graka hineinstecken?

Autor: Johnny B. (johnnyb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vor ein paar Jahren hatte ich auch viel mit DVI -> HDMI vom PC zum 
Plasma TV (Samsung) gepröbelt.
Ich hatte nach vielen schlaflosen Nächten folgendes herausgefunden: Mein 
TV kann nur ein korrektes Bild anzeigen, wenn ihm per HDMI ein Bild in 
einer offiziellen HD Auflösung geschickt wird. Also konkret folgende:
1920x1080
1280x720
1024x576
853x480

Das war natürlich Kacke, da das Panel meines TV's eine Auflösung von 
1366x768 hat und mit keiner Auflösung übereinstimmt, welche er per HDMI 
verarbeiten kann.
Also blieb mir nur der Ausweg, den PC analog per VGA anzuschliessen, da 
er damit auch 1366x768 akzeptiert. Das Bild sieht jetzt zwar sehr 
ordentlich aus, aber es geht mir trotzdem auf die Nerven, dass es nicht 
gleich direkt digital geht.

Vielleicht stehst Du vor einer ähnlichen Problematik. Obwohl in Deinem 
Fall vielleicht eher die Grafikkarte Mühe hat.

Autor: HTPC-Freund (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Auflösung spielt am TV keine Rolle (soweit ich das beobachten 
konnte!)

ich habe zu Testzwecken mal nen anderen PC (auch per DVI-HDMI-Adapter) 
an den LCD-TV angeschlossen, bei dem konnte ich ohne Probleme alle 
Möglichen Auflösungen einstellen. (1650x1050, 1280x720, 1024x768, 
1440x960...)

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann wird das Problem am PC liegen. Entweder ist die Graphikhardware 
flau, oder der Treiber, oder beides.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eventuell erkennt der antike Grafiktreiber die EDID Daten nicht korrekt. 
Dann kannst du mal suchen, ob du eine inf Datei für den Fernseher 
findest, oder bastelst dir selber eine, Anleitungen dazu gibts im 
Internet.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Fehlerbild will nicht so recht zur EDID-Theorie passen.

Autor: Johnny B. (johnnyb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, nun bleiben wohl nicht mehr viel Fehlerquellen übrig.
Entweder ist der DVI-Ausgang des Motherboard defekt oder:
- Ein Firmwareupdate des BIOS vom Motherboard und/oder des Grafikteils 
des Motherboards hilft (sofern vorhanden)
- Ein Treiberupdate hilft

Autor: Johnny B. (johnnyb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://vip.asus.com/forum/view.aspx?SLanguage=en-u...

Guck Dir mal die Forenbeinträge an; es handelt sich wohl um ein weit 
verbreitetes Hardwareproblem dieses Motherboards.
Dann kannst Du wohl aufgeben weiter zu suchen, da es wahrscheinlich die 
Mühe nicht wert ist...

Autor: HTPC-Freund (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Johnny, das hast mir sehr geholfen!
ich habe natürlich sehr viel im Asus-Forum gelsen und auch über gurgel 
eine Lösung gesucht, den von Dir verlinkten Beitrag habe ich aber 
gestern nicht gefunden!

Auch wenn es nicht sehr erfreulich ist was da steht weiß ich jetzt 
wenigstens wo das Problem ist!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.