www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMega8 TWI


Autor: Marcel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich krieg noch die Krise! Seit 5 Stunden sitze ich hier und probiere rum
- ohne Erfolg.

Wer kann mir beim Auslesen eines LM75 am ATMega8 weiterhelfen?
Beiliegender Code (zusammengestellt aus dem Manual und diversen online-
Quellen) funktioniert leider nicht.

Hardware (Adressierung LM75, PullUps,... sind OK, Terminal auch.)

Vielen Dank für Eure Mühe bereits im Voraus,

Marcel

Autor: Marcel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Status: Immer noch "Hilfe!" :-)

Nach leichter Überarbeitung des Code passiert nun gelegentlich auch mal
was (PortB=LEDs) allerdings scheint die große Schleife nicht zu
funktionieren, nur nach Reset zeigen die LEDs mal unterschiedlich an,
wenn der LM 75 erwärmt wird. Woran kann das liegen?

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Atmel hat beim Sample-Code freundlicherweise die Initialisierung
weggelassen. Beispielsweise steht TWBR nach Reset auf 0, darf aber
nicht unter 10 sein.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.