www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik GSM Modem ansteuern


Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
es ist das erste mal, dass ich mit einem GSM-Modem (TC35i) hantiere. Ich 
habe das Geräte über ein Seriell-USB-Adapter an meinen PC angeschlossen 
und ein SIM-Karte eingelegt. Bei jeglichem Versuch einen AT Befehl über 
hTerm an das Gerät zu senden, sendet es ERROR zurück. Bitte um 
Hilfe...VG

Autor: LED Display (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sende mal nur "AT" (ohne anführungszeichen).

das modem sollte dann "OK" zurückgeben, dann siehst du mal ob du 
generell mit dem Modem reden kannst.

funktioniert dies, allerdings die anderen befehle nicht, so scheinst du 
die falsche syntax zu verwenden. dabei wird dir die doku bestimmt 
behilflich sein.

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch das quittiert es mit ERROR, Die LED blinkt langsam...Komisch

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ùnd welche Baudrate verwendest Du? Die nahen Verwandten dieses Modems 
dürften die Siemens-Telephone aus der C/M/S35-Reihe gewesen sein, die 
funktionierten bei 19200 Baud.

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab 115200 bps, 8 Bit, 1 Stoppbit, gerade Parität. Ich muss ja nur 
"AT" in die Zeile "ASend" des hTerm eingeben, oder? Muss ich noch was an 
"AT" anhängen?

Autor: fz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

sendest du am Ende des Befehls ein carriage return (0x0D)?

Sonst erkennt er es nicht als korrekten Befehle und nach einen Timeout 
sendet er ERROR zurück.

fz

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oje, wenn man natürlich AT einfach so eingibt und versendet, erklärt das 
einiges... 41 54 0D (Hex Type) und es funktioniert einwandfrei. Trotzdem 
Danke!

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
ich bins nochmal. Ich hab mal ein bisschen mit dem GSM-Modem+Hterm rum 
gespielt und mir ist aufgefallen, dass wenn ich eine SMS an das Modem 
Sende, mein GSM-Modem gar nicht reagiert. Sprich Hterm signalisiert mir 
nicht, das ne SMS angekommen ist. Beim Anruf erscheint im Terminal RING. 
Komisch, was mache ich nur falsch?
Grüße

Autor: Björn G. (tueftler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
soweit ich weiß werden sms nicht rückgemeldet.
Hier gibt es aber Befehle um die auf dem Gerät gespeicherten SMS 
"nazufordern"

Autor: Mirko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Klaus,
keine Ahnung ob die Frage noch aktuell ist. Allerdings kannst du mit 
Hterm auch ASCII Zeichen eingeben und versenden. Du Kannst "AT" 
eingeben. Du brauchst nicht 41 54 0D eingeben. Einfach bei Input options 
ASCII wählen und bei "Send to enter" CR anklicken. Befehle eingeben und 
ab gehts!

Autor: Jojo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich arbeite das erste mal mit einem GSM Modem (TC65) und auch das 
erste mal mit HTerm.
Bei mir wird leider gar nichts zurückgesendet, nichtmal ein Error.
Wie kann ich prüfen, ob es an dem Modem liegt oder ob ich was falsch 
machen?

Autor: Dominique Görsch (dgoersch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal andere Baudraten probiert? Ich hab schon vor Jahren mit dem Siemens 
M25 gearbeitet und ich meine das arbeitet nur bei 9600 Baud per default.

Autor: Jojo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da passiert leider auch nichts. Die LED blinkt, aber es antwortet nicht. 
Das Modem wurde schon verwendet, eine SIM Karte ist drin. Muss ich das 
vorher noch initialisieren oder so bevor es überhaupt antworten kann?

Autor: Jojo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit einer wesentlichen höheren Baudrate von 115200 hat es funktioniert!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.