www.mikrocontroller.net

Forum: FPGA, VHDL & Co. VHDL & Llatex


Autor: Fabian Z. (farb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich wollte mal fragen ob evtl. ein paar Latex Pros hier unterwegs 
sind die mir eventuell mit meinem kleinen Problem helfen können.

Das Problem ist folgendes ich schreibe grade an nem Protokoll für die 
Uni und würde gerne VHDL Code in mein Dokument einbinden. Dafür benutze 
ich lstinput, was auch für sämtliche andere programmiersprachen ganz gut 
funktioniert. Leider sehe ich grade, dass er bei VHDL aus dem "<=" 
Operator das kleiner gleich Zeichen im eingebunden Listing macht. Hat 
jemand von euch nen Plan wie man das evtl. eliminieren kann?

Meine Einstellungen sehen wie folgt aus:

\lstset{numbers=left,
    numberstyle=\tiny,
    numbersep=5pt,
    tabsize=4,
    basicstyle=\scriptsize\sffamily,
    frame=single,
    linewidth=\textwidth,
    breaklines=true,
    keywordstyle=\color{BrickRed},
    commentstyle=\color{NavyBlue},
      stringstyle=\color{OliveGreen},
      morecomment=[s][\color{blue}]{/*}{*/}
      }

Und Code binde ich ein z.B. über:

\lstinputlisting[language=VHDL, caption=DFF]{./../FIFO/DFF.vhd}

Vielen Dank im voraus!

farb

Autor: D. I. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
\verb ?

Autor: Marcus Harnisch (mharnisch) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fabian Z. schrieb:
> Leider sehe ich grade, dass er bei VHDL aus dem "<="
> Operator das kleiner gleich Zeichen im eingebunden Listing macht. Hat
> jemand von euch nen Plan wie man das evtl. eliminieren kann?

Wird irgendwo die literate option gesetzt? Siehe Manual, "5.4 Literate 
Programming"

--
Marcus

Autor: Fabian Z. (farb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Marcus vielen Dank genau das wars!

\lstset{numbers=left,
    numberstyle=\tiny,
    numbersep=5pt,
    tabsize=4,
    basicstyle=\scriptsize\sffamily,
    frame=single,
    linewidth=\textwidth,
    breaklines=true,
    keywordstyle=\color{BrickRed},
    commentstyle=\color{NavyBlue},
    stringstyle=\color{OliveGreen},
    morecomment=[s][\color{blue}]{/*}{*/},
    literate=
    }

hat Abhilfe geschaffen, scheint wohl irgendeinen default zu geben! ;)

Autor: M. P. (annexe)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
literate= {<}{{\textless}}1

So wäre es noch etwas korrekter mit Argument, falls mal Fehlermeldungen 
auftauchen sollten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.