www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Unterspannungsschutzschaltung auf 12V anpassen


Autor: Lipomensch (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

jemand hat hier mal das PDF im Anhang gepostet. Diesen 
Unterspannungsschutz würde ich gerne so anpassen, dass er 
4S-Lipo-Akkupacks schützen kann. Dazu müsste die Abschaltspannung knapp 
über 12V liegen (Einzelne Zelle soll nicht unter 3V entladen werden). 
Balancing macht mein Ladegerät - damit brauchen wir uns nicht 
beschäftigen.

Als Transistor nehme ich einen IRF4905
Den Opamp habe ich als Sample bestellt - es könnte natürlich auch ein 
anderer verbaut werden. Ich bin für Vorschläge offen.

Erstmal habe ich das Ding ohne Hysterese ausgelegt: R5 = unendlich

R1 = 100k
R2 = 150k
R3 = 220
R4 = 220
funktioniert rein rechnerisch bei einer Zenerspannung von 2.4V optimal 
und schaltet bei exakt 12V ab (http://www.reichelt.de/?;ARTICLE=23119;)
Im Aufbau stellt sich allerdings heraus, dass die Zenerspannung selbst 
bei so kleinen R3 und R4 stark schwankt: 2.75V@12V und 2.97V@18V 
dementsprechend weich schaltet der Transistor ab. Ist also schonmal 
völlig unbrauchbar.

Also erste Frage: Wie bekomme ich den Abschaltvorgang "härter"?
Wo finde ich eine härter schaltende Diode? Oder sehe ich das Problem an 
falscher Stelle?

...und für die nächste Frage würde ich mich mit der Hysterese 
beschäftigen wollen... Aber erst das eine Problem!

Autor: Lipomensch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich vergaß: in meinen Tests ist die Last eine 24V, 50W Halogenlampe. 
Alles was stärker ist, treibt mein Netzteil zu schnell in die 
Strombegrenzung :(

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Zenerspannung

Wovon redest du ?
Die LT1389 hat 1.2V.
Und sie ist der entscheidende Grund, warum die Schaltung so wenig Strom 
braucht.
Mit Zenerdioden brauchst du das 1000-fache,
deshalb zeigt dir LinearTech ja wie's geht.

> Den Opamp habe ich als Sample bestellt

Die Referenzdiode war wichtiger.

Bei Reichelt gibt's nicht so tolle Bauteile, aber einen LT1004 hat der 
auch, die kannst du einsetzen wenn du die Widerstandswerte viertelst, 
und ein TLC 271 (in low bias mode) tut's auch.

Braucht halt 10 mal so viel Strom.

Die Rechenformeln stehen doch im Artikel alle drin.

Autor: Lipomensch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
naja ich habe es halt mit einer normalen Zenerdiode versucht und nicht 
mit so einem Zauberding.
Der Stromverbrauch war mir nämlich, gelinde gesagt, relativ schnuppe!

Und nun wollte ich wissen, ob neben dem Stromverbrauch auch die Härte 
des Schaltvorgangs durch die diode entscheiden beeinflusst werden kann.
Und ob mein Problem der eklig großen Schaltgemütlichkeit daher kommen 
kann. Oder vielleicht woanderst her?

Autor: Lipomensch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich wollte euch mal auf den aktuellen Stand bringen und nochmal um Rat 
fragen:

Ich habe mir jetzt noch eine schöne Referenzspannung besorgt mit 2.5V 
(LT1004).
weiteres:
R1 = 100k
R2 = 150k
R3 = 101k
R4 = 100k
R5 = 44M
RSW = 1k

laut meiner Rechnung ist die Abschaltspannung damit 12.26V und die 
Wiederanschaltspannung 12.53V
Klar, auf Toleranzen muss ich achten, aber darum soll's erstmal noch gar 
nicht gehen.

in den Versuchen konnte ich immer noch keinen harten Abschaltvorgang 
erzeugen (unabhängig davon, ob eine Last hinter dem Transistor hängt und 
ob man einen anderen Transistor wählt). Auch das Weglassen von R5 hat 
nix geholfen. Der ist ja eh praktisch ein Isolator.

Ich hab nur multimeter und netzteil. Wenn ich die Versorgung von 13V bis 
auf 12V runterfahre,
sehe ich eine Lastspannung von 12V... bis runter auf 8.7V, wo sich ne 
Zeit lang gar nichts tut und erst dann sinkt sie langsam ab bis auf 0V.

Dementsprechend warm wird die Transe, weswegen ich gerne einen richtig 
harten Schaltvorgang hätte. Nur woran kann's noch liegen??

ich habe bereits mehrere Transistoren versucht,
mehrere LT1494 (Opamp)
und auch die Z-Spannung ist über den gesamten Bereich konstant (2.48V)

langsam werde ich ratlos

Autor: BMK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm, ist mir schon klar, dass ein MOSFET seeeehr langsam schaltet,
wenn der Gate-Vorwiderstand (RSW) 1M beträgt.

Setz doch den RSW mal auf 12k, damit schaltet der MOSFET genügend
schnell und der Ausgang des LT1494 wird mit 1mA nicht überlastet.

Und R5 hat schon seine Daseinsberechtigung, nämlich die Hysterese
zwischen Abschaltspannung und Wiedereinschaltspannung.

Aber R5 = 44M ???  Kann irgendwie nicht sein. Wert viel zu hoch.

Ich würde den Wiedereinschaltpunkt auch viel höher legen, als
der Autor, eher bei 13V. Denn wenn ein Bleiakku auf 12V angekommen
ist, ist er doch recht leer und sollte erstmal gut aufgeladen
werden (Ladeendspannung um die 14V) so dass eine Wiedereinschaltung
bei ca. 13V also 'teilgeladen' etwa in der Mitte liegt. Ist aber
jetzt meine Meinung und von den Parametern der Anwendung abhängig.

Autor: Lipomensch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
alles klar, der R5 ist natürlich diskussionswürdig.
aber die Größenordnung kommt schon hin - bei 10M ist die 
Wiederanschaltspannung schon bei 13.5V
Dadurch, dass die beiden Punkte A und B bei meiner Auslegung eine 
relativ ähnliche Steigung haben (wenn man die Versorgungsspannung 
ändert), genügt schon ein kleiner Zusatzstrom, also eine kleine 
Zusastzspannung im Punkt B, um das Verhalten ordentlich anzupassen.
Aber wie gesagt: das harte Schalten tritt auch ohne R5 nicht auf.

Was den Gate-Widerstand angeht: Der ist mittlerweile bei 1k, wie ich 
oben geschrieben habe. Das ist zwar sehr wenig, aber ich gehe davon aus, 
dass der opamp nicht überlastet wird, da er ja nur das Gate laden muss.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.