www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Lautstärkeregelung


Autor: Thomas S. (thomas_s74)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich wollte bei meinem Mini amp. mit dem TDA7266  ein Poti zur 
Lautstärkeregelung einbauen. C2 Verzerrt die Musik jedoch ganz 
ordentlich. Aber wenn ich C2 Weglasse fängt er troz Speisung mit 
Batterien an zu brummen. Ich habe schon verschiedene Werte von C1 R1 und 
C2 ausprobiert und es ist immer das selbe Problem. Mache ich was Falsch? 
Auch wenn ich den Poti als Spannungsteiler beschalte und die Mittelachse 
mit dem Eingang des TDAs verbinde fängt ohne C2 an alles zu brummen. 
Wenn C2 zu klein ist brummt auch wieder alles. Wenn er so groß ist, dass 
das Brummen fast weg ist dann verzerrt die Schaltung die Musik. C3 muss 
sein, da der Eingang nicht auf Masse gelegt werden darf.
Bei R1 abe ich von 1K bis 20K so ziemlich jeden Wert, den ich da hatte 
durchprobiert.

Was Kann ich dagegen Tun? Sollte ich ne andere Schaltung verwenden? Ich 
hab ja im Gehäuse schon den Poti verbaut.
Gibt es da alternative Schaltpläne, mit denen man die Lautstärke über 
einen Poti regeln kann?

MFG
Thomas

Autor: Egon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Poti ist verkehrt herum. Schleifer zum Verstärker.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Poti ist falsch rum;)

Autor: Thomas S. (thomas_s74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ändert auch nix, wenn ich den anders rum einbaue. Ich habe schon so 
viel versucht.

Autor: Ralph Berres (rberres)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hast du ein Oszillografen, mit dem du den Verstärker mal auf 
HF-Schwingen kontrollieren könntest?

Hast du eventuell Gleichspannung auf dem Lautsprecherausgang?

Ralph Berres

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Masseproblem.

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
C2 ist ziemlich unsinning. Der bildet zusammen mit dem Eingangspoti 
einen Tiefpass. Was ist das für ein Brummen? 50Hz? Wie hast du den 
Verstärker aufgebaut? Zeig mal einen Schaltplan bzw. ein Foto vom 
Aufbau.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch wenn das Poti, wie schon richtig bemerkt wurde, falsch eingebracht 
wurde, der C2 gehört da nicht hin! Der macht beliebiges, von der 
Potistellung abhängiges Tiefpassverhalten und selbst wenn man eine 
Bandbegrenzung auf z.B. 20kHz möchte, ist das der falsche Platz.
Wenn du Brumm hast, dann liegt das an anderen Ursachen, die in dem Bild 
nicht zu erkennen sind:
- hochohmige Quellen mit ungeschirmten Leitungen
- irgendwelche Masseschleifen, falsche Masseführung
- Einstreuungen durch andere Geräte
- grundsätzlicher Schaltungsaufbau (Layout etc.)
- Gewinnung einer Referenzspannung ohne Block-C aus verbrummten Quellen
- und was weiß ich noch ...

Autor: Thomas S. (thomas_s74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab so ein billig DSO. Der Ausgang ist eigentlich immer unter ca. so 
2 MHz bei etwa 0,03V. Denke mal, dass das so sein soll, da es immer so 
ist. Soll ich den Poti villeicht so schalten, dass ich einfach die Musik 
in Wärme umwande und so dem Eingang den Strom klaue? Nicht die feine 
Englsche Art aber hauptsache es Funktioniert.
Wie machen große Firmen das? z.B. in nem PC Subwoofer-da regeln die doch 
auch mit nem Poti?!?!? Villeicht über den "Gain" pin!?!? TDA7266 Hat 
aber laut Datenblatt "fixed gain".

Autor: Michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also löte noch mal alles ab und fange neu an.
Und vor allem den Schleifer zum Verstärker. Sonst schließt du deine 
Quelle kurz!
Und dann verbindest du den Verstärker mit dem Schleifer mit 0,22µ 
(Folie) wie in der Applikation mit dem IC.
Wenn das Poti eine Abschirmung hat, muß die auch an Masse.
10-20 KOhm für das Poti sind gut.
Wenn es verzerrt, ist die Eingangsspannung zu hoch. Kannst du leicht mit 
einem Vorwiderstand am Eingang machen.

Autor: STK500-Besitzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas S. schrieb:
> Soll ich den Poti villeicht so schalten, dass ich einfach die Musik
> in Wärme umwande und so dem Eingang den Strom klaue?
Das Poti sollte so um die 50kOhm haben. Bei einer Signalspannung von ca. 
1V klaut man da fast keinen Strom und Wärme wird auch nicht viel 
erzeugt.

> Wie machen große Firmen das? z.B. in nem PC Subwoofer-da regeln die doch
> auch mit nem Poti?!?!?
Die benutzen Trolle dafür. Deswegen sind Verstärker auch so schwer.

Deine Schaltung hat ein Masseproblem und C2 ist da völlig sinnfrei 
hingebastelt. Wenn es brummt, dann ist es ein Masseproblem und wenn es 
höherfrequent pfeift, dann schwingt da irgendwas.

Autor: Michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Wie machen große Firmen das? z.B. in nem PC Subwoofer-da regeln die doch
>auch mit nem Poti?!?!? Villeicht über den "Gain" pin!?!? TDA7266 Hat
>aber laut Datenblatt "fixed gain".
Was redest du für einen Quatsch?
http://www.datasheetcatalog.org/datasheet/SGSThoms...
An der Schaltung kann man doch nichts falsch machen.
Hast du auch die Eingänge genommen und nicht etwa ST-BY/MUTE?

Autor: Michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Das Poti sollte so um die 50kOhm haben.
Bei einem Eingangswiderstand von 30 KOhm ist das etwas hoch.
5-10 KOhm sollten passen.

Autor: Thomas S. (thomas_s74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So ich habe die Mittelachse über 0,22µF an den Eingang gelegt. C2 Hab 
ich direkt an die Audioquelle geschlossen (verhindert jetzt das brummen, 
wenn keine Audioquelle angeschlossen ist). Und mit dem Brummen hab ich 
jetzt überhaupt keine Probleme und verzerrt ist auch nix mehr. Das mit 
dem Gehäuse auf Masse ist n guter Tipp! Danke!

So sieht der mini Amp. momentan aus: 
http://img812.imageshack.us/i/dsci0033n.jpg/

Die LED ist natürlich mit ner konstantstromquelle gespeist, damit die 
Helligkeit bei verschiedenen Eingangsspannungen nicht schwankt.
Ich muss allerdings hinten noch eine 5,5/2,5 mm Hohlbuchse, eine 3,5mm 
Klinkenbuchse und 2 Cinchbuchsen einbauen (wird bei den kleinen Maßen 
sehr schwer). Ist übrigenz dieses kleine mini Gehäuse: 
http://www.pollin.de/shop/dt/Mjk5OTM1OTk-/Baueleme...

Danke für die Hilfe!

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keine Ahnung was du da jetzt genau gemacht hast um das Problem zu lösen.

Aber eine Konstantstromquelle für eine Signalisierungs-Anzeige-LED? 
Overkill?

Autor: Michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>So ich habe die Mittelachse über 0,22µF an den Eingang gelegt. C2 Hab
>ich direkt an die Audioquelle geschlossen (verhindert jetzt das brummen,
>wenn keine Audioquelle angeschlossen ist).
Parallel zum Poti oder in Reihe?
Brummen an einem offenen Eingang kann nur! durch gute Abschirmung 
erreicht werden.
Parallel zum Poti killt die hohen Frequenzen.

Autor: Michael_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Brummen an einem offenen Eingang kann nur! durch gute Abschirmung
>erreicht werden.
KEIN Brummen an einem offenen Eingang kann nur! durch gute Abschirmung
erreicht werden.
Entschuldigung!

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas S. schrieb:
> So ich habe die Mittelachse über 0,22µF an den Eingang gelegt.
An welchen Eingang?
An den Eingang des TDA? Gut! An den Eingang der Schaltung? Schlecht!

> C2 Hab
> ich direkt an die Audioquelle geschlossen (verhindert jetzt das brummen,
> wenn keine Audioquelle angeschlossen ist).

Der ist auch an der Stelle falsch. Wie groß ist denn dein Poti? Hast du 
die obige Empfehlung mit ca. 10k beachtet? Ist alles geschirmt?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.