www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Atmega16 + Tyco A1029-B


Autor: Thomas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo µC-Freunde!

Habe mein Tyco A1029-B Modul günstig von ebay bekommen, und gleich mal 
ans testen gemacht. Gleich vorweg - ich habe leider keinen COM-Port am 
Computer.

Quartz ist 3.6864 MHz.
Laut Hersteller sind für die UART verbindung folgende Einstellungen 
vorgesehen:
Serial 0 (NMEA) 4800 baud, 8 data bits, no parity, 1 stop bit, no flow 
control

Das ganze geht durch einen MAX3232. Das ganze schaut im Oszilloskop auch 
hervorragend aus - ausgangspegel leicht über 5V, 1x eine Ladung Daten 
pro Sekunde, wie im Datenblatt.

Nun ja das Problem: Der Atmega empfängt nur Bahnhof. Anbei das Testprog 
und das was er empfängt.

Bitte um Hüüüülfe! ;)

Autor: Thomas R. (thomas666)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
übrigends, es der Tyco Gps receiver sollte sich mit folgenden (oder 
ähnlichen) NMEA strings melden:

$PTYCVER,TYCO Electronics - a100-57 (11:43:42 Feb 24 2004)
$PSTMVER,GPS Version 4.07release-ARM (14:02:29 Sep 27 2003)

Autor: Thomas R. (thomas666)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für die Nachwelt: der MAX3232 invertiert, wozu das gut sein soll - kA, 
dem atmel gefällts natürlich nicht ;)

Direkt an den atmel angeschlossen (der arbeitet ja mit HIGH ab 2.7V bei 
entsprechender Fuse) funktionierts!

$PTER,TYCOeos1005..2)PVGVi4.esR15..2)PVBleeo..
$GPGG31000N00,,9,2M.,7GC5.,00,0.00019.*.GA,,,,0.90.
$GPGG32000N00,,9,2M.,4GC5.,00,0.00019.*.GA,,,,0.90.
$GPGG33000N00,,9,2M.,5GC5.,00,0.00019.*.GA,,,,0.90.

danke fürs lesen trotzdem

Autor: Andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also mir hat dein Post geholfen,
ich werde mir jetzt einen davon bestellen :)

Gruß
Andi

Autor: Thomas R. (thomas666)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In die andere Richtung funktionierts allerdings nicht so gut... hab mir 
dann einen Inverterr HEF4048BP gekauft, mit dem läufts wunderbar =)

Was hast du bestellt, das Tyco Modul? Da gibts auch einige 
Schwierigkeiten, bei denen ich dir helfen kann bzw wo ich gerne auch an 
Erfahrung austauschen möchte. Bitte hierbei um Antwort.

Lg,
Thomas

Autor: Volker Block (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was für eine Antenne benutzt man denn für diesen Baustein?

Autor: Tip (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas R. schrieb:
> Für die Nachwelt: der MAX3232 invertiert, wozu das gut sein soll - kA,
> dem atmel gefällts natürlich nicht ;)

Die RS-232 Schnittstelle ist in negativer Logik definiert. Darum muß ein 
CMOS-RS232 Schnittstellenwandler invertieren, sonst wäre es kein 
Schnittstellenwandler.
;-)

Autor: Michel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Volker Block schrieb:
> was für eine Antenne benutzt man denn für diesen Baustein?

z.B. soetwas:
http://www.tycoelectronics.com/catalog/pn/en/15136...

Autor: Jan K. (do6jan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moin leute,
ich hab mir auch mal eins gekauft,für den preiß oO

ich sehe grade das ihr hier schon ein theard offen habt, brauch ich nix
neues in die welt setzten.

bevor ich irgendwas verbastell würde mich interresieren wie ihr von der
saukleinen stiftleiste das signal rausbekommen habt?
und wie sieht die minimalkonfiguration aus? also reichen 5v und ein
pegelwandler damit er was ausspuckt oder wo muss was hin? und was ist
diese vant?
laut dem datenblatt würde ich sagen kann man die kondensatoren mal eben
übersehen kann ;)

mfg
Jan

Autor: Jan K. (do6jan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sooo,
hab gr4ade ein zweites datenblatt gefunden da ist die minimalbeschaltung 
gut drauf zusehen...

aber kann mir jemand sagen wie ich am besten meine leitungen an die 
kleine buche ran bekomme? löten oder gibt es dafür adapter auf 2,56mm?

mfg

Autor: Thomas R. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
pegelwandler war bei mir nicht notwendig, wenn vielleicht doch 
empfehlenswert...
probeweise kriegt man das signal mit sehr dünnen kupferdrähten raus 
(oder normale steckdrähte mit nem seitenschneider zuspitzen) und die 
dann auf ein steckbrett verbinden zB.

GPS signal hab ich übrigens nach 6 monaten noch immer keines bekommen, 
falls du es schaffst bitte poste wie!!

Autor: Jan K. (do6jan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi thomas!

ich hab nun eine sma gps antenne vom R drann und alles nach 
minimalbeschaltung aufgebaut, kommt nur ungültiges nmea kein 
sattelitensignel an oO

weiss jemand ob das an einer zu geringen VCC liegen kann? hab ca 2,8 V , 
hab den spannungsreger zu doof bemessen -.-

hoffentlich kann jemand helfen!

mfg
Jan

Autor: Thomas R. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
genau das ist es... ich bin mir zwar nicht sicher ob meine antenne die 
richtige war, aber bei sonst korrekter beschaltung hab ich auch nie ein 
gültiges gps signal bekommen.
NMEA strings waren allerdings korrekt (halt nur mit position 0/0)

Autor: Thomas R. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was mir noch geraten wurde und ich leider noch nicht testen konnte:
bei schönem wetter eine runde mit dem ganzen im auto fahren (wenn 
möglich antenne am dach)... weil der erste sync einige minuten dauern 
kann und meistens nur bei bewegung richtig gut hinhaut (wenn du deinem 
navi den strom raubst und es ohne zu fahren einschaltest bekommst du 
auch erst nach 10 minuten oder so signal.. und ich glaub die sind schon 
besser ;) )

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.