www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Audiostörungen filtrieren


Autor: Luca Bertoncello (lucabert)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, Leute!

Ich habe einen Mikrocontroller gesteuerten Wecker gebaut.
Das ganze funktioniert sehr gut, ich habe aber noch ein Problem, das ich 
nicht lösen kann, und zwar, wenn ich eine MP3 abspiele, ist immer ein 
Hintergrundgeräusch (wie ein höhes "Piep") zu hören.
So laut ist die Störung nicht, und wenn du Musik laut genug ist, ist es 
kaum zu hören, aber trotzdem würde ich sehr gern es rauskriegen.

Als Anhang der Schaltplan meines Weckers.

Meint ihr, ich kann noch was machen? Kann ich eventuell, zwischen den 
Verstärker und den Lautsprecher irgendein Filter einbauen, so daß diese 
Störung filtriert wird? Wenn ja, wie?

Besten Dank
Luca Bertoncello

: Verschoben durch Admin
Autor: Lucky Luck (rantanplan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich vermute mal das es an dem TDA liegt. Also Layout bzw. Masseführung.

Autor: Luca Bertoncello (lucabert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lucky Luck schrieb:
> Ich vermute mal das es an dem TDA liegt. Also Layout bzw. Masseführung.

Also, an den Verstärker...

Was meinst du jetzt mit "Layout bzw. Masseführung"?

Danke
Luca Bertoncello

Autor: Lucky Luck (rantanplan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie gesagt ich vermute nur. Also das die Lautsprecher oder der 
Verstärker keine saubere Masseverbindung haben. Oder die Kondensatoren 
zu weit weg vom Verstärker plaziert wurden. So wie du das beschreibst 
meine ich da eine Masseschleife zu erkennen.

http://de.wikipedia.org/wiki/Brummschleife

Autor: Luca Bertoncello (lucabert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lucky Luck schrieb:
> Wie gesagt ich vermute nur. Also das die Lautsprecher oder der
> Verstärker keine saubere Masseverbindung haben. Oder die Kondensatoren
> zu weit weg vom Verstärker plaziert wurden. So wie du das beschreibst
> meine ich da eine Masseschleife zu erkennen.
>
> http://de.wikipedia.org/wiki/Brummschleife

Aha, sehr interessant...
Ich muß leider sagen, daß ich nicht alles verstehen. Meine 
Elektronikkenntnisse sind etwas schlecht (ich bin ein Programmierer), 
insbesondere bei Analogelektronik.

Daher bitte ich dich noch um Geduld und stelle ich folgende Frage vor: 
wie kann ich mein Problem lösen?
Die Platine neu zu machen ist keine Option: viele Komponenten werde ich 
nicht so einfach auslöten können (SMD...) und das ganze wird mir einfach 
zu teuer.

Gibt es eine andere Möglichkeit?

Besten Dank für deine Antwort
Luca Bertoncello

Autor: hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Audio und Digital ist oft feindlich.

Das "Piep" kann auch vom µC und seinen Komponenten kommen.

Masse und Versorgung sollten bei sowas sehr sorgfältig
getrennt und verlegt werden.
Das ist hier lt. Schaltbild nicht der Fall.

Wenn man die PWM für das Display ändert wird wohl auch der
Piep seine Tonhöhe ändern.
Das wäre schon mal der erste Ansatz.

Für mehr müßte man mehr wissen.

hans

Autor: Luca Bertoncello (lucabert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hans schrieb:
> Audio und Digital ist oft feindlich.

Das habe ich verstanden... :(

> Masse und Versorgung sollten bei sowas sehr sorgfältig
> getrennt und verlegt werden.
> Das ist hier lt. Schaltbild nicht der Fall.

Kannst du mir bitte sagen, WIE ich die Masse und Versorgung der 
Komponenten getrennt halten kann?
Ich verstehe es wirklich nicht...

> Wenn man die PWM für das Display ändert wird wohl auch der
> Piep seine Tonhöhe ändern.

PWM?!? Ich spreche mit dem Display nicht über PWM...
Was meinst du?

> Für mehr müßte man mehr wissen.

Tja, ich versuche was neues zu lernen... :D

Danke
Luca Bertoncello

Autor: Lucky Luck (rantanplan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Luca Bertoncello schrieb:
> Kannst du mir bitte sagen, WIE ich die Masse und Versorgung der
> Komponenten getrennt halten kann?
> Ich verstehe es wirklich nicht...

Normal macht man sich da gedanken bevor man zum layouten beginnt.
Zum Beispiel fast man die alle Massen von "analogen Bauteilen" und die
von "digitalen Bauteilen" in seperaten Masseflächen zusammen. Oft wird 
auch noch die Möglichkeit geschaffen diese beiden Flächen über einen 
Jumper oder einer Lötbrücke zu verbinden.

Zeig mal dein Layout.

Datenblatt vom Verstärker Hersteller wäre auch interessant.

Autor: Michael K-punkt (charles_b)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lucky Luck schrieb:

> Normal macht man sich da gedanken bevor man zum layouten beginnt.

Gute Anmerkung!

> Zum Beispiel fast man die alle Massen von "analogen Bauteilen" und die
> von "digitalen Bauteilen" in seperaten Masseflächen zusammen. Oft wird
> auch noch die Möglichkeit geschaffen diese beiden Flächen über einen
> Jumper oder einer Lötbrücke zu verbinden.

Halte ich grundsätzlich auch für richtig!

> Zeig mal dein Layout.

Rätsel: erst meckerst du an seinem Layout rum und jetzt kommt raus, dass 
du es gar nicht kennst....?

Autor: Lucky Luck (rantanplan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Drum schreib ich ja das ich es vermute. Genau weil ich es nicht kenne.

BTW. Pin 4 könnte man noch 100µF gegen Masse spendieren.

Autor: Lukas K. (carrotindustries)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was die Mär von getrennten Masseflächen anbetrifft: Mein 
Klasse-D-Verstärker (Modulator mit LM393) funktioniert auch ohne 
getrennten Massefläche prächtig; nichts fiept, obwohl die schnell 
schaltenden MOSFETs, deren Treiber und 74HC Gatter nur ein paar wenige 
cm vom Modulator entfernt sind.

Autor: Wegstaben Verbuchsler (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mach doch mal eine Tonaufnahme von deinem Piepton und stelle diese hier 
ein.

Vielleicht kann man da ja was raushören

Autor: Luca Bertoncello (lucabert)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wegstaben Verbuchsler schrieb:
> mach doch mal eine Tonaufnahme von deinem Piepton und stelle diese hier
> ein.
>
> Vielleicht kann man da ja was raushören

So, als Anhang den Layout und ein Beispiel der Störung.
Ich konnte es nur mit meinem Handy aufnehmen, ich hoffe, aber, es ist 
noch deutlich zu hören.

Grüße
Luca Bertoncello

Autor: soundso (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ahhhrg, Autorouter  ... da krigt man ja augenkrebs :-)

nei mal ehrlich, du hast keine Massenflägen und deine Masse Leitungen 
gehen irgenwo quer durch das Ganze Layout, das kann ja nichts werden...

Autor: Luca Bertoncello (lucabert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
soundso schrieb:
> Ahhhrg, Autorouter  ... da krigt man ja augenkrebs :-)

Nein, kein Autorouter... Alles per Hand gemacht...

> nei mal ehrlich, du hast keine Massenflägen und deine Masse Leitungen
> gehen irgenwo quer durch das Ganze Layout, das kann ja nichts werden...

Mmm... Ich habe auch probiert (Vorschlag von einem anderen Forum) die 
Masse des Verstärkers mit einem Kabel direkt zu verbinden.
Keine Änderung.

Was kann ich noch machen um meine Schaltung zu retten?

Ansonsten, gibt es eine Möglichkeit, einen Filter NACH dem Verstärker 
einzubauen, so daß die Lautsprecher nicht so viel Mist bekommen?

Danke
Luca Bertoncello

Autor: Lucky Luck (rantanplan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau mal hier. Der C3

http://www.aaroncake.net/circuits/amp20w.asp?showc...

100µF wie ich oben schon geschrieben hab. Vllt. bringt der was.

Autor: Andreas Riegebauer (blackpuma)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe mal eine Frage an alle! Seht euch doch bitte mal Q3 an und sagt 
mir wie das funktioniert! Eigentlich gar net bzw. ist das Sinnlos oder!?

BG
Andreas

Autor: Luca Bertoncello (lucabert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lucky Luck schrieb:
> Schau mal hier. Der C3
>
> http://www.aaroncake.net/circuits/amp20w.asp?showc...
>
> 100µF wie ich oben schon geschrieben hab. Vllt. bringt der was.

Aha! Also, 100µF zwischen RR und GND?
Ich kann probieren!

Ich werde morgen einen 100µF Elko suchen und versuchen einzubauen.

Ich melde mich, wenn ich es gemacht habe!

Besten Dank!
Luca Bertoncello

Autor: Weingut Pfalz (weinbauer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, hast Recht, Q3 schaut in der Konstellation nicht sinnig aus.

> Nein, kein Autorouter... Alles per Hand gemacht...

Um so schlimmer ... Massefläche Fehlanzeige, 2/3 der 
Durchkontaktierungen
sehen auf Anhieb unnötig aus. Ein insgesamt "nicht sehr elegantes" 
Routing, sorry.

Autor: Luca Bertoncello (lucabert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fhutdhb Ufzjjuz schrieb:
> Ja, hast Recht, Q3 schaut in der Konstellation nicht sinnig aus.

Warum denn nicht?
So kann ich den TDA von Mikrocontroller ein- und ausschalten.

Ich gebe selber zu, mit Mute saugt das Ding sehr wenig, und dann ist es 
nicht notwendig, aber total sinnlos ist es ja nicht, oder?

>> Nein, kein Autorouter... Alles per Hand gemacht...
>
> Um so schlimmer ... Massefläche Fehlanzeige, 2/3 der
> Durchkontaktierungen
> sehen auf Anhieb unnötig aus. Ein insgesamt "nicht sehr elegantes"
> Routing, sorry.

Naja, ich bin Anfänger...
Dazu ich nutze die kostenlose Version von Eagle, und ich bin von der 
Fläche sehr begrengzt...

Grüße
Luca Bertoncello

Autor: Andreas Riegebauer (blackpuma)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich sehe Q3 als Nutzlos an. Durch die Diode im FET kannst du 
Schalten was du willst aber es sind immer 12V am TDA.

Ich verstehe nicht wie das mit dem Q3 funktionieren soll. Damit der 
P-FET leitet muss doch das Gate Negativer werden als Source oder nicht? 
Kann das hier überhaupt so sein?

Autor: Lukas K. (carrotindustries)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Luca Bertoncello schrieb:
> Dazu ich nutze die kostenlose Version von Eagle, und ich bin von der
> Fläche sehr begrengzt...

Das ist kein Argument gegen Masseflächen.

Autor: Luca Bertoncello (lucabert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lucky Luck schrieb:
> Schau mal hier. Der C3
>
> http://www.aaroncake.net/circuits/amp20w.asp?showc...
>
> 100µF wie ich oben schon geschrieben hab. Vllt. bringt der was.

So, endlich habe ich die Zeit gefunden, dieses Test zu machen.
Ich habe also einen 100µF Elko zwischen RR und GND gelötet.

Vorteile:
1) Bei Einschalten ist kein "Plomp" mehr zu hören
2) Die Störung ist ein wenig leiser geworden, aber leider nur ein wenig

Nachteile:
1) Aus irgendwelcher Grund wird die ganze Musik PI*Daumen 2-3 Töne höher 
transponiert

Fazit: ich muss feststellen, daß, wenn ich mal was in digitale Technik 
machen will, bin ich in der Lage was akzeptabel zu machen, aber bei 
Analogelektronik habe ich SEHR viel zu lernen.
Diese kleine Störung bei meinem Wecker wird mir jeden Tag daran 
erinnern, daß ich nur ein armer Programmierer/SysAdmin bin, und wenn ich 
in meiner Arbeit auch gut sein kann, in anderen Bereich der dümmster 
Lehrling bin... :(

Ich werde also mit diesen kleinen Störung leben, denn ich denke 
wirklich, daß es nichts mehr zu tun gibt, ohne die Platine völlig neu zu 
gestalten, und bei dem Spaß auch ~70% der Komponenten zu tauschen.
Das ist mir zu teuer.

Ich danke euch trotzdem für eurer Geduld und eure Empfehlungen! Wenn ich 
mal wieder was mit Tontechnik machen werde, werde ich bestimmt nicht nur 
den Schaltplan euch zur Prüfung schicken, sondern auch den Layout!

Euch eine schöne Woche
Luca Bertoncello

Autor: Lucky Luck (rantanplan)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du schon mal ein anderes Netzteil versucht?

Autor: Spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Hast du schon mal ein anderes Netzteil versucht?

Bei dem Layout?

MfG Spess

Autor: Giuseppe G. (Firma: ACS) (gcrax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nimm ein Trenntrafo 1:5 von Conrad und gut ist...
hatte auch mal das Problem, lag am AD Wandler des µC, aber war viel zu 
umständlich alles neu zu entwickeln, deshalb der Trafo...
LG

Autor: Luca Bertoncello (lucabert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lucky Luck schrieb:
> Hast du schon mal ein anderes Netzteil versucht?

Ich habe sogar mit einer Autobatterie versucht.
Keine Änderung...

Grüße
Luca Bertoncello

Autor: Luca Bertoncello (lucabert)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Giuseppe G. schrieb:
> nimm ein Trenntrafo 1:5 von Conrad und gut ist...
> hatte auch mal das Problem, lag am AD Wandler des µC, aber war viel zu
> umständlich alles neu zu entwickeln, deshalb der Trafo...

Kannst du mir besser erklären?

Danke
Luca Bertoncello

Autor: Jan S. (jan_s)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Luca Bertoncello schrieb:
> Fazit: ich muss feststellen, daß, wenn ich mal was in digitale Technik
> machen will, bin ich in der Lage was akzeptabel zu machen, aber bei
> Analogelektronik habe ich SEHR viel zu lernen.
Vorsicht, auch bei Digitaltechnik bekommst du mit so einem Layout ganz 
schnell Probleme. Dann sitzt du vor einer Schaltung und wunderst dich 
warum diese alles mögliche macht, nur nicht das was sie soll.
Also einfach mal ein wenig mit Platinenlayout und den physikalischen 
Grundlagen beschäftigen. Ist kein Hexenwerk, bekommen die meisten 
SysAdmins die ich kenne hin. ;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.