www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik wird ATMEL erkannt wenn ...


Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
er ständig auf RESET gezogen wird ?
Ich hab warscheinlich einen C falsch eingelötet.

Also die Software Bascom oder ähnliches versucht ja abzufragen.
Aber da kommt nur device .... 00000 oder FFFFF

Hmmm :-(

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oder richtiger wenn das Reset ziehen unmöglich ist .

Autor: Joh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hä... bitte nochmal genauer. und mit deutschen satzbau.
Gruß

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ist da schwer zuverstehen ?

Wird der ATMEL per Software erkannt wenn er nicht auf RESET gezogen
werden kann ( wegen falsch angeschlossenen Kondensator) oder spielt das
keine Rolle .

Ich kann auf meinen ATMEL AT90S2313 in der Schaltung nicht zugreifen.

Autor: dave (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich den RESET auf Masse lege, dann erkennt YAAP den natürlich.
Informationen, die NIX mit dem laufenden Betrieb zu tun haben, braucht
man halt RESET = LOW.

Also: Device Informationen etc. gehen, wenn RESET low, ob nun durch
Programmer oder manuell..

dave

Autor: thkais (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir erschließt sich nicht ganz, wie ein Kondensator derart geschaltet
werden kann, so daß dieser die Auslösung des Reset verhindern könnte...
außer es wäre ein Elko. Und was spräche dagegen, den Übeltäter einfach
zu entfernen?
Aber ich bin immer offen für Neues.

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dafür hab ich euch doch um mir Bauteileverlöter das zu erklären :-)
Es ist ein Elko. Vieleicht auch ein Tantal . Den hätte ich dann mit
100% falsch  herum eingelötet (weil der Balken + ist ). Wenn ich den
ganz raus nehme , hab ich meine Spannungsversorgung noch und der
"Reset" hängt nur noch an der Datenleitung. Ich denke das wird mein
Problem sein.

Autor: thkais (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ah, so, jetzt wirds einigermaßen klar...

Hmmmm - warum verbaut man an den Reset-Eingang einen Elko? Habe ich da
irgendetwas verpaßt?

Autor: MSE (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht weil man nicht weiß, dass AVRs Power-Up-Resetlogic
enthalten?!?

Gruß, Michael

Autor: tex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@MSE
Wenn AVRs Power-Up-Resetlogic enthalten, was ich hiermit nicht
anzweifeln will, warum hat dann der Butterfly von Atmel eine
Restschaltung?

Autor: MSE (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe keine Ahnung vom Butterfly.

Gruß, Michael

Autor: tex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Butterfly ist so ein Demoboard mit einem Mega169 drauf.

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tach,
vielleicht, weil die externe RESET Schaltung weniger Strom zieht, als
die interne Brownout Detection? Nur so 'ne Idee...

AxelR.

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich werd mal den Kondensator auslöten damit der ATMEl nur an der
Datenleitung hängt. Wenn er dann sich nicht zu erkennen gibt , weis ich
auch nciht weiter.
Vorallem diese Schaltung läuft ja schon in einem Motorrad.

 http://pilling-sonneberg.de/CDI/cdi-schaltung.gif

Autor: ...HanneS... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja, mit 2313...

Der hat natürlich noch kein BOD und keine interne Reset-Schaltung.

Das kommt davon, wenn man das Kind nicht beim Namen nennt. Ein
"Atmel" kann alles Mögliche sein, schau mal was die außer AVRs noch
alles produzieren...

...

Autor: Klaus Leidinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... und keine Kondensatoren an XTAL1 und XTAL2 ...

Entspricht auch nicht dem Datenblatt, vielleicht schwingt der Quatz
nicht? Von jedem XTAL Bein einmal 27pf gegen Masse.

Erstaunlich, das es vorher ging.

Ciao,
Klaus

Autor: thkais (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit den Kondensatoren am Quarz kann ich bestätigen. Je nach Layout,
Quarz, Luftfeuchtigkeit und Mondphase kann es durchaus sein, daß der
Quarz völlig ohne Kondensatoren schwingt.
Am einfachsten kann man das testen, indem man mal den Finger auf den
Quarz hält - meistens schwingt er durch den parasitären Brumm der
Netzspannung.
Ich habe den 2313 sicherlich in 50 Schaltungen ohne Reset-Beschaltung
laufen, lediglich mit dem obligatorischen externen Pull-Up Widerstand,
und es funktioniert.

Autor: Ratber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nochmal zum Thema


Ein Elko in der Resetleitung ist etwas oversized.

Bis der über die Datenleitung oder den Treiber entladen ist und
reagiert ist wieder Weihnachten.

Wenn schon die Resetleitung "entstören" dann bitte mit Adequaten
Mitteln.

Ein 100nF Folien/Keramiktyp über 100 KOhm nach Vcc reicht da volkommen
aus.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.