www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik JTAGICE mkII 6 Polig


Autor: Paulo Rock (paulo-rock)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo zusammen,
ich habe eine JTAGICE mkII und ich will damit ein Microkontroller Attiny 
24 programmien. mit welchen schnittstelle denn?? 6 pollig oder 9 
pollig??
danke

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich mag keine Pollen, bin Allergiker...

Autor: Paulo Rock (paulo-rock)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter schrieb:
> Ich mag keine Pollen, bin Allergiker...

Alles Klar Perer
ok 6 pins oder 9 pins

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir passieren ja auch öfters Tippfehler, aber ein kleines bisschen mehr 
Mühe könntest Du Dir bezüglich Rechtschreibung schon geben, BITTE!

Der JTAGICE MKII hat keinen 9 Pin Stecker (6 Pin oder 10 Pin), für 
weitere Infos RTFM  => 
http://www.atmel.com/dyn/resources/prod_documents/...

Autor: Paulo Rock (paulo-rock)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja das stimmt 6 oder 10 sorry.
zur programmierung und debbugen reicht mir die 6 pin??

Autor: Thomas K (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat dein Tiny debugWire? Dann reicht 6-polig

RTFM!!

Autor: Paulo Rock (paulo-rock)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas K schrieb:
> Hat dein Tiny debugWire? Dann reicht 6-polig
ja hat mein Tiny debugWire
> RTFM!!

Autor: Oliver Ju. (skriptkiddy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für dW reichen Betriebsspannung des AVR, Masse und Reset. Externe 
Pullupwiderstände am Resetpin können störend für dW sein.
Wenn man nen 6-Pin-ISP-Header auf dem Board hat kann man den beim 
Debuuger mitgelieferten mitgelieferten 10-Pin auf 6-Pin Adapter zwischen 
Jtagicemkii und das Board hängen und dW sollte funktionieren.

PS: Bitte Bedienungsanleitung lesen.

Gruß Skriptkiddy

Autor: Spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Für dW reichen Betriebsspannung des AVR, Masse und Reset.

Und wie kommst du in den Debugwire-Mode?

MfG Spess

Autor: Oliver Ju. (skriptkiddy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spess53 schrieb:
> Und wie kommst du in den Debugwire-Mode?

Gute Frage. Natürlich über ISP. Wenn er aber est mal aktiv ist, dann 
reichen die 3 Leitungen. Ist schon etwas spät. ;)

Hast schon recht. Ees macht keinen Sinn, nur 3 Leitungen zu verlegen, 
wenn der dW-Mode noch nicht aktiv ist.


Gruß Skriptkiddy

Autor: Paulo Rock (paulo-rock)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielen Dank

Autor: Spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HI

Stellt sich nur noch die Frage was für ein JTAG ICE er hat? Das Original 
hat nur einen 10pol. Anschluss.

MfG Spess

Autor: Oliver Ju. (skriptkiddy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spess53 schrieb:
> Stellt sich nur noch die Frage was für ein JTAG ICE er hat? Das Original
> hat nur einen 10pol. Anschluss.

Ich hab auf Arbeit nen Adapter von 10-polig auf 6-polig. Der wird afaik 
beim jtagicemkii mitgeliefert.

Gruß Skriptkiddy

Autor: Spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Ich hab auf Arbeit nen Adapter von 10-polig auf 6-polig. Der wird afaik
>beim jtagicemkii mitgeliefert.

Ich auch.

MfG Spess

Autor: Paulo Rock (paulo-rock)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
guten morgen.
ich habe die Datasheet gelesen und bin ich bei einem Punkt  hängen 
geblieben:
click on the button " debugwire". Now The ISP interface is enabled and 
debugWIRE interface disabled: d.h kann ich umschalten zwischen ISP 
interface und debugwire hardwaremässig oder das ist einfach quatsch. 
geht es mit einem taster (button) ? oder nur mit fuse down==> ISP enabel
danke

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Skript Kiddy schrieb:
> Ich hab auf Arbeit nen Adapter von 10-polig auf 6-polig. Der wird afaik
> beim jtagicemkii mitgeliefert.

Bei ganz alten ICEs war er noch nicht dabei (weil die anfangs noch
kein ISP konnten).  Dann müsste man sich mit dem "Tintenfisch"-
Adapter behelfen, der war schon immer dabei.

Paulo Rock schrieb:
> ich habe die Datasheet gelesen und bin ich bei einem Punkt  hängen
> geblieben:
> click on the button " debugwire".

Welches Datenblatt hat denn Beschreibungen, irgendwo draufzuklicken?
Sowas kam mir noch nicht unter.

Der debugWIRE-Modus und der ISP-Modus schließen sich einander
gegenseitig aus: debugWIRE ist ein Eindraht-Protokoll, das über den
/RESET-Pin gefahren wird, andererseits ist das Aktivieren von /RESET
die erste Aktion, die man zum Aktivieren von ISP machen muss.

Vom ISP-Modus zum debugWIRE-Modus gelangt man durch Programmieren der
DWEN-Fuse, gefolgt von einem "power cycle".

Vom debugWIRE-Modus zum ISP-Modus gelangt man durch das debugWIRE-
Interne Kommando "reset with MonCon disabled".  Das muss irgendwie
dein Debugger aussenden (und das ist vermutlich die Aktion, die sich
hinter deinem "Button" versteckt).  Danach bleibt debugWIRE inaktiv
bis zum nächsten power cycle; ab da wird die DWEN-Fuse neu bewertet.
Wurde diese Fuse zwischenzeitlich (als ISP möglich war) gelöscht, dann
bleibt der Controller im ISP-Modus, andernfalls wird dann debugWIRE
wieder aktiviert.

Autor: Paulo Rock (paulo-rock)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paulo Rock schrieb:

> geht es mit einem taster (button) ? oder nur mit fuse down==> ISP enabel

sorry dwen und nicht down

Autor: Paulo Rock (paulo-rock)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Kurfürst (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Für den mega168-DIL hab ich den Anhang auf der Platine...

Autor: Paulo Rock (paulo-rock)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ich habe es so (das bild oben) mit einem taster für /RESET verbunden . 
ich glaube es dass kein Problem ist. zum dW und Reset oder??
danke

Autor: Micha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paulo Rock schrieb:
> ich habe es so (das bild oben) mit einem taster für /RESET verbunden .
> ich glaube es dass kein Problem ist. zum dW und Reset oder??
> danke
Du solltest es dann tunlichst vermeiden während des debuggens zu 
resetten. C4 kannst du für was sinnvoll(er)es aufheben.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.