www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Leistungsverstärker mit MosFET und OPV


Autor: Bernd P. (bernte)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo liebes Forum

Ich habe ein großes Problem, welches ich mir einfach nicht erklären 
kann. Es geht um den Schaltplan im Anhang. Im Grunde ist es ein 
einfacher OPV gestützter Spannungsfolger mit MosFETs.Zum Einsatz kommt 
hier der TL081 und die IRF4905 und IRF3205,

Treiben tut die Schaltung einen DC Motor der Firma Faulhaber. Die 
Spannungsversorgung beträgt +-20V aus einem Labornetzteil. R3 ist ein 
Shuntwiderstand zum Messen des Motorstroms.

Über die andere BNC Buchse wird aus einem Freqenzgenerator ein Signal 
auf den nicht inv. Eingang des OPVs gegeben. Die Spannung am Motor soll 
die gleiche sein. Die Kondensatoren sind 6,8µ Bolliden die Ruhe auf der 
Leitung schaffen sollen. Folgendes Problem:

Die Schaltung tut tadellos in die negative Richtung. In die positive 
Richtung beginnt plötzlich alles zu schwingen. Es sind sogar Geräusche 
aus dem Netzteil zu hören. Die Schwingung klingt manchmal ab, manchmal 
auch nicht. Woran könnte das liegen? Ist vlt. einer meiner MosFETs 
hinüber?

Über jeden hilfreichen Kommentar bin ich sehr dankbar.

Viele liebe Grüße
Bernd

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In der Rückkopplung des OPV liegt der Tiefpass R2/C9 und der 
komplementäre Sourcefolger aus den beiden Mosfets. Der OPV ist intern 
kompensiert für eine reine niederohmige ohmsche Gegenkopplung. Die 
zusätzliche erhebliche Phasendrehung durch die genannten Elemente führt 
zu den Schwingungen.

Autor: Bernd P. (bernte)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey Arno

Danke für die Antwort. Warum aber verhält sich das mit den Schwingungen 
dann nur in die postive Richtung?

Und was für Änderungsvorschläge hättest du? Einfach den Tiefpass 
komplett rausnehmen? Anderer OPV? Ich hatte es glaub ich auch ohne 
Kondensatoren auf dem Steckbrett...

Ansonsten vielen Dank und noch einen schönen Abend
Bernd

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du kannst folgendes machen: C9 und C10 raus, für die Mosfets möglichst 
"kleine" Typen verwenden, also solche mit kleinen Kapazitäten, eine 
Verstärkung deutlich größer als 1 einstellen.

Autor: Arno H. (arno_h)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die MOSFET benötigen eine Vorspannung.

Arno

Autor: Bernte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey

Werd ich gleich morgen versuchen. Es hatte schon funktioniert auf dem 
Steckbrett.

Leider brauche ich die 1zu1 Verstärkung. Das hängt an weiterer 
Elektronik die darauf angewiesen ist. Kann ich vielleicht über 
Widerstände zur Masse an den FETS die Gatekapazität schnell genug 
entladen oder so?Irgendwelche Stabilitätsideen? Hättest du andere FET 
Vorschläge? Die genannten sind für die Aufgabe jedenfalls nicht 
überdimensioniert.

Viele Grüße und auf jeden Fall besten Dank
Bernd

Autor: Nacktaktiver (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der ist zwar nicht ganz billig, aber der LT1498 ist ein 
Operationsverstärker welcher Lasten mit einer Kapazität von 10nF am 
Ausgang treiben kann, ohne zu oszillieren.

Durch eine geeignete Kompensation bekommt man dann die Schwingungen auch 
gut im Griff. (Da müsste aber jemand anderes aushelfen)

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dimensioniere den OPV für v=10 oder 20 oder 30 oder ...
Und dann mache einen Spannungsteiler mit demselben Verhältnis wie die 
Verstärker, und schon hast Du wieder v=1. Durch diesen Trick werden 
OPV's merklich stabiler bei kapazitiven Lasten.
Auserdem mal 1k oder 2,2k zw. Gates und Sources klemmen, damit zumindest 
ein klein bißchen von der OPV-Spannung zw. rund -3V und +3V (also die 
Ugs_thres) zum Ausgang gelangen kann, und somit der OPV nicht unheimlich 
schnell umswitchen muß (je nach Niederohmigkeit der Last ist das aber 
nur ein Tropfen auf dem heisen Stein).
Der R2 ist aber eigentlich eher witzlos, weil der TL081 bereits fast 
200Ohm intern dort hat.

Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pass aber auch auf die Versorgungsspannung deines OPVs auf. Die +-18V 
sind bereits das höchste, was er verkraftet.

Christian

Autor: Bernte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey

Danke für die vielen Antworten.

Ich werde die Versorgungsspannung des OPVs auf +-15V senken und diese 
Widerstände an die FETs ranklemmen. Die Verstärkung kann ich leider 
nicht mehr so leicht ändern, da die Platine schon fertig ist (aber den 
Trick werd ich mir merken, danke auf jeden Fall).

Ich hab jetzt auch ein paar neue MosFETs hier rumliegen und werd den 
schwarzen Käfer mal tauschen. Durch diese Schwingungen hat das Netzteil 
auch gute Spannungsspitzen rausgehaun, weshalb der vlt. einen Knacks weg 
hat.

Was mich verwundert ist eben, dass es bei negativem Führungssignal 
funktioniert und bei positivem nicht. Außerdem hatte es schonmal auf dem 
Steckbrett tadellos funktioniert.

Auf jeden Fall allen Patizipanten vielen Dank, heut abend berichte ich 
obs geklappt hat oder nich =)

Viele Grüße
Bernd

Autor: Paulchen Panther (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Es ist interessant, dass es bei negativen Spannungen funktioniert. 
Vielleicht liegt es daran, dass der P-Kanal Mosfet andere Kenndaten als 
der N-Kanal hat.
Wenn du es rausgefunden hast, würde ich mich über ein Post freuen.

Gruß
PP

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
daß pos. und neg. Seite unterschiedlich sich verhalten, liegt einfach 
daran, weil beide Seiten nicht wirklich symmetrisch sind. Schaon der OPV 
ist innerlisch nicht wirklich symmetrisch, und die Mosfets 
wahrscheinlich auch net.

Autor: Bernte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey

Ich hab jetzt die FETs gegen neue getauscht, den Käfer gewechselt und 
die Kondensatoren rausgenommen. Keine Schwingung mehr zu verzeichnen. 
Jetzt hoff ich natürlich, dass die nicht irgendwann wiederkommen.

Ansonsten vielen Dank an euch alle. Falls ihr noch ein paar Ideen habt 
wie ich das aktuelle Design stabilisieren kann (Platine ist wie gesagt 
leider schon fertig, aber paar WIderstände oder Kondis könnt ich auf der 
Rückseite aber schon noch aufbringen) immer her damit.

Viele Grüße
Bernd

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.