www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik aus 9V Versorgungsspannung 6V(?) für Dev-Board "abzweigen"


Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo NG,

Ich habe hier ein Dev-Board:
http://www.olimex.com/dev/index.html

Bisher bekommt das Teil immer den Strom von USB. Jetzt möchte ich das 
Ganze getrennt vom Computer betreiben.

--------------------------------------------------
Auf der Seite steht:
single power supply: 6V AC or DC required.

Allerdings kann man auf dem Board links unten beim Anschluss erkennen:
  6 VDC
4.5 VAC

Was hat das zu bedeuten?
--------------------------------------------------

Die eigentliche Frage:

Ich habe einen Soundchip, der momentan an eine 9V-Quelle angeschlossen 
ist. Von dieser Quelle würde ich gerne die Spannung für das Board 
erzeugen. Was kann man denn da am einfachsten nehmen?

Vielen Dank schon jetzt für jeden Hinweis,
Peter

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...sorry, der Link stimmte nicht:
http://www.olimex.com/dev/sam7-p256.html

Autor: Billydeedaniels (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

das Ding hat einen Brückengleichrichter drin.
Du kannst also deine 6V Gleichspannung oder eben 4,5 V Wechselspannung 
anlegen. Der Spannungsregler macht dann daruas 3,3V.
Sofern die 9V Gleichspannung sind, kannst du folgendes machen:

- einen 7806 dazwischen
- oder die überschüßigen 3 V verbraten z.b. Widerstand oder Dioden
- 9 V belassen und auf ausreichend Kühlung des LM1117 achten.

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... und dieser 7806 ist dann alles, oder muss man da noch zusätzliche 
Bauteile anschließen?

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du kannst deine 9V direkt anlegen,
es ist ja schliesslich ein Spannungsregler drin,
der bis 20V aushält,
und der verkraftet auch das 1 Watt das bei 100mA
Stromverbrauch entsteht.
Solltest du allerdings zusätzliche Elektronik
aus den 3.3V oder 1.8V des Boardes versorgen,
prüfe ob der LM1117 schon kocht (Wassertropfen
drauf, kocht der nicht, ist es in Ordnung).

Autor: Rainer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der 7806 braucht meist an Ein- und Ausgang mindestens ein paar kleine 
Kondensatoren (100nF).

Ich würde aber ruhig die 9V direkt anschließen und die Temperatur vom 
L1117 dabei prüfen. So wie das Layout vom Board aussieht, wird die Wärme 
auf eine recht große Kupferfläche geführt. Es kommt natürlich drauf an, 
was für Stromverbraucher sonst noch am Board hängen. Im Datenblatt vom 
LM1117 stehen die thermischen Parameter alle drin.

Gruß
Rainer

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...hab eben mal kurz die 9V direkt angeschlossen. Das Display bleibt zum 
einen dunkel, zum Anderen startet der Player scheinbar nicht 
(wahrscheinlich, weil der 1MHz Oszillator für den Soundchip keine 5V von 
USB bekommt.)

Wahrscheinlich sind die 5V von USB direkt an die Anschlussleiste 
geführt?

Somit habe ich - so denke ich eigentlich die Thematik, dass ich das 
Board über 5V am USB-Eingang speisen muss, oder?

Also brauche ich wohl 9V für den Soundchip und 5V für den USB-Eingang.

Gibts da auch einen Passenden Spannungsregler?

Wie stehen die Chancen, dass dieses Bauteil ein kleiner Elektronik-Laden 
hat? Ist das Standard oder doch eher speziell?

MfG
Peter

Autor: Rainer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann ist dein Problem aber nicht die Stromversorgung vom Dev-Board, 
sondern die vom Player.

Guck dir mal deine Gesamtschaltung an, wer woher seinen Strom bekommt.

Gruß
Rainer

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, da gebe ich Dir Recht, dass es kein Problem vom DEV-Board ist. Ich 
dachte nur, dass die 5V, die ja auch an der Anschlussleiste des 
DEV-Boards herausgeführt werden vom Board erzeugt werden. Aber die sind 
dann wohl nicht vorhanden, wenn kein USB-Kabel angeschlossen ist.

Deswegen muss ich nun doch aus den 9V die 5V generieren. Werde mal am 
Samstag zum Elektronik-Laden schauen...

MfG
Peter

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo NG,

jetzt wollte ich nochmal kurz fragen:

ich habe ein 9V Netzteil. Davon möchte ich 5V "abzweigen".
geht das mit dem hier:

http://www.reichelt.de/index.html?;ACTION=7;LA=28;...

Auf Seite 3 sind 3 Schaltungen. Genügt mir das Figure 1 ?

Danke schon mal.
Peter

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo NG,

so, jetzt habe ich am SA meinen 78M05 bekommen und einen 5V-Zweig 
angelegt. Der Elektronikhändler meinte, der macht bis 1A mit. 
Kondensatoren sagte er, brauche ich auch nicht. Funktioniert alles super 
soweit.

Jetzt wollte ich nur noch kurz wegen der Kühlung fragen:

Das "Fähnchen" wird ungefähr so heiß wie ne Tasse Kaffee. Ist das noch 
OK? Oder muss immer ein Kühlkörper ran?

MfG
Peter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.