www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Entering programming mode.. FAILED!


Autor: Jan B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leutz

Ich habe folgendes Problem und verzeit mir diese vielleicht blöde
Frage.
Momentaner Status:
Avr Studio 4.11 Servicepack 3
Avrisp

Nach der Installation des von Avr-Studio hat das Programm mir gesagt
das ich die Firmware des Avrisp auf 2.0 updaten soll.
Habe dann ja gedrückt.
Er hats geschrieben und überprüft.
Danach war die Led aus.
Erst einmal Spannung weg und wieder dran hat ihn wieder zum Leben
erweckt.  ( Initialisierung  rot orange  grün blinkend und dann
dauergrün )

Die Verbindung geht also bis zum Avrisp.
Wenn ich jetzt allerdings das Device auswähle und versuche meine .hex
File draufzubekommen erscheint folgende Fehlermeldung.
Entering programming mode.. FAILED!
Leaving programming mode.. OK!
Dasselbe passiert wenn ich auf die Registerkarten Fuses und Lockbits
zugreifen will.


Hab ich was kaputt gemacht ?

bitte helft mir.

mfg Jan

Autor: Rüdiger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
Hat dein Avrisp vorher funktioniert ?
Welchen Controller willst du flashen ?

Rüdiger

Autor: Jan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe den Avrisp und den MC ( At90s2313 ) ganz neu gekauft.
Mit beiden wurde noch nie geflasht sie sind ganz frisch.
Ich bin mir auch sicher das ich keine Fuses verstellt habe, da es ja
von
anfang an nicht ging.
Beim Firmwareupgrade kommt er auch in den upgrade mode. Er kommt
allerdings nicht in den Programmiermodus.

Autor: Jan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tschuldigung wegen der Rechtsschreibfehler

Also sagen wir es so ich habe keine Fuses wissentlich verstellt, aber
es
hat ja nie funktioniert also sollten die auch nicht verstellt sein.
Einmal hatte ich die ISP Frequenz auch so gewählt das
Entering programming mode.. FAILED!
Leaving programming mode.. FAILED!

kam. Wisst ihr was ich machen muss.

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie betreibst du den 2313??? Mit Quarz?

Autor: Jan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja an Xtal 1 und Xtal 2 liegt ein Quarz mit 1 Mhz

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und auch sonst ist er so beschaltet, wie es sich gehört? Nicht, dass du
evtl. Mosi und Miso vertauscht hast, oder vergessen hast, den Reset zu
verbinden oder dergleichen.

Autor: Jan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nene das ist alles dran und da wo es hingehört

Autor: Jan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Problem gelöst
Habe ein falsches Quarz eingelötet ich depp
muss mindestens 8 Mhz haben und ich hab 1mhz eingelötet
Ausgetauscht und schon gehts

Der Mc macht noch nicht das was ich will aber das kriege ich auch noch
hin

danke für eure Bemühungen

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sollte eigentlich nicht das Problem sein. Immerhin werden die ganzen
neueren mit internem Oszillator mit 1MHz-Einstellung ausgeliefert, und
die lassen sich auch proggen.
Da ist wohl eher dein Quarz kaputt.

Autor: hans müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
da muss nicht unbedingt der quarz kaputt sein...
das avrisp rammelt da mit der vollen geschwindigkeit drüber.

(schreib mal ne blinke oder so etwas (mit langen pausen) so dass du was
siehst und häng mal den 1 mhz quarz dran)

dann würde ich bei den lockbits aufpassen, da gibt es einen bug mit den
at90 in avrprog

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.