www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 433 Mhz


Autor: Raymond (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo AVR-freaks,
wer hat schon mal erfolgreich die Conradmodule 130428
mit einem AVR (8515) verheiratet?
Mich interessiert der Hardwareanschluss
und evtl ein einfaches Testprogramm
und dies vorzugsweise in Bascom.
Ich habe zwar Threads gefunden aus 2002/2003
aber noch nirgendwo eine Erfolgsmeldung gesehen.
Ich möchte z.B. Aussentemperatur und -feuchte
drahtlos an meine Haupstation übertragen.
Wäre für jeden Hinweis oder evtl Lösung dankbar.
Raymond.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
ich häng mich jetzt mal hier ran.
Ich habe mir jetzt beim Conrad auch das "SENDE-/EMPFÄNGERMODULSET 
433MHZ"
gekauft
aber habe noch Probnleme mit dem Signal zu übermitteln
wenn ich mit einem Multimeter das ausgangssignal messe habe ich einen 
wert von
max 0,8V
d.h. ich kann das Signal nicht mehr richtig auswerten.
hat jemand erfahrung mit dem Modul?
ich habe vor mit einem AVR daten zu übertragen habe es jetzt erst mal 
mit 2 PC's versucht bei denen ich über nen Max232 die daten umgewndelt 
hab.... leider ohne Erfolg. :-(

thx Timo


Autor: Tobias Paul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sorry aber das hilft mir ganit weiter....

Autor: Carsten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welches Ausgangssignal hast du gemessen? Die 433 MHz? Mit einem 
Multimeter???

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein der sender moduliert das serielle Signal auf die 433Mhz und der 
Sender sollte das wieder in das normale serielle signal umwandeln ....
so die theorie.....
gemessen habe ich ich am "data" vom Empfänger.....

Autor: Timo S. (hoserunter)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi, habe mir das alles mal aus interesse angeschaut, und habe das 
Problem mit deinen 0,8 Volt gefunden.? oder nicht ?

Schau einfach mal in den Anhang, dort habe ich die Anleitung dafür.

Seite 8 bitte, da dies die Multilanguage Anleitung ist.

Autor: Timoum (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ah danke
hat jemand ne Idee wie ich das hinbekomme???
einfach 2 transistoren??
PNP und NPN ( umd das Signal zu verstärken und wieder zu invertiren)
oder giebt es da auch nen Pegelwandler mit dem ich das einfacher/besser 
hinbekomme?

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Keiner ne Idee?

Autor: Freudi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Thema hatte ich Anfang letzten Jahres. Un dhatte mich Stück für 
Stück vorgearbeitet. Als erstes habe ich ein Recheckgenerator mit 555 
zusammengeschweisst und den Sender mit ca 800 Hz getastet und mit einem 
Oszi am Data eingang geschaut was ankommt. Bei mir waren das 1a TTL (5V) 
Impulse.
Dann habe ich mit dieser Schaltung und verschiedenen Antennen 
experiementiert bis ich ein sauberes Signal von der Terasse bis zu 
meinem Büro hinbekommen habe ( 15 m 2 mal Ytong Wände ). Bei mir hat 
sich eine Groundplane als Senderantenne als beste herausgestellt. Als 
das lief habe ich den Data-Ausgang des Empfängers an den 
InterruptCapture Eingang eines ATMEGA128 (STK500) gelegt, ein LCD 
angeschlossen und die Pakete eines vorhandene RF-Thermometers 
entschlüsselt.
Dann habe ich im Sender den 8515 dahingehend programmiert das er ein I/O 
Pin entsprechend schaltet, also nichts mit UART sondern ich habe einfach 
die Zeiten genommen die ich für jedes Bit/nicht Bit ermittelt habe und 
für diese Dauer ein Pin High/Low geschaltet.

Soviel zum Prinzip.Funktioniert bei mir mit inzwischen 2 Sendern von 
Conrad jeweils mit 8515 angesteuert. Der Empfänger läuft immer noch im 
Bastelstadium am STK500 mit ATMEGA128. Zu allen Detailfragen 
(Antenne,Protokoll usw.) gibt es hie reigentlich genug antworten. 
Quelltext kannste auch gern haben, Aber bei Deinem Problem würde ich mit 
der Übertragung eines simplen Rechtecksignals anfangen.

An meinen Data-Ausgang des selben Moduls liegt immer Astreiner 
TTL-Pegel.

Freudi

Autor: Dennis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo freudi,

ich habe auch einen thread zum thema hier, experimentiere mit modulen 
aus funksteckdosen, ist eh alles die selbe schose...

du hast mit antennen experimentiert!? hast du auch mal eine antenne an 
das empfängermodul gekoppelt - wenn ja - wo!?

zudem ist der mist scheinbar nicht angepasst, d.h. mit 50ohm antennen im 
433mhz bereich - banane...

was ist die höchste datenrate die du übermittelt hast!?

gruß,
dennis

Autor: Dennis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Freudi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Am Empfänger habe ich bis jetzt nur das Kabelstückchen was dabei war.
Was wirklich was gebracht hat war die Groundplane am Sender. Dazu habe 
ich Koaxkabel 50 Ohm, altes Netzwerkkabel genommen und am Ende ein 
"Stecker/Buchseadapter" in die Mitte der Buchse habe ich eine angefeilte 
17 cm lange Fahrradspeiche gesteckt und im Winkel 45° nach unten 4 mal 
dicke Kupferschutzleiter. Sieht primitiv aus funktioniert aber bestens. 
Am Empfänger habeich das aber nicht probiert, weil der in der Küche 
hängen soll und da kriege ich Ärger mit der Frau wenn da , ich zitiere, 
"So'n Ding hängt"

Freudi

Autor: Dennis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
naja, so zu 67% kann ich mir da etwas drunter vorstellen.... aber ich 
ahbe auch schon überlegt das einfach mit einem stück draht 
zuversuchen....

d.

Autor: Freudi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Kann jetzt schlecht zu Hause nen Foto machen. Aber meine sieht im 
Prinzip genauso aus wie de Snapshot. Die Radials ( die Dinger die nach 
unten zeigen ) sind mit dem Schirm des Koaxkabels verbunden.

Freudi
uebrigens DO2FRE ( darf ich garkeinen erzaehlen )

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.