www.mikrocontroller.net

Forum: Compiler & IDEs Übertragungsrobleme mit STK500


Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich experemtiere seit längerer Zeit mit dem STK500 EVAL-Board von
Atmel. Als C-Compiler verwende ich CodeVisionAVR.

Bis jetzt hat immer alles super funktioniert, aber seit gestern Abend
wird das Programm nur sehr langsam in den Controller geschrieben. Aber
es wird fehlerfrei geschrieben, nur halt sehr langsam. Das Austauschen
den des Controllers (8515) hat auch nichts gebracht. Auch mein Laptop
spielt die Daten nicht schneller ein.

An was kann das liegen??

Markus

Autor: mthomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1 - Frage in diesem Forum ("gcc") deplaziert.
2 - Wie ist die ISP-Frequenz des STK500 eingestellt?
3 - ATmega8515 oder AT90S8515?

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry wo hätte die Frage denn hin gesollt?

Es handelt sich um den AT90S8515. Der ATMEGA16L hat das gleiche
Problem.

Die Einstellungen für die ISP-Frequenz habe ich nirgends gefunden.

Aber jetzt geht es plötzlich wieder?? Warum?? Ich nur im AVR-PROG mal
den AT90S8535 ausgelesen.

Danke für die schnelle Antwort.

Markus

Autor: Jörg Wunsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Sorry wo hätte die Frage denn hin gesollt?

Die Frage solltest du dir wohl bitte vor dem Posten stellen.  So
unaussagekräftig sind die Beschreibungen der Foren ja wohl nicht.

Sie hätte ins allgemeine Forum gehört (,,Microcontroller und
Elektronik'').  In diesem Forum hier wäre sie bestenfalls am Platz
gewesen, wenn du parallel zu AVR Studio nochmal avrdude oder UISP
benutzt hättest und diese gleiche Effekte gezeigt haben.  Diese beiden
Programmiertools werden die Teilnehmer des Forums sicher noch im
weiteren Sinne als zur GCC-Toolchain für den AVR zugehörig anerkennen.

Autor: Steffen Brüssel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Brennt hier die luft?

Also mit neueren Versionen des AVR Studio gibts immer ne neue Firmware.
irgendwie senkt die die Schreibgeschwindigkeit. du kannst die aber im
AVRStudio wieder erhöhen.
und Zwar im Programmierinterface unter Reiterkarte 'Board'
Stell da einfach die ISP Freqenz höher ein und fertig. Beachte aber max
1/4 des Prozessortaktes. Geh lieber etwas vorsichtiger ran ich hab
460kHz eingestellt, das ist schon wieder recht flink.

Gruß

Steffen

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.