www.mikrocontroller.net

Forum: Platinen Anfängerfrage - Problem beim Bauteileerstellen mit Eagle


Autor: Malte Jahn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

bin nun gestern von Target auf Eagle umgestiegen. Nun will ich auch
gleich lernen wie man Bauteile erstellt. Als erstes sollte ich ein SMD
Uhrenquarz(Reichelt) haben. Vorgehensweise war:
- neues Package mit SMD Pads erstellt. Im Layer tPlace die äusseren
Abmessungen gemalt. Auch >name und >value
-neues Symbol mit zwei Pins. Die Namen der Pins habe ich nicht
geändert. >name und >value und einen Rahmen umd das Bauteil im Layer
Symbols eingetragen.
-neues Device. Mein Symbol importiert. Prefix definiert. Nun die Pins
den Pads zugeordnet(G$1.P$1 -> P$1, G$2.P$2 -> P$2)

Das Problem ist jetzt, das zwar die Luftlinien(z.B. bei meinem Quarz
und einem PCF8583) zwar angezeigt werden, der Autorouter aber keine
Bahn zieht. Auch von Hand ist das nicht möglich.
Habe ich einen Schritt übersprungen?

Gruss
Malte

Autor: Gerhard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Malte,

evtl. musst Du bei der Sym.-Definition kurz ein kleineres Raster
nehmen.
oder Du probiertes mal das manuelle Routen von Hand, aber vom Bauteil
ausgehend arbeiten.

Aber hier gibt es eine schöne Anleitung zur Def. eigener lbr's.
http://www.amateurfunkbasteln.de/eagle_lib/eagle_lib.html

mfg Gerhard

Autor: Jürgen Schuhmacher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche DEF haben die Pins?  (IO, Power ...)
Blinken die Symbolpins mit, wenn man das Signal aktiviert, durch z.B:
"show"?

Autor: Malte Jahn (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Danke für den Link. Leider bin ich noch nicht weitergekommen.
Die Pins sind als I/O´s definiert. Wenn ich z.B. show N$2 eintippe, so
ist die entsprechende Linie heller(im Schaltplan). Im Layout die Pads
samt Luftlinie.

Im Anhang ein Bild des Layouts.

Gruss
Malte

Autor: Kurt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für mich hört sich das schon ein wenig, so an, als ob die Pins nicht
korrekt sitzen.  Wenn man aber mit Route auf der Seite des Bauteils
anfängt, müsste der blaue/rote wire in jedem Falle DORT entspringen-
selbst wenn er NICHT im Raster sitzt. Geht das ?

Autor: PeterL (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo

was sind die unteren roten Linien (schraffiert) eventuell im tRestrict
Layer , dann dind sie fürs Routen nicht erreichbar
versuche mal mit mirroe beide Bauteile auf Bot zu spiegeln
kannst du dann routen?

Peter

Autor: Jürgen Schuhmacher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hänge doch einfach mal Deine Lib hier rein.

Autor: Malte Jahn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

seit gestern Abend versuche ich mich an diesem Bauteil. Und nun scheint
es dieses tRestrict zu sein, das der Router ignoriert.
Wie kann ich das im Layout deaktivieren, das der Router Sperrflächen
berücksichtigt? Weil auch von Hand gezogene werden auch ignoriert.
Und noch was. Wie kann ich das Routen Rückgängig machen. Undo
funktioniert dann ja nicht mehr.

Gruss
Malte

Autor: Malte Jahn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Teil 2 meiner frage habe ich gerade selbst herausgefunden: Ripup.
Komisch ist, das der Router trotz Sperrfläche unter dem SMD Teil ein
Verbindung verlegt und das zu meinem Quarz(also scheint das Teil
Richtig zu sein)

Autor: PeterL (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
in einer Sperrfläche darf kein Pad, Via oder Wire sein - dafür gibt es
sie ja !
also beim unteren Bauteil Sperrfläche ändern oder entfernen sonst
geht es nicht, spätestens beim Abschließenden DRC (Design Rules Check)
wird es Fehlermeldungen geben

Peter

Autor: Malte Jahn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ahhhhh. Ich habs. Der Routing Grid war Standardmäßig auf 50mil.
Gibt es sonst noch irgendwelche Einstellungen die ich im Router machen
sollte/sinnvoll sind?

Gruss
Malte

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.