www.mikrocontroller.net

Forum: Offtopic Atmel AtMega8515


Autor: Ingwersen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Ihr,
ich habe ein Problem mit dem Austausch von dem AT90S8515 mit dem
MEGA8515.
Ich habe festgestellt, daß die Baudrate (19200) nicht stimmt.
In der Schaltung wird ein 8 MHz Quarz benutzt, was bei dem
90S8515 kein Problem war. Aber bei dem MEGA8515 gibt es mehrere
Möglichkeiten.
- Interner Oszillator
- externer Oszillator
- Quarz
Die Optionen kann man über die Fuse Bits einstellen.
Das Programmiertool ist ein STK 500.
Ich habe das Problem, daß ich aus dem Datenblatt nicht verstehe,
was für ein Fusebit ich für den 8MHZ Quarz einstellen muß.
Es gibt zu viele Möglichkeiten.
Ausprobieren kann ich das auch nicht, weil nach einmaliger
Programmierung der Fuse Bits sich nichts mehr programmieren läßt.
Auch nicht die Software.
Vielleicht könnt Ihr mir weiterhelfen

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was hast du denn eingestellt bevor es nicht mehr lief? meist hilft ein
externer takt an xtal1 um den uC wieder programmieren zu können. das
thema war aber schon sehr oft, die forensuche sollte viele ergebnisse
liefern

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Yahoo-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.