www.mikrocontroller.net

Forum: Offtopic AVR USB dev board aus dem Shop


Autor: Marius Schmidt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich wollte nur mal meine unzufriedenheid hier kund tun, denn das AVR
USB dev board aus den shop ist zwar relativ preisgünstig hat aber, rein
vom design, meiner Meinung nach ein paar Fehler:

- Der Reset IC der auf dem Board verbaut ist hat bei mir in zufälligen
intervallen einfach den chip reseted (vielleicht wegen der nicht ganz
so perfekten USB spannung? Daran sollte man aber denken wenn man ein
USB dev board entwickelt). Ich hab ihn raus gelötet und das board
funktioniert!

- Der 8 Mhz Quarz ist ziemlich ungeeignet um RS232 standard-baudraten
zu benutzen (meiner war aus irgend einen Grund ein 10 Mhz quarz) was
wohl ziemlich schlecht ist wenn man den FT232BM richtig benutzen will.
Ausserdem dreht mein AVR immer durch wenn ich das quarz berühre - ist
das normal bei quarzen oder stimmt da irgendwas nicht?

- Die löt-pads auf der unterseite gehen ziemlich leicht ab, ich bin aus
versehen ein wenig gröber mit meiner lötspitze rüber gegangen und hatte
gleich ~4 von den pads an meiner spitze kleben ;(

- Es gibt keinen Jumper um fest zu legen ob sich das device als low-
oder high-speed device anmelden soll

Falls jemand auch Erfahrungen mit den board gemacht hat könnt ihr es
hier gerne posten, oder falls ihr ein besseres board kennt was im
grunde die gleichen funktionen hat (ich fand dieses board recht gut
weil es nicht soviele LEDs, schalter und sonstigen test-kram drauf
hat).

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"- Der 8 Mhz Quarz ist ziemlich ungeeignet um RS232 standard-baudraten
zu benutzen (meiner war aus irgend einen Grund ein 10 Mhz quarz) was
wohl ziemlich schlecht ist wenn man den FT232BM richtig benutzen
will."

Warum langsame Standard-Baudraten nutzen, wenn man einen solchen IC
hat? Nutz doch einfach 250kBaud, 500kBaud, ...

Autor: Marius Schmidt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja klar, aber der FT232BM mag auch nicht alle baud raten, am besten
funktioniert es halt mit standard baud raten glaube ich... Auf jeden
Fall habe ich komische Übertragungsprobleme selbst bei einfachsten
Anwendungen (mal schauen ob ich am montag ein besseren quarz finde...)

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der hat doch ein Divide-Register mit dem du freie Hand hast! Dann
brauchst du dich auch nicht mehr mit den Standardbaudraten ärgern.

Autor: Marius Schmidt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok mein Problem lag woanders... siehe hier:
http://www.mikrocontroller.net/forum/read-2-199111.html#new

Aber trotzdem kann man mit dem quarz auf den board keine standard
baud-raten erzeugen :P

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Yahoo-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.