www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik SPI-ubertragung


Autor: andi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich wurde gerne bytes uber die seriell rausschicken,
jedoch funktioniert es nicht.kann mir jemand sagen wo der fehler ist.
.include "8535def.inc"

anfang:
ldi r18,0b01010000
out SPCR,r18

ldi r19,0b00001111
out SPDR,r19                       register

fertig:
sbis SPSR,SPIF
rjmp fertig
rjmp anfang

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Andi,

ich mag mir solche Programme nicht anschauen.
Da weiß man doch nicht, was Du willst.

Warum verwendest Du nicht die Symbole ?

Dann siehts doch viel verständlicher aus, z.B.:

        ldi     a0, 1<<CS02^1<<CS01^1<<CS00     ;T0 count on rising edge
        out     TCCR0, a0


Peter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.