www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Handy am ATmega


Autor: Thomas P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Die Such-Resulate habe ich ausführlich studiert, leider aber nichts
passendes gefunden.
Ich möchte das Handy über den ATmega8 ansteuern und habe das Handy mit
dem ATmega verbunden, ohne MAX232 -> hatte eine Schaltung hier im Forum
gefunden (1K Widerstand je Datenleitung, mit Z-Diode 2V7 geg. Masse
gezogen).
Die Zeichen, z.B. AT sende ich als einzelne Zeichen und schließe die
Übertragung mit "0x0d" ab. Das Handy antwortet nichts. Beim Anruf auf
dem Handy empfange ich auch kein "RING".

Muss ich irgendeine Pegel-Anpassung dazwischen schalten? Kann ich mir
aber nicht vorstellen, da ich den Pegel mit den 2V7 Dioden eh wieder
herunterziehe...

Über eine Nachricht würde ich mich freuen.

Gruß

Thomas

Autor: Jörn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch ein paar Fragen

Was für ein Handy?
Baudrate des Mega8?
Versorgungsspannung Mega8?

Hinweise:
Übertragungen abschliessen mit 0x0D 0x0A

Gruß Jörn

Autor: Thomas P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

0x0d und 0x0a habe ich schon probiert, ohne Erfolg.

Baudrate: alles von 9600 bis 38400 versucht. MEGA8 über 7806 Stabi!
Handys habe ich versucht Siemens M35, M45 und S65...Alles ohne Erfolg.
Schließe ich einen MAX dazwischen und übertrage zum PC, dann kommen die
Zeichen sauber rein!

Gruß

Autor: Jörn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Atmega über 7806 ?!? oder nur ein Schreibfehler und du meinst 7805.

Ich hab immer 19200 als Baudrate verwendet.

Verwende mal eine andere Z-Diode. 3V3 oder 3V6.

Datenleitung vom Handy -> M8 nur über Widerstand anschliessen.

Autor: Thomas P. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So - habe das nun auch alles versucht. Keine Chance...ich weiß nicht,
warum es nicht geht.
Es ist doch richtig, dass ich immer einzelne Zeichen sende, oder? -
Anders ist es ja garnicht möglich ?!

Vielleicht hat noch einer einen evtl. entscheidenden Tipp...

Grüße vom verzweifeltem Thomas

Autor: Jörn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast dir mal mit dem PC angeschaut was der ATMega an Daten sendet ?

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du kannst die TxD und RxD Leitungen an einen L Version des ATMEGA 8
anschliessen ( direkt) aber nur bis Ue=3 - 3,6 V klappt wunderbar :-)

Habe es mit einen C35i ausprobiert und sollte auch bei M35 , xx45 auch
klappen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.