www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Fehler ICS 1702 ?


Autor: Sven (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

eine Ladeschaltung mit dem Controller ICS1702 (nach Klaus Leidinger)
geht nach dem Einschalten sofort in den Lademodus, obwohl kein Akku
angeschlossen ist (hat aber schonmal funktioniert).
In einer minimierten Testschaltung (siehe Bildanhang) der gleiche
Effekt, auch bei einem nagelneu bestelltem IC.
Habe ich bei der Testschaltung was übersehen oder hat die den neuen IC
sofort gekillt? Bin mir da eigentlich keines Fehlers bewußt.

Danke im Voraus für die Infos,

Sven

Autor: Age Bee (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sven,
ich habe einen ähnlichen Effekt bei mir.
Konntest Du den Fehler inzwischen finden ? Ich habe eine gekaufte
Platine verwendet mit gekauften Bauteilen. Also ist bei mir nix falsch
verdrahtet. Die Schaltung hat mal funktioniert aber aus irgendwelchen
Gründen scheint der IC jetzt kapuut zu sein.
Grüße
Harald

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Harald,

der vermeintlich defekte IC hat sich als doch nicht defekt
herausgestellt. Mit dem Ersatztyp war der gleiche Effekt.
Ich habe je nach gewählter Zellenzahl (meist bei einer Zelle) diesen
Effekt. Wenn man dann einen Akku kurz anschließt, wird er jedoch
korrekt geladen und nach entfernen desselben ist die Anzeige dann auch
richtig. Also einfach mal probieren, wird wahrscheinlich gehen. Mal auf
eine andere Zellenzahl umschalten (wenn die Platine bei dir das hergibt)
bzw einfach mal eine Zelle laden.
Bin sehr zufrieden mit dem Gerät. Habe noch einige Umbauten gemacht,
damit ich auch Einzelzellen gut laden kann (es war ein
Entladetransistor eingesetzt, wo wenigstens 3 Zellen nötig waren, damit
der richtige Entladestrom fließt und ein PWM-Laderegler ist gerade im
Bau, um die Verlustleistung im Ladezweig zu senken).

Viel Erfolg ;-)

Sven

Autor: Klaus Leidinger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

der 1702 ist leider sehr empfindlich in der 1 Zellen Einstellung, da
der Vin Pin im IC nicht ordentlich abgesichert ist. Oft reicht es hier
einen (mehrzelligen) Akku anzuschliessen bevor die Ladeschaltung unter
Spannung ist um das Ding zu killen.

Zu empfehlen ist die Schaltung eigentlich nur für mehrzellige Akkus.
Alle IC Defekte die ich kenne wurden in der 1 Zellen Einstellung
verursacht.


@Sven, eventuell funktioniert die Resetbeschaltung nicht sauber, oder
der Akku ist schon vor dem einschalten angeschlossen?

@Harald, Du kannst versuchen die Spannung am Vin Pin zu messen (ohne
angeschlossenen Akku) Wenn ich mich recht erinnere darf da dann nichts
anliegen. Ich tippe aber auf einen Defekten IC (1 Zellen Akku?)

HTH,
Klaus

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.