www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Taster-Problem


Autor: Markus Wentker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe eine kleine Schaltung mit 2 Tastern an einem Atmel Mega8.
Die Taster sind nach dem Tutorial über PullUps angeschlossen.
Bisher gab es damit bei anderen Schaltungen keine Probleme.

Bei meiner neuen Schaltung habe ich jetzt allerdings folgenden Effekt:

Obwohl die Taster die Eingänge des Atmels beim Drücken auf Masse ziehen
und sie im nicht-gedrückten Zustand auf +5V liegen, reagiert der Atmel
nicht (er läuft aber, wie ich durch einen Flagpin nachweisen kann).
Wenn ich jetzt aber das ISP-Interface (gleiche Bauart wie hier im Shop)
aufstecke, reagieren die Taster.

Alle VCCs, AVCC, GNDs sind angeschlossen. Ansonsten hängt nur noch eine
DIN-Buchse am TXD für MIDI und ein LCD ist an Port C angeschlossen.
Beide funktionieren.

Hat jemand ne Idee? Bin da etwas ratlos.

Verbindungen habe ich alle mit Multimeter überprüft.

Gruß
Markus

Autor: Jens. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hmmh
hast du den taster auch mit dem pullup auf VCC gezogen??
ich habe gerade nicht den schaltplan vom isp im kopf aber es kann sein,
dass der die leitung auf VCC legt
schsu dir das noch mal an mit dem widerstand

Autor: Markus Wentker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

Ja, die Taster (bzw. der Eingang des Mega8, aber ich denke das meinst
du), sind über 10k Ohm-Wiederständer auf Vcc gezogen.

Btw.: Den Mega8 habe ich auch schon ausgetauscht, daran liegts nicht.

Autor: Markus Wentker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe jetzt mal direkt an den Eingangspins eine Masseverbindung
hergestellt (n Stück Draht nach Masse drangehalten).
Zunächst ebensowenig eine Reaktion.
Plötzlich reagiert das Dingen dann aber und dann sind auch die Taster
durchgängig und ohne Probleme benutzbar - bis zum nächsten
"Neustart".

Also: Sehr unzuverlässig, nur wenn es einmal läuft, dann durchgängig.

Sehr komisch...

Autor: ...HanneS... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Resetpin über Widerstand nach Vcc gelegt?

...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.