www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Megaload und Device


Autor: hodoe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, habe unter XP Megaload .NET V4.0.b2 installiert. Sobald ich mein
AVR-CTRL an die serielle Schnittstelle meines Notebooks stecke
erscheint Programming flash ... please wait. Unter Target findet
Megaload aber nicht das richtige Device. Nacheinander werden Mega48,
Mega64, Mega163,Megaxxx ... angezeigt. Programmiert wird nichts. Ich
habe einen fertigen Bootloader (hex-File) und die Fuses entsprechend
der Homepage von microsyl mittels ISP und PonyProg programmiert.
(http://www.roboternetz.de/phpBB2/dload.php?action=...)
verwendet.

Any hints?
Holger

Autor: Werner B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuche mal verschiedene baudraten, beginnend mit der schnellsten.

Autor: moin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich quäle mich auch gerade mit megaload ab. Bei mir scheint gerede nut
eine ältere Version zu funktionieren. Megaload 4 stürzt immer wieder ab
und funktioniert nicht mit meinem USC-Seriell-Wandler.
Probiere es mal mit der Version 2.3. Hast du dir die Dateien angepasst
und neu kompiliert?
Euer moin

Autor: hodoe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

neu angepasst und kompiliert habe ich nichts. Die Hex-Dateien sind ja
eigentlich fertig. Die RS232-Kommunikation funktioniert garantiert. Wo
bekomme ich eine ältere MegalLoad Version denn her?

Gruß
Holger

Autor: moin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du die emailadresse angiebst, kann ich sie dir mailen. Als Anhang
ist die Datei für dieses Forum zu groß (ca 2 MB)
Ich musste die Dateien für den Mega neu kompilieren um den UART1
verwenden zu können und habe auch den Quarz angegeben.
Welche Hartware verwendest du?

Euer moin

Autor: hodoe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

so ich habe jetzt MegaLoad 2.3 am laufen. Den Bootloader habe ich aus
diesem Threat
(http://www.mikrocontroller.net/forum/read-4-183976.html#new). Alles
mit PonyProg entsprechend der MegaLoad-Anleitung gemacht. Das
Programmieren funktioniert. Was mich nur stutzig macht ist die
Tatsache, dass Megaload immer einen Mega 161 erkennt. Verbaut habe ich
aber einen Atmega32. Ganz sicher ;-)

Gruß
Holger

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.