www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik UART Problem mit IgorUSB


Autor: see4far (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Brauch mal dringend eure Hilfe!
Ich setze hier IgorUSB
8http://www.cesko.host.sk/IgorPlugUSB_RS232/IgorPlu...)
in meinem Aufbau (AVR kommuniziert über IgorUSB mit Laptop) ein. Erst
hab ich mich die ganze Zeit gewundert, dass mein AVR ständig 0x00-Bytes
sendet, obwohl ich das gar nicht gewünscht hatte, jetzt hab ich aber mal
einen anderen PC über die serielle Schnittstelle mit IgorUSB verbunden
und kriege auch ständig 0x00en am Laptop ab. Wenn ich mit dem Laptop
über IgorUSB sende, passiert das nicht. Ist also nur beim Empfangen!
Hat irgendjemand ne Idee, wodran das liegen könnte??? So kann ich
absolut nicht damit arbeiten - muss ich aber unbedingt!!!

Danke für eure Überlegungen.

Simon Fabian

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.