www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik µC - Probleme mit Relais


Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

ich bin grade dabei mir ein kleines avr-bastelkit zusammenzustellen.
beim schalten eines motors über ein relais (schutzdiode hab ich
drinnen) hatte ich dann ein "aha-erlebnis".
die dabei entstehenden induzierten spannungsspitzen führten dazu, dass
sich der µC bzw. auch der prozessor vom display "aufhängten".

da ich anfänger bin bitte ich euch mir ein paar tips zu geben wie man
hier am besten vorgeht.

danke vorab mal.

Autor: Christoph Lechner (clechner)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also fangen wir mal an:
* Blockkondensatoren, d.h. Keramikkondensatoren mit 100n, vorhanden?
Wie viele insgesamt?
* Was für sonstige Kondensatoren?
* Steuerst Du das Relais mit einem Transistor?
* Was für eine Diode verwendest Du als Schutzdiode?

- cl

Autor: Christoph Lechner (clechner)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Achso noch was:
Hängt sich der uC nur dann auf, wenn der Motor angeschlossen ist oder
auch dann, wenn der Motor nicht angeschlossen ist?
Wie viel Power hat Dein Motor denn?

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,

also ich habe mit 1x 0.1µ vor diode (1N4148) probiert, hatte jedoch
selbige probleme.

* Was für sonstige Kondensatoren?
0.1µ bei µC -> VCC.

* Steuerst Du das Relais mit einem Transistor?
ja, hatte bc337-40 verwendet. geplant war die sache mit nem ULN2803
(darlington array).
* Was für eine Diode verwendest Du als Schutzdiode?
1N4148

* Hängt sich der uC nur dann auf, wenn der Motor angeschlossen ist oder
auch dann, wenn der Motor nicht angeschlossen ist?
der µC hängt sich nicht auf wenn der motor nicht angeschlossen ist.
der µC hängt sich auch nicht auf wenn der motor angeschlossen ist und
kein relais geschalten wird.

* Wie viel Power hat Dein Motor denn?
230V, 3VA

thx

Autor: Christoph Lechner (clechner)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich das richtig verstehe, dann hängt sich die Schaltung nur auf,
wenn das Relais geschaltet wird und der Motor dranhängt. Wenn man das
Relais schaltet ohne das der Motor dranhängt, dann passiert nix.
Richtig so?
Wenn das so ist, wie ichs verstanden habe, dann muss ich fragen, ob Du
einen Snubber, d.h. ein RC-Glied über die Relais-Kontakte drin hast.
Ein fehlender Snubber könnte die Absturzursache sein, weil beim Öffnen
des Kontaktes sich ein Lichtbogen bildet. Das mag der uC gar nicht.

- cl

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

* Wenn ich das richtig verstehe, dann hängt sich die Schaltung nur auf,
wenn das Relais geschaltet wird und der Motor dranhängt. Wenn man das
Relais schaltet ohne das der Motor dranhängt, dann passiert nix.
Richtig so?

Ja, genau so ist es.

RC-Glied hab ich keines an den Relais-Schaltkontakten.
Welche Werte nimmt man da, rechnerisch?

So?

               /
              /
  >-----------     -----------
   |                         |
   |                         |
   ------- R ------ C --------


thx

Autor: Christoph Lechner (clechner)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
falls Du keinen Snubber hast hier ein paar URLs:
http://www.dse-faq.elektronik-kompendium.de/dse-fa...
http://www.mikrocontroller.net/forum/read-1-84031.html
http://www.mikrocontroller.net/forum/read-1-142598.html

falls was unklar ist nochmal fragen, denn brennende Elektronik an 230V
ist uncool, weil gefährlich.

- cl

Autor: Christoph Lechner (clechner)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mist, Du warst schneller ;)

Das mit dem fehlenden Snubber ist höchstwahrscheinlich die
Absturzursache.

Also welchen Wert Du nimmst kann ich Dir leider nicht sagen. Das müssen
andere besser wissen als ich. Siehe u.a. URLs.

Dein Schaltplan ist meiner Meinung nach richtig, wenn der Kontakt ein
Schließer sein soll.

Wichtig: Achte auf die Spannungsfestigkeit und die Verlustleistung. Der
Kondensator sollte X2 sein, z.B. MP3-X2 100N bei Reichelt.

- cl

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,

ich schaue mir mal die links an.

herzlichen dank!!!

Autor: Christoph Lechner (clechner)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sag mir, ob's gefunzt hat!

- cl

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,

rc funkt super .... ich nahm 100 Ohm und 0.1µF.

dieser link ist super!
http://www.dse-faq.elektronik-kompendium.de/dse-fa...

danke nochmal ...

stefan

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.