www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Timer0/Counter Atmega128 + Bascom


Autor: Jan Boese (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forum,

zuerstmal was ich hab:

Atmega 128
Bascom 1.11.7.4

Den Code im Anhang habe ich ausprobiert, dazu folgendes Problem und
folgende Fragen:

An welchen Pin müsste ich nun eine steigende Flanke anlegen damit der
Counter (timer0) zählt???

Wenn ich in Bascom im Simulator PortD.6 oder PortD.7 auswähle, dann
zählt er gar nichts.

Wenn ich den code jetzt allerdings auf timer1 ummodifiziere, dann zählt
der bascom-simmulator auch...

Ich brauche allerdings die 16 Bit Timer schon für andere Sachen, und
ein 8 Bit Counter reicht dicke aus, da eh jede 30 Impulse ein Interrupt
ausgelöst werden soll...

Wer kann helfen? Bascombug?

Viele Grüsse

Jan

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.