www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Suche von möglichen Fehlern in meiner Motorsteuerung


Autor: Mathias (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich plane gerade eine Motorsteuerung bis 64A, die den Motor in meinem
1:18 Modellauto, stufenlos vor- und rückwärts steuern soll. Das
Modellauto hab ich mir selbst zusammengebaut, es hat einen 43A Motor
der mit 7,4V läuft.
Die Schaltung müsste von 7,2V bis 12Volt und wahrscheinlich auch bis zu
18 Volt problemlos laufen.
Die (p-Kanal) Mosfets halten einen Dauerstrom bis 64A aus. Mit besseren
p-Kanal Mosfets wären denke ich auch noch 100A Dauerstrom drin. Dafür
braucht man dann aber auf jeden Fall eine ausreichende Kühlung der
Mosfets und die Kühlbleche der Mosfets (=Drain Anschlüsse) dürfen durch
die Kühlung keine Ströme über den Kühlkörper leiten. ( ->dadurch kriegt
der Akku einen Kurzschluss und könnte dann weg sein). Also am besten
mit Sekundenkleber
den Kühler vorsichtig auf die Mosfets kleben, der Sekundenkleber dürfte
den Strom eigentlich nicht leiten. Als Kühler dürften Grafikkartenkühler
gut geeignet sein.

Der Schaltplan ist im Anhang! Ich hab die Schaltung nochmal etwas
überarbeitet!

Hier hab ich noch die Erklärung der Schaltung, falls sich jemand
durchlesen will. Der Motor wird über das 1-2ms lange Pwm-Signal vom
Funkempfänger angesteuert. Der Operationsverstärker verstärkt die
Spannung auf 6,5 Volt und 20mA.
Der Kondensator lädt sich auf etwa 5,9V fast voll auf (der Strom reicht
für mehr Spannung nicht aus). Das steuert den p-Kanal Mosfet am Gate
(mittlerer Anschluss) an.
Dadurch werden die +7,4V angesteuert und gehen dann an den
Spannungsteiler von R5 und R6. Der Strom der über R6 und T1 geht öffnet
wieder einen +7,4V Anschluss, der den Kondensator C1 entlädt. Nun wird
der p-Kanal Mosfet P1 angesteuert, über den die Spannung die beim
umpolen von C1 frei geworden ist über den P-Kanal Mosfet zum OPV
geleitet. Danach gehen die Ströme die über R1 und R5 über den zweiten
OPV an den Kondensator.
Jetzt hängt es von der Spannung, die vorher am Kondensator C1 anlag ab,
ob und wie stark der Motor positiv oder negativ über die Mosfets
angesteuert wird. Weil die Mosfets bei bsp. +2V noch nicht
durchsteuern, werden je nach der Spannung, die am Kondensator C2
anliegt noch 3V der gleichen Polung addiert =5V mit der die Mosfets
angesteuert werden.
Würde man jetzt den Motor ansteuern dann wird von jedem Impuls der
Strom addiert oder abgezogen werden, das Rc-Car könnte nur mit vollgas
vor- oder rückwärts fahren, weil der Kondensator C2 nicht entladen
wird. Deswegen entlädt der nächste Impuls den Kondensator
über den p-Kanal Mosfet P2. Der Kondensator C1 muss über einen
Widerstand entladen werden, wieviel Ohm der hat, muss ich noch
berechnen.

Sonst weiss ich auch noch nicht wie gross der Wiederstand R6 sein
sollte, damit wenig Strom über R6 und der Transistor voll
durchgesteuert ist. Dann bin ich mir nicht ganz sicher, ob ich die
Mosfets mit einem Kondensator vor dem Gate richtig angesteuert habe.
Übrigends stimmen die Werte an den Widerständen am OPV nicht - die muss
ich noch berechnen. Und dann bin ich mir noch unsicher, was ich als
Masse benutzen soll. Ein Alublech wäre dafür wahrscheinlich gut
geeignet glaub ich.
Sonst wäre es auch nicht schlecht wenn mir jemand die Abwärme, die an
den Mosfets entsteht berechnen könnte.
Die Typenbezeichnungen sind IRF4905 und IRF1104 Hier sind gleich die
links zu den Datenblättern.
http://www.produktinfo.conrad.com/datenblaetter/15...
http://www.produktinfo.conrad.com/datenblaetter/15...

Achtung die Schaltung habe ich noch nicht getestet und könnte noch
kleinere Fehler haben, also nicht nachbauen!!!

Danke im voraus für die Antworten! Ich werde die Schaltung dann noch
mal auf die Seite hochladen, wenn sie fertig und getestet ist.

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Achtung die Schaltung habe ich noch nicht getestet und könnte
> noch kleinere Fehler haben, also nicht nachbauen!!!

Naja, lustige Idee, die Ladungen per Kondensator irgendwie von Stufe zu
Stufe zu transportieren...

Aber hilft alles nichts: Die Schaltung funktioniert garantiert nicht.
Schon die Endstufe ist totaler Murks. Vom Rest davor, reden wir lieber
mal nicht...

Autor: sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube auch nicht wirklich das deine Schaltung so funktioniert.
Als erstes kann man nicht davon ausgehen das die Akkus immer  7,4V
liefern. Besonders beim Anfahren wird die Spannung stark einbrechen.
Aber die ganze Schaltung wir wie Mr " unbekannt "schon sagte so nicht
funktionieren, besonders der vordere Teil.

Ich würde dir auch davon abraten die Schaltung so aufzubauen.

Nach meiner meinung ist es besser die Impulse vom Empfänger in einem
Mikrocontroller auszuwerten, welcher dies in ein PWM Signal umsetzt.
Zwischen Mikrocontroller und H-Brücke würde ich auf jeden Fall einen
Motortreiber einsetzen.
Solche Schaltungen gibt es auch schon fertig im Netz, auf welchen man
ganz gut seine eigenen Ideen aufbauen kann.

Autor: Rolf Magnus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich plane gerade eine Motorsteuerung bis 64A, die den Motor in
> meinem 1:18 Modellauto, stufenlos vor- und rückwärts steuern soll.
> Das Modellauto hab ich mir selbst zusammengebaut, es hat einen 43A
> Motor der mit 7,4V läuft.

Da ist klingt aber nach ziemlich viel Power für so ein kleines Auto.

>Dafür braucht man dann aber auf jeden Fall eine ausreichende
> Kühlung der Mosfets und die Kühlbleche der Mosfets (=Drain
> Anschlüsse) dürfen durch die Kühlung keine Ströme über den
> Kühlkörper leiten. ( ->dadurch kriegt der Akku einen Kurzschluss
> und könnte dann weg sein).

Fall es sich um einen NiXX-Akku handelt, ist noch wahrscheinlicher, daß
die Zuleitungen vorher durchglühen.

> Also am besten mit Sekundenkleber den Kühler vorsichtig auf die
> Mosfets kleben, der Sekundenkleber dürfte den Strom eigentlich
> nicht leiten.

Das klingt sehr gewagt. Ich würde die Transistoren lieber ganz
klassisch festschrauben und zur Isolation die passenden
Glimmerplättchen und Kunststoffbuchsen für die Schrauben nehmen.
Siehe z.B. http://tinyurl.com/8bsxr
Das ist dann was vernünftiges, und du kannst sicher sein, daß dein Auto
nicht einfach mal so in Flammen aufgeht, weil der Sekundenkleber doch
nicht ganz deckend war.

> Als Kühler dürften Grafikkartenkühler gut geeignet sein.

Wenn du da noch einen übrig hast, ja. Ansonsten ist es wohl deutlich
billiger, einen passenden beim Elektronikversand zu bestellen. Die für
den PC sind teuer.

Ich würde übrigens auch einen Mikrocontroller empfehlen, z.B. den
ATtiny13. Der hat Hardware-PWM eingebaut und lässt sich dafür prima
verwenden. Die Schaltung wird dadurch sehr einfach.

Autor: sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die meisten elektronischen Fahrtregler die ich in der Hand hatte kommen
ohne einen großen Kühlkörper aus. Ein Kühlkörper kostet Gewicht und
Platz. Beides will man bei Modellbau meist vermeiden. Ich würde die
Mosfets deutlich überdimensionieren. Der RDS on Widerstand sollte so
klein wie möglich sein, dann reicht eine Massefläche als Kühlung meist
aus.
Ich kenne den Motor nicht, aber normalerweise fließen die richtig
großen Ströme nur beim Anfahren. Ich gehe mal davon aus das mit 64A der
maximal Strom beim Anfahren gemeint ist.
Die Leitungen müssen natürlich entsprechend ausgelegt sein. Aber die
Zuleitungen sind meist auch nicht besonders lang.

Autor: Mathias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sind die Mosfets eigentlich richtig angesteuert oder nicht?
Kanns auch sein das ich das Signal auch dehnen muss, wenn ich Mosfets
benutze? (Denke ich aber eigentlich nicht, weil sonst die Ansteuerung
nicht stromlos wäre)
Der Akku ist kein NiCd oder Nimh billig Akku oder so sondern ein
Lithium Polymer Akku mit 7,4Volt und 5100mAh. Auf den maximalen
Entladestrom hab ich schon etwas geachtet. Ich hab den Motor schon vor
kurzem direkt mit einem NiCd Akku und meinem Akku getestet. Beim NiCD
Akku gibts am Anfang nen starken Spannungsabfall, aber mit dem Li-po
Akku geht alles ohne spürbare Spannungsverluste, auch wenn der Strom
dran ist und man den Motor festhält, dass er sich nich dreht. Zur
Kühlung könnte ich auch vier einzelne passive Chipkühler nehmen und die
mit einem Lüfter kühlen.
Die Mosfets haben alle einen Innenwiderstand von so 0,01Ohm, da hab ich
vor dem Kaufen schon darauf geachtet. Ach und die 64A sind der Strom den
die Mosfets höchstens verkraften, der Strom beim Anfahren ist nur 43A
groß!

Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://s-huehn.de/elektronik/fahrtregler/fahrtregler.htm

Ich würde mal ganz langsam anfangen und diese Schaltung
hier studieren.

Autor: Mathias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich bin schon vor ein paar Wochen auf die Seite gestoßen.

Ich schreib dann mal jemandem eine E-mail, was für ein Ausgangssignal
der Attiny13 ausgibt.
Das Ausgangssignal könnte man vielleicht doch einfach mit einem OPV
verstärken und damit die Mosfets ansteuern.

Autor: Arno H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo hast Du denn den selbstleitenden P-MOSFET links unten in der
Schaltung her? Welcher Typ, welcher Hersteller?
Bis jetzt waren auf diesem Planeten keine aufzutreiben.
Für Eigenbedarf mögen ja solche mundgemalten Schaltpläne noch angehen,
aber zum Anderen zeigen gibts (genormte) Schaltzeichen und
Konventionen.
Viele Löten so wie sie zeichnen.
Kommen aus der Fernsteuerung wirklich Impulse zwischen 10 und 20ms?
Arno

Autor: Rolf Magnus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der Akku ist kein NiCd oder Nimh billig Akku oder so sondern ein
> Lithium Polymer Akku mit 7,4Volt und 5100mAh.

Aja. Dann mußt du aufpassen. Die reagieren empfindlich auf Überlastung,
und vor allem auch auf Untersrpannung! Du solltest also was vorsehen,
das den Motor abstellt, wenn die Spannung zu niedrig wird. Sonst sind
die teuren LiPos schneller hin als du das Geld dafür ausgegeben hast.

> Auf den maximalen Entladestrom hab ich schon etwas geachtet.

Da solltest du mehr als nur "etwas" drauf achten. Auch die Temperatur
nach dem Entladen solltest du prüfen.
Ich will nicht den Oberlehrer spielen. Es ist nur so, daß viele
Modellbauer von NiXX-Akkus gewöhnt sind, das sie sie fast jeder Tortur
unterziehen können, ohne daß das signifikanten Schaden an den Zellen
verursacht, und sich nachher wundern, warum die LiPos so schnell ihren
Geist aufgegeben haben.

> Ich hab den Motor schon vor kurzem direkt mit einem NiCd Akku und
> meinem Akku getestet. Beim NiCD Akku gibts am Anfang nen starken
> Spannungsabfall, aber mit dem Li-po Akku geht alles ohne spürbare
> Spannungsverluste,

Ja, es ist bekannt, daß LiPos eine bessere Spannungslage haben als
NiCD.

> auch wenn der Strom dran ist und man den Motor festhält, dass er
> sich nich dreht.

Vorsicht! Der Motor zieht beim Blockieren sehr hohe Ströme.

> Zur Kühlung könnte ich auch vier einzelne passive Chipkühler
> nehmen und die mit einem Lüfter kühlen.

Lüfter würde ich vermeiden.


> Kommen aus der Fernsteuerung wirklich Impulse zwischen 10 und
> 20ms?

Nein. Die Impulsdauer liegt zwischen 1 und 2ms.

Autor: high_speed (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Ansteuerung eines MOSFET mit einem OP-Amp ist nicht gerade optimal.

Die meisten OP-Amp können Ausgang nur geringe Strom um 20mA liefern.

Jetzt fragen sich aber einige, warum das ein Problem sein soll.
>>Zum ansteuern eines FET wird doch keine Energie benötigt.<<
Dies ist ein Irrglaube. Zum laden der Gate-Kapazität wird sowohl
Energie benötigt.

Das Laden und Entladen der Gate-Kapazität dauert um so länger, desto
kleiner der Ladestrom bzw. Endladestrom ist.
Die Verlustleistung an einem elektrischen Bauteil ist das Produkt aus
anliegender Spannung und durchfließendem Strom.

Da du die MOSFETs mehrmals pro Sekunde einschaltest und ausschaltest
wird, werden diese ungünstigen Zustände häufiger durchlaufen.

Im übrigen kann man MOSFETs parallel betreiben, wenn einer nicht
reicht.

PS: Ein Leistungs-MOSFET ist eine Zusammenschaltung aus mehreren.

Holger

Autor: Mathias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab einen High Speed Opv zuhause der bis zu 50mA Strom liefern
kann.

Sind die selbstsperrenden Mosfets im Schaltplan eigentlich richtig
angeschlossen, so dass die Gates von den 4 Mosfets am Kondensator
anliegen, der die Mosfets ansteuert.

Der Akku ist recht gut gekühlt, weil darunter noch ein Aluplatte vom
Boden des Modellautos liegt.

Die selbstleitenden Mosfets sind von Infineon. Ich hab die beim Conrad
gesehen, aber ich werd später nochmal danach schauen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.