www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Komparator für 40khz


Autor: Mirko M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an alle,

ich versuche gerade aus einem sinussignal das in der amplitude zwischen
50 und 100 mV +/- liegen kann und genau 40 khz hat, ein rechtecksignal
mit ttl kompatiblen eigenschaften zu erzeugen.

leider erweist sich der lm393 als zu träge. die hysterese müsste
präzise einstellbar sein...

vielleicht hat ja noch jemand etwas im nähkästchen...

grüße, und danke im vorraus,

Mirko M.

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
40kHz sind kein Problem für den LM393. Dimensionierungsfehler?

Autor: Mirko M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...hmm, bin nicht so der analogtechniker. habe vom ausgang zum + eingang
100 kohm und in reihe dann 1kohm....

die betriebsspannung liegt bei 10 volt. über einen spannungsteiler wird
sie auf 5volt geteilt und über den 1kohm wiederstand auf den + eingang
geführt... der - eingang enthält das auf 5 volt angehobene sinussignal
von ca 100mV spitze spitze...

....

Autor: Mirko M. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hier mal ein kleines bild...

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
pullup-Widerstand eingebaut am Ausgang eingebaut? Der 393 hat einen
OC-Ausgang.

Autor: ..,- (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hehe, da bin ich auch mal drauf reingefallen :)

Autor: Mirko M. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
...es hat sich verbessert, jedoch habe ich eine menge pulse drauf...

Autor: Mirko M. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
..es bricht langsam ein, also im kleinen amplitudenbereich, und hat in
dem bereich sehr große rückwirkung auf das eingangssignal. dadurch
scheinen schwingungen zu entstehen, die die messung versauen...

Autor: Mirko M. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
...hier sieht man es noch etwas deutlicher, mittlerweilen habe ich einen
4093 schmiddy hintergeschaltet um es etwas rechteckiger zu bekommen, die
verzögerungen die dadurch entstehen lassen sich wohl wieder per software
rausrechnen...

Autor: Mirko M (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also, gibts hier noch den einen oder anderen vorschlag???

die probleme sind denke ich

zum ersten, die Rückwirkung auf den eingang, evtl über den Komp selbst
und zum zweiten, die genaue dimensionierung der größen

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
stell doch bitte mal deine GESAMTE Schaltung ein, so, wie sie ist, ohne
verbale Ergänzungen/Streichungen. Hab heute keine Lust zum Rätselraten.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Mirko,

ich würde fast vermuten, daß du relativ hochohmig ansteuerst. Kann das
sein ? Dadurch "klappert" der Eingang bei Umschalten mit und dafür
ist wohl die Hysterese zu klein....

Gruß Thomas

Autor: Mirko M (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
...ich wusste zwar nicht das es hier nach Lust geht, aber bitte, hier
die schaltung im ganzen...

für mich ist speziell der aussschnitt komperator.jpg sehr wichtig, ich
wollte nur vermeiden das zu viel rätselraten statt findet, aber
vielleicht sind es ja auch noch irgendwelche zusammenhänge...

wie gesagt man sieht in den bildern komp2 und 3 sehr schön wie der
lm393 sich scheinbar aufschwingt, oder in einem bereich zittert, da das
eingangssignal zu schwach ist an der stelle oder der ausgang den eingang
des lm`s zu sehr beeinflusst....

grüße und dank,

mirko m

Autor: Mirko M (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Thomas,

vielleicht hilft  mein kleines schaubild ja weiter, ist etwas krakelig,
habe aber leider kein editor auf diesem pc....also musste paint her
halten...

als eingansverstärker verwende ich den tlo82, der ist nun von haus aus
schon hochohmig, da fet eingang....aber dieser komperator macht mir
kopfschmerzen...

nun muss ich die bauteile schon mit unterschiedlichen spannungen
versorgen, damit das alles etwas besser zusammen passt, wenn der lm
durchsteuert, liegt seine ausgangsspannung genau auf 5 volt, da die
vergleichspannung auch genau bei 5 volt liegt, passt schon ganz gut.

die messung komp1 ist ohne schmiddy gemessen. das signal wird über
einen kondensator eingespeist, gleichspannungsfrei...

davor sitzt noch ein sehr hochohmiger instrumentenverstärker, der das
signal überhaupt antastbar macht. er ist in seiner funktion jedoch
vollständig erprobt...wie die ossi messungen ja auch sichtbar
machen...


ich denke das mit der hysterese ist der springende punkt, nur dort
genau zu dimensionieren, ist kompliziert, oder!?

gruß, m

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
na, geht doch.
Als 1: hast du Enkopplungskondenstaoren 100n an den ICs? zumindest
direkt am 393 solltest du die haben.
2. durch die Mitkopplung schwankt auch die 5V-Spannung ein wenig, nicht
viel, aber deutlich. Das geht dann auch wieder auf den Verstärker, so
sollte das Schwingen zu erklären sein (oder schau ich jetzt verkehrtrum
und das erhöht die Hysterese weiter?). Setz mal statt des
5V-Spannungsteilers einen 5V-Regler ein, evtl. reicht auch statt des
unteren Teilerwiderstands eine Z-Diode. Auch ein 1µ-Tantal parallel zum
unteren Widerstand könnte schon helfen.

Autor: Mirko M (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ crazy hoars,

die 100nf s habe ich für selbstverständlich gehalten, sorry mein
fehler...

da die beiden op's aber den selben referenzpunkt haben, verstehe ich
nicht was eine stabilere referenz ändern soll...

die sache mit der hysterese scheint mir da sinniger, aber ich werde
nichts unversucht lassen...und bin für jeden tipp dankbar...

man kann auf dem bild komp2 nur sehr gut sehen, das das ausgangs signal
meinen wünschen entspricht, wenn das eingangssignal etwas stärker
wird.... und man sieht die schwingungen die am ausgang sind, auch am
eingang...

gruß, m.m.

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nehmen wir mal an, das Ausgangssignal del TL steigt über den
Referenzwert. Der Ausgang des LM393 geht auf Masse, über den 100k und
den 1k wird auch der Spannungsteiler beeinflusst, Spannung sinkt. Damit
 fällt auch die Spannung am +Eingang des TL, dementsprechend sinkt auch
dessen Ausgangsspannung. Damit scheinen mir alle Bedingungen für die
Schwinger im Umschaltbereich gegeben.

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PS: 5V Referenzspannung scheinen mir nicht wirklich geeignet, da kann
die Hysterese nur in eine Richtung wirken (wenn der Ausgang auf L
liegt). Bei H-Pegel fliesst kein Strom über den 100k, erhöht also nicht
den Referenzwert. Mit 2,5V solltest du besser fahren.

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei Interesse:
Zur Berechnung der Hysterese:
http://home.cogeco.ca/~rpaisley4/ComparatorHyster.GIF

Bild hier im Kontext (ungef. in der Mitte der Seite)
http://home.cogeco.ca/~rpaisley4/Comparators.html

Hier eine Appnote von MAXIM ganz unten auf der Seite
http://www.maxim-ic.com/appnotes.cfm/appnote_number/3616

Dein PullUp Widerstand spielt auch noch mit rein

Autor: Unbekannter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh, oh...

Wenn Schaltungen mit OPVs und Komperatoren einigermassen funktionieren
sollen, müssen mindestens die Referenzeingänge entkoppelt sein. Also
nicht so einen ollen Spannungsteiler doppelt verwenden, nur um zwei
Widerstände zu sparen.

Zusäzlich bietet es sich an, die Referenzeingänge mit Kondensatoren zu
stützen.

Autor: Bernhard S. (bernhard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Durch einfache RC-Tiefpasse am Eingang oder/und zwischendurch könnte man
das Eingangssignal auch etwas filtern, da es ziemlich verrauscht
aussieht?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.