www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probleme mit AT90S1200


Autor: Axel (ojojo) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich bin fast am verzweifeln.
Habe mir eine Test-Schaltung für einen 1200er gebaut und bekomme das 
Teil einfach nicht programmiert:-(
Nachdem ich alles gründlich durchgecheckt habe, habe ich mir einen 
ErsatzController geholt. Gleiches Problem.
Heute habe ich meine Schaltung nochmal neu aufgebaut und bekomme wieder 
den gleichen Fehler.
Was mache ich falsch?
Woran kann´s hängen?

jo
Axel

Autor: Markus Burrer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deine Informationen sind ja etwas dünn. Welchen Programmer (Hard- und 
Software) verwendest Du? Hast Du sonst noch was an den Controller 
angeschlossen? usw

Autor: Thomas Weisenburger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

hatte das gleiche Problem mit meinen  AT90S1200, PonyProg und Yaap 
wollten die einfach nicht erkennen. Hatte mir dann SP12 besorgt, einen 
DOS-Programmer. Damit gings dann endlich problemlos.


http://www.xs4all.nl/~sbolt/e-spider_prog.html

Bye
Thomas

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mit AVR-ISP und STK200 keinerlei Probleme.

Autor: Lars (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
kontrollier mal ob die Pinnummer die auf der Schnittstelle stehen, mit 
dennen im Schaltplan übereinstimmt, die Schaltpläne stellen nicht 
unbedingt die Lötseite des Steckers da.

Autor: Axel (ojojo) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi

bei mir war wohl tatsächlich der neue 1200er auch defekt.
Mit nem dritten geht´s jetzt perfekt !
Komisch. Hab bissher mit dem 4433 nur gute Erfahrungen gemacht.
Erschien mir als sehr "robust".
Naja.

jo
Axel

Autor: Notker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie ich schon mal hier geschrieben habe, der AT90S1200 ist der älteste 
Vertreter seiner Gattung und hat hardwaremässig an den ISP-Eingängen ein 
etwas anderes Innenleben. Ich hatte schon den speziellen Fall, dass sich 
mit einem ISP-Programmier-Adapter alles bis auf die 1200er programmieren 
liess! Das war übrigens auch mit PonyProg!
Ich denke, daran wird es wohl eher liegen als dass mehrere 1200er 
plötzlich defekt sein könnten.

Notker

Autor: RoBSki! (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Overrule:

SP12 -i12

:)

Autor: Swunn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In der Hilfe von PonyProg 2000 wird darauf hingewiesen, dass einige 1200 
(ältere Charge) offenbar ihre Kennung nicht oder nicht korrekt 
zurückgeben. Wenn PonyProg eine derartige Fehlermeldung "Device 
unknown?" bringt, einfach "Ignore" wählen. Wird dann nach dem Schreiben 
"Write successful" gemeldet, kann man davon ausgehen, dass es 
funktionier hat. Auch ein "Read" ist möglich, wieder mit "Ignore". Das 
sollte euch helfen.

Es kann aber trotzdem sein, dass einige Interfaces nicht funktionieren. 
Bei mir geht es mit einem einfachen seriellen Interface (3 Z-Dioden, 
paar R's und 1 BC337).

Viel Erfolg.

Swunn

Autor: Armin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab versucht einen AT90LS4433 ohne Quarz und ohne Widerstand und 
Kondensator am Reset zu programieren. Dabei ging dieser in Rauch auf. 
Kann das sein daß die davon kommt daß ich kein Quartz verwendet hatte? 
Oder muß irgendwo ein anderer Fehler sein??

Autor: Frankl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum hast überhaupt ein At90LS4433 genommen hättest den ja auch noch 
einsparen können.

Autor: Armin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bin davon ausgegangen daß man AVRs auch so wie PICs programieren kann ( 
zumindest den 16F84 )

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Armin,

warum muß auch alle Welt immer ein Schweißernetzteil nehmen ???

Ich betreibe meine MCs immer mit einem Steckertrafo und einem 87L05 
dahinter. Der begrenzt auf ungefährliche 100mA und mir ist noch nie ein 
MC abgeraucht, egal was man macht und wie man ihn reinsteckt.


Peter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.