www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik EEPROM-Löschung beim Start vom Studio?


Autor: St.Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mir passiert da etwas seltsames: Ich programmiere mit Codevision;
debugge mit AVRStudio und AVR-JTAG-Emulator meine Zielhardware mit dem
mega128.
Mein Programm benutzt das interne EEPROM des mega128.
Beim Starten vom Studio zeigt das EEPROM-Fenster, das alle
Speicherplätze gelöscht sind(FF), obwohl Daten drin stehen müssten.

Hab' ich da irgend etwas übersehen?

Autor: St.Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich geb' mir mal selbst ne' Antwort:

Du musst im Fenster für den JTAG-ICE die Checkbox für das EEPROM
setzen(Inhalte bleibe bei reprogramming erhalten):

St.Martin

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.