www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Display 4x20 mit AVR


Autor: Sven (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich versuche schon seit einiger Zeit ein HD44780 kompatibles Display
anzusteuern. Das Display ist soweit für den 4-Bit Modus angeschlossen
und die schwarzen Balken leuchten in der 2. und 3. auf. So nun möchte
ich einfach das Display initialisieren, so dass das der Cursor auf dem
ersten Zeichenplatz blinkt. Mehr nicht!

Dazu hab ich mir ein C-Programm geschrieben, welches nacheinander auf
dem Port die Initialiserungsbefehle (wie im Datenblatt beschrieben) an
das Display sendet. Die Wartezeiten zwischen den entsprechenden
Befehlen hab ich auch berücksichtigt. Leider funktioniert gar
nichts!!!

Ich benutze eine ATmega32 und ein STK500 Entwicklungsboard.

Braucht man unbedingt einen Pull-Ups zwischen Port und Display?
(Im Moment ist das Display direkt am PortA angeschlossen)

Muss Enable auch bei der Initalisierung auf HIGH sein?

Autor: TOM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Sven,

zu deinen Fragen:
- Pullups müssen nicht sein.

- Du mußt immer wenn ein gültiges Datum an den Datenleitungen anliegt
und dieses übernommen werden soll einen positiven Impuls auf die Enable
Leitung geben. So wie ich deine Frage interpretiere , wird das wohl dein
Fehler sein.

Weiterhelfen kann man dir besser, wenn du deinen Code mit postest und
eventuell noch eine Übersicht des Hardwareaufbaus.

Gruß

Thomas

Autor: Asterix-007 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

schau oben links ins AVR-Tutorial => Punkt 4 - LCD-Display!
Beachte den Punkt  " Taktgeschwindigkeit des Prozessors" und dann
sollte es gehen. Die Beispiele funktionieren und zum Testen tuts auch
mal Assembler.

Ansonsten Schaltung und Timing kontrollieren => meist liegt hier der
Fehler!!!!!!

mfg und gute Nacht!

Asterix-007

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.