www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Umstieg Atmega16 auf Atmega32


Autor: Ingo Sauerland (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo zusammen,
ich verzweifele langsam!

habe erste erfolgreiche erfahrungen mit dem Atmega16 gesammelt und
möchte nun auf den 32er umsteigen.

doch da beginnt mein problem! ich kann den 32er überhaupt nicht
ansteuern (bits auslesen, programme übertragen usw.).

zur zeit nutze ich folgende komponenten:
- einen seriellen programmieradapter mit reset, ground, sck, miso und
mosi
- testboard mit minimalbeschaltung siehe bild
(gibt es hier unterschiede zw. dem 16er und 32 -außer natürlich der
pin-belegung?)
- ponyprog 2.06f
- bascom

wer weis rat von euch? freue mich sehr auf eure antwort!

gruß Ingo

Autor: Weihnachtsmann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann schwingt der Quarz nicht ?

Autor: Ingo Sauerland (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
es handelt sich ja um einen neuen atmega, der sowieso auf den internen
quarz gestellt ist!

Autor: D. W. (dave) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich brauche zwar selbst keinen, aber wie wärs mit Abblockkondensatoren
an VCC und GND, sowie anstatt 100n an Reset was kleineres?

OT: was is mit dem Eingabefenster los (Opera) irgendwie komisch, läuft
ins Nirvana, der Text.

Autor: Frank Weltz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte beim mustieg auf den Mega32 einfach nur den Mega16 aus der
fassung gezogen und nen Mega32 rein gemacht. Funktionierte auf anhieb
super. Ich weiss auch nicht was du gemacht hast....
Ich vermute mal dein Programmer ist zu schnell für den standartmässigen
1 Mhz interner osc. Also stell den Programmer mal langsamer ein (sofern
er das unterstützt)

Autor: Marko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das kann an sich nicht sein,
haste die Controllerdefinition in Deinem Listing angepasst?

$regfile = "m32def.dat"

Autor: Frank Weltz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuch mal wirklich die programmierfrequenz runter zu drehen...das kam
bei mir auch schon öfters vor, dasses mit den hohen frequenzen nicht
geht. ich hab nen avrisp

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.