www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Umstieg Mega8 auf Mega 32


Autor: Ingo Sauerland (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
da seht ihr mal, wie verrückt ich bin! möchte vom 8er und nicht vom
16er umsteigen!!


hallo zusammen,
ich verzweifele langsam!

habe erste erfolgreiche erfahrungen mit dem Atmega8 gesammelt und
möchte nun auf den 32er umsteigen.

doch da beginnt mein problem! ich kann den 32er überhaupt nicht
ansteuern (bits auslesen, programme übertragen usw.).

zur zeit nutze ich folgende komponenten:
- einen seriellen programmieradapter mit reset, ground, sck, miso und
mosi
- testboard mit minimalbeschaltung siehe bild
(gibt es hier unterschiede zw. dem 16er und 32 -außer natürlich der
pin-belegung?)
- ponyprog 2.06f
- bascom

wer weis rat von euch? freue mich sehr auf eure antwort!

gruß Ingo

Autor: Ingo Sauerland (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
und hier noch der schaltplan, den ich auf die pinbelegung des 32er
angepaßt habe!

es klappt einfach nichts!!!

Autor: Ingo Sauerland (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
so, habe nun noch eimal mit einem neuen M32 und einem anderen quarz
getestet.

kann weder die fuse-bits, noch den inhalt des megas auslesen.

fehlermeldung in ponyprog: "device missing or unknown device (-24)".

wer weis rat oder arbeitet selbst mit einem Atmega32?

gruß ingo

Autor: Andreas Kassner (andi_k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sag mal, von was bist Du jetzt umgestiegen?
Vom Mega8 oder Mega16 im anderen Thread?
Vom Mega16 aus würde es mich wundern mit solchen Probs zu kämpfen.

MfG
Andi

Autor: dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo ist jetzt dein problem, wenn dein ISP auf einen Mega 8 läuft , sollte
es auch auf einen Mega16 oder Mega32 laufen.

Mega 16 und Mega 32 sind PIN Kompatibel und ohne Einstellung laufen Sie
mit 1 MHz.

Wenn du Das Teil mit dem Programm Kommunizieren kannst. Solltest du bei
Bascom JTAG abschalten, damit die Port frei sind und entsprechend auf
Externen Quarz umschalten.

Autor: karlheinz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
tip.
hatte auch das problem...
hab aus irgendeinem grund den chip geschrottet...nimm mal nen neuen!!!

Autor: Ingo Sauerland (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bin ich also doch nicht zu blöd für diese welt? hab den fehler
gefunden!!!

kalte oder schlechte lötstelle auf meiner neuen testplatine zwischen
Mosi und dem steckkontakt zum avr.

kann nun mit ponyprog arbeiten!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.