www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik pic mit 40 mhz betreiben


Autor: Eddy Ilg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich versuche vergebens einem PIC das Laufen mit 40Mhz beizubrigen. Ich
habe HSPLL, PWRT on (power-reset-timer), und IEOSB on (reset
verzögerung) ausgewählt.
An OSC1 und OSC2 habe ich jeweils einen 22pf kondensator gegen ground
angelötet (15pf habe ich auch probiert und weglassen auch). Zwischen
OSC1 und OSC2 hab ich außerdem den 10Mhz Quarz gesetzt. Er hat folgende
technische Daten (Reichelt bestell nummer 10-HC18):

Standardquarz im Gehäuse HC18/U
Frequenz: 10,0 MHz
Modus: Grundton
Cl: 32 pF
Rsmax: 30 Ohm
TK: +/- 30 ppm
Frequenztoleranz: +/- 30 ppm

Irgendwelche tipps? Was mache ich falsch?

Eddy

Autor: Borny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Als erstes wäre es ratsam ein 40MHz Quarz zu benutzen.
An deiner stelle würde ich mir aber direkt einen Quarzoszillator
holen. Die sind nur 1€ teurer, dafür ist die frequenz aber
stabiler,
und du brauchst keine Kondensatoren.
Kann es sein, dass du dass mit dem Vorteiler missverstanden hast?
PICs arbeiten in 4 Takten nur einen Befehl ab, nicht umgekehrt.
Ich hoffe mal, dass du das ganze auch bei nem PIC18XXX machst,
denn die anderen sind sowieso meines Wissens nach nur bis 20MHz
taktbar.

Autor: Geri (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Eddy

Was hast du eigentlich für einen PIC?
Mit welchen Configuration-Bits hast du den PIC gebrannt?
Dann kann man dir evtl. besser weiter helfen.

Meine Oszillatorschaltung sieht beispielsweise so wie hier aus:
http://burger-web.com/Projects/PIC18F4550USB/de_PI...
(habe ich problemlos auch bei anderen PICS eingesetzt).

An den Reichelt Oszillatoren liegt es zeimlich sicher nicht. Die haben
bei mir auch immer funktioniert.


Beste Grüsse
Geri

Autor: Eddy Ilg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Geri,

die betreffenden configuration bits sind so:
HSPLL, PWRT on, IEOSB on
Es handelt sich um einen PIC18F4680.
Dein board benutzt ja auch einen 20Mhz quarz. Mit denen habe ich den
pic früher auch betrieben. Jetzt habe ich nur den 20Mhz quarz gegen
einen 10Mhz quarz ausgetauscht (und verschiedene kondensatoren
getestet). Im normalen HS modus mit 10Mhz läuft der PIC einwandfrei,
ändere ich die bits aber in den HSPLL (x4) modus, gehts es nicht mehr.
Vielleicht ist die frequenz zu unsauber?

Ich habe hier auch noch einen 40Mhz Oszillator. Den kann ich doch
einfach an OSC1 anschließen und den EC modus wählen oder?

Vielen Dank auch


Eddy

Autor: dc7hpe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche Spannung liegt den am PIC an ?


Wenn es weniger als 4,8V sind dann --> rtfm ( read the fucking manual)

Schau mal bei mircochip auf der Homepage. Da gibt es pdf über den PIC.

PS : Habe einen 18F458 mit 80Mhz am laufen (Wie lange noch ?)

Autor: Mr. PIC (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem bei den 18er PICs ist, wenn man die PLL beim Progammieren
ein- oder ausschaltet, muß man mal kurz die Stromversorgung
ausschalten, damit der PIC das auch kapiert. Klingt komisch, ist aber
so. Hab meine PICs aber trotzdem lieb :-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.