www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik FT 232 BM nur RX und TX


Autor: Sascha Müller zm hagen (durin-v)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

ich hab mir ein Evertool mit einem FT232BM anstatt der Sereiellen
gebaut und habe nun das Problem, das ich zwar am FT232BM etwas
empfange, er das aber nicht weitergibt. Was mach ich da verkehrt?

Ich habe einfach die TTL Pegel von RX und TX an den AVR's
(Wechselschalter) angelegt aber diese regen sich nciht. Ich habe schon
das Evertool auf einer Lochrasterplatine mit einer Serielen gebaut. Von
daher sind die µC's schon richtig Programmiert.
Den treiber des FT232BM konnte ich ohne Probleme installieren und die
TXD-Led blinkt auch wenn das AVR-Studio auf den Com2 Port zugreifen
möchte aber das Signal wird halt nicht vom FT232BM durchgeleitet.

Gruß
DurinV

Autor: thkais (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ist in diesem Zusammenhang ein Wechselschalter?
Woher weißt Du, daß der FT232 etwas empfängt, wenn er es nicht
weitergibt?
Schonmal den AVR rausgenommen und am FT232 RX und TX miteinander
verbunden - dann sollte mit einem ordinären Terminal-Programm schonmal
ein Echo zurückkommen. Ich habe die FT232 auch schon benutzt und die
sind eigentlich total problemlos, wenn man sich ans Datenblatt hält.
Das kann viel sein - Chips totgebraten, ESD, irgendwo einen Pin
vertauscht, Versorgungsspannung, EMV etc. etc. etc

Autor: Jens D. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
IOVCC angeschlossen??

Autor: Ingo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Test doch mal mit einem Terminalprogramm, ob der 232 überhaupt richtig
funktoniert. Dazu verbindest Du Tx und Rx. Die gesendeten Zeichen musst
Du dann wieder empfangen können.

Autor: xzibit (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Super, Ingo! Und was hat thkais oben geschrieben??

Autor: Sascha Müller zum Hagen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

ich bin gerade nicht zu hause, aber sobald ich zu hause bin werde ich
mal gleich ransetztn und eure Tips ausprobieren. Das der FT232 was
empfängt das sehe ich an der LED die ich angeschlossen habe. An das
Datenblatt habe ich mich auch gehalten von daher habe ich ja auch in
voller verzweiflung hier etwas geschrieben.

Gruß
 Durin-V

PS: Der Wechselschalter ist ein Zweipoliger Wechselschalter zum
Umschalten zwischen STK500 und JTAGICE (ich habe auch beide
Schalterstellungen versucht).

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

hab es hinbekommen. Ich habe RX und TX vertauscht (wie peinlich).
Danke nochmals an alle dir mir bei diesem Problem geholfen haben.

Gruß
   Durin-V

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.