www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Motorsteuerung


Autor: Florian Goldschmidt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ZUR VORGESCHICHTE
Ich hatte vor einen kleinen Roboter zu bauen, da das ja nunmal nit ganz 
so einfach ist wie ich feststellen musste entschloss ich mich, bevor ich 
an den AVR gehe, das ganze mal am PC über den LPT laufen zu lassen. 
Hierbei verband ich einen Ausgang des LPT's mit 2 Transistoren und einen 
anderen Ausgang mit 2 anderen Transistoren. Jetzt noch 'nen 1K Ohm 
Widerstand zwichen Ausgang und Transistor, die Massen von der 9V 
Batterie und vom LPT verbunden und schon lief das Teil... (Also wenn 
beite Ausgänge aus waren stand der Motor still, und wenn einer an war 
drehte er sich in die eine Richtung, bei dem anderen in die andere 
Richtung, und was passiert wenn beide Ausgänge Strom geben kann man sich 
ja denken g).

SO...

Da dieser Motor aber nur einer war der zufällig bei mir noch so rumlag, 
entschloss ich mich 2 andere zu kaufen. Und da dachte ich mir, wenn ich 
schon dabei bin nehm ich gleich welche die nur (min) 1,5 V brauchen.

UND NUN ZUM PROBLEM
Diese Motoren mit Getriebe laufen bei 1,5V auch klasse, aber einfach 
nicht in meiner Schaltung. Und ich hab keinen Plan warum.

Ich sag schonmal DANKE

Florian

Autor: Danny Paulsen (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Florian,

was für nen TransistorTyp hast du verwendet ( NPN PNP ) und wie hast du 
diese geschaltet? Kannst es evt. kurz aufzeichnen ?

Danny

Autor: Florian Goldschmidt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich benutz' nen C548B

Autor: Josef Strasshofer (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Der BC 548B ist auch für so kleine Motoren meist viel zu klein. Einen BD 
139 und BD 140 - in geeigneter Brückenschaltung - würde ich schon 
verwenden. Ob dann allerdings die Spannung reicht, ist eine andere 
Frage.
Ich habe mal so eine Schaltung gebaut, mit insgesamt 4 BD - Typen und 
und noch ein wenig Hardware davor, gesteuert mit TP 7.0 .... lief 
problemlos. Trotz risikoreich geschalteter Hardware - um wenig Verluste 
über die Transistoren zu haben. Auch der dümmste Programmierer kann so 
keinen Kurzschluss produzieren. Alle gängigen Getriebemotoren bis etwa 1 
A funktionieren damit. Anbei das TP-Steuerprogramm, falls sie 
hochgeladen wird.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.