www.mikrocontroller.net

Forum: Platinen Egale Libraries


Autor: Hans Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo! Habe da eine Frage und zwar bezüglich des Eagle Layout
Editors...

Und zwar hab ich eine neue Library erstellt, welhe noch leer ist..


Nun lege ich ein neues Device an mit dem Titel "test"..

Ich möchte nun für dieses Device sowohl ein Symbol, wie auch ein
Package verwenden, welche bereits ni anderen Libraries existieren..

Ich hab dann im main panel bei den bibliotheken eine "geöffnet"
(Klick auf Bibliotheken)....dann seh ich die Bestandteile der
Libraries.

Nunn kann ich entweder auf das gewünschte Device oder das gewünschte
Package Rechtsklicken und "In Bibliothek kopieren" wählen, dann
kopiert er das in die aktuell geöffnete Lib...

Allerdings kann ich wie gesagt nur entweder das gesamte Device kopieren
oder das Package...wie kann ich nur das Symbol kopieren??

DANKE schonmal...Mfg

Autor: juergen klauck (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi
- man kann die lib oeffnen in der das gewuenschte symbol ist
- das symbol mit group einrahmen -> mit cut und rechter maustaste
  makieren (die schrift unten veschwindet)
- lib schliessen -> die lib oeffnen wo das symbol rein soll
- symbol oeffnen ... oder neues erstellen
- mit paste einfuegen
- wenn ok sollte man noch speichern... :)
vieleicht hilft das ja weiter

gruss juergen

Autor: hans Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey Juergen!

Danke vielmals...das hilft schon!!

Ich hab mich immer gewundert...das mit copy und paste hab ich schon
versucht, hat aber nciht geklappt..man muss also Cut und paste
verwenden (warum auch immer, ist doch eigentlich blödsinn, den obwohl
man cut wählt(ausschneiden), bliebt das symbol ja an Ort uns
Stelle)...

Aber ok!

Danke nochmals. Hat wirklich geholfen!

MFG

Autor: Manfred Schäfer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

meiner Meinung nach ist es doch einfacher du kopierst das Device und
löscht in deiner neuen Bibliothek das Device und dann das Package.
Übrig bleibt das Symbol.

Gruß

Manfred

Autor: hans Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun, ich wüsste nciht, wie ich, wenn ich das device kopiert habe, nur
das package davon löschen kann?

Kannst du mir vielleicht eine schritt für schritt Anleitung geben?

Das wär nett!

Achja, was anderes!
Ist es eigentlich möglich, aus einem Design (Schaltplan + Board)
verwendete Bauteile zu "extrahieren" und diese dann einer neuen
Library hinzuzufügen? Hab gehört, dass das funktionieren soll, bin aber
nicht sicher...

DANKE!!

Autor: hans Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das heißt, die Package Variante löschen geht schon,aber dann existiert
ja das Bauteil als Device und nicht das Symbol alleine...

Autor: René König (king)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Nun, ich wüsste nciht, wie ich, wenn ich das device kopiert habe,
> nur das package davon löschen kann?

HELP REMOVE

> Ist es eigentlich möglich, aus einem Design (Schaltplan + Board)
> verwendete Bauteile zu "extrahieren" und diese dann einer neuen
> Library hinzuzufügen?

Per ULP, z.B. mit exp-project-lbr.ulp

Autor: Remo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich exportiere mir die Lib, aus der ich kopieren will in eine
Script Datei *.scr.
Dann lösch ich im Ascii-Editor alles raus, was ich nicht übernehmen
will. Das geht recht einfach, weil alle Bestandteile wie Symbols,
Packages, Devices sauber getrennt sind. Eventuell noch in dem
verbleibenden Fragment gewünsche Umbenennungen vornehmen und dann die
Script Datei in der Ziel Lib importieren.

Ist vielleicht nicht der letzte Anwendungsschrei, geht aber sehr sauber
und eigentlich auch schnell.

ciao
Remo

Autor: hans Klaus (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich dieses ULP ausführe, und auf Collect Data klicke, bricht er
nach einiger Zeit ab mit dem Fehler: Siehe Bild im Anhang!

Autor: René König (king)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die aktuelle Eagle-Version ist 4.15, nicht 4.13. Verwende mindestens das
ULP der aktuellen Version.

Autor: hans Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey, super! Ich habe mir das aktuelle ULP geholt und mit dem
funktioniert das tatsächlich...das hilft schon mal ein gutes Stück
weiter...

Wenn ich jetzt ncoh rausfinde, wie und ob man im Egale Tastenkürzel
definieren kann (wäre beim Layouten extrem hilfreich), dann könnte das
noch interessant werden :-))

@Remo: Auch eine interessante Methode. Werd ich mir morgen mal zu
Gemüte führen :-)

Autor: René König (king)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wenn ich jetzt ncoh rausfinde, wie und ob man im Egale Tastenkürzel
> definieren kann

HELP ASSIGN
:-)

Autor: Manfred Schäfer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Hans klaus

Ein Bauteil in Eagle besteht aus drei Bestandteilen. Dem Symbol, das
ist das Bild das du im Schaltplaneditor siehst, dem Package, das ist
die Gehäusebeschreibung und dem Device. Das Device beschreibt die
Verknüpfung zwischen dem Symbol und dem Package. In deinem Fall hättest
du zuerst das Device löschen müssen, Symbol und Package befinden sich
noch in der Bibliothek. Dann das Package löschen. Anders herum geht es
nicht, da ja das Package vom Device benutzt wird.

Aber du hast ja eine elegantere Möglichkeit gefunden.

Gruß

Manfred

Autor: hans Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles klar! Danke für den Tipp!

Tja, ohne nun hefiteg Diskussionsrunden auslösen zu wollen, werde ich
nun dennoch eine Frage stellen.

Und zwar habe ich nun w(wie ihr alle merkt) meine ersten zaghaften
Schritte mit egale gemacht. Und naja, so komfortabel ist das Programm
dann doch wieder nicht. Das Library Management geht z.B.: in PCAD
wesentlich einfacher ganz zu schweigen von Protel..

Protel an sich gibt es nun ja nicht mehr, es heißt nun Altium Designer
und das Toll vereinigt viele Mächtige Werkzeuge zum Schlatugsdesign bzw
Entwurf.

Nun möchte ich eure Meinung zu diesem Thema hören. Natürlich ist die
Bedienung von Altium´s Software komplizierter, aber wenn man sich damit
einarbeitet, hat man , denke ich zumindest, wesentlich mehr in der
Hand.

Nur um Simulationen zu nennen. Mit Egale it es nicht möglich(soviel ich
weiß) irgendwelche Simulationen bezüglich EMV oder ähnlichem zu machen.
Dies kann allerdings äußerst nützlich sein...

Darum die Frage:
1.)Haltet ihr einen Umstieg auf Altium Designer für sinnvoll?
2.)Welches Design Tool verwendet ihr und aus welchen Gründen??

LG und ein schönes Wochenende!!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.